Please select Into the mobile phone version | Continue to access the computer ver.
Controller 2 bound to O3 AU but no stick input
4732 14 2023-3-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
tkloubek
lvl.1
Flight distance : 2892871 ft
  • >>>
Czechia
Offline

Hello, I am using the new DJI Controller 2 and an FPV drone with DJI O3 Air Unit with DJI Goggles V2. I Updated all three to the latest firmware.
DJI O3 AU: V01.02.0000
DJI Controller 2: V02.00.0500
DJI Goggles V2: V01.06.0000

I was able to bind all three together, but the Aur Unit is recieving no stick input. The only button that works is the record button. I checked in Betaflight and the ports are set up correctly, but there is no stick input whatsoever. Am I using the correct firmware, or is there some sort of setting that I have wrong? Thanks!
2023-3-19
Use props
HDPS
First Officer
Flight distance : 44957 ft
  • >>>
United States
Offline

I had the same problem, Betaflight all correct, gave up trying

I just added a $30 R-XSR micro receiver to drone  and using a TX16S Mark II Max Radio Controller, it is actually safer. When using the O3 Air Unit, if you lose video feed, you also lose control of aircraft.
2023-3-19
Use props
djiuser_LsAudeekKkCJ
lvl.3
Flight distance : 28615 ft
Canada
Offline

Check out that RC2 and BTFL configured the same SBUS mode (Normal or FAST):
In goggles check Controller SBUS setting
In Betaflight CLI run "get sbus_baud_fast"

Make sure the settings match
2023-3-19
Use props
tkloubek
lvl.1
Flight distance : 2892871 ft
  • >>>
Czechia
Offline

djiuser_LsAudeekKkCJ Posted at 3-19 12:39
Check out that RC2 and BTFL configured the same SBUS mode (Normal or FAST):
In goggles check Controller SBUS setting
In Betaflight CLI run "get sbus_baud_fast"

Oh yes they are… Thanks though!
2023-3-19
Use props
HDPS
First Officer
Flight distance : 44957 ft
  • >>>
United States
Offline

djiuser_LsAudeekKkCJ Posted at 3-19 12:39
Check out that RC2 and BTFL configured the same SBUS mode (Normal or FAST):
In goggles check Controller SBUS setting
In Betaflight CLI run "get sbus_baud_fast"

Had done all that, wasted hours searching, YouTube videos...nothing worked. Will never get a PNP drone  again, get it with dedicated receiver besides O3.  It may be a Firmware issue even that all 3 were bind OK but decided to be safer with a controller and receiver aside O3, worked well.

DJI O3 Air Unit

DJI O3 Air Unit
ACRO.jpg
2023-3-19
Use props
Tadango
Second Officer
Flight distance : 232359 ft
Netherlands
Offline

I had the same issue on my O3 suddenly and it looks like the ribbon cable inside the Air unit was not connected correctly. This might be the case is Telemetry and SBUS out are not working
2023-3-20
Use props
djiuser_LzuDBQxEa38Y
lvl.2

United Kingdom
Offline

Found the problem why is not showing any inputs, if you're on 4.4 betaflight, check firmware is the protocol chosen sbus ( I had just on crsf) re-install firmware, in receiver tab serial-sbus. Now I had some problems with air unit wires with  plug n play, I just solder them
2023-6-6
Use props
Didichung
lvl.2
Flight distance : 395148 ft
Indonesia
Offline

Has anyone been able to solve this problem?
2023-9-28
Use props
WeatherB
lvl.4
Canada
Offline

Check out the troubleshooting steps in this video. It was the SBUS Baud Fast for me.

2023-10-1
Use props
Charles Bulgari
lvl.2

United States
Offline

Didichung Posted at 2023-9-28 06:57
Has anyone been able to solve this problem?

I have, most likely all you need to do is unscrew the air unit from the bottom and see if that helps.  This happened to me and I think it was due to the 03 connector wire coming out of the designated grove in the bottom of frame and gets squeezed underneath air unit causing some wires to not send good signals.. I had the same problem after installing a new antenna.  Just unscrew the air unit and make sure no wires are getting squeezed underneath then screw back on... that should solve problem!
1-7 16:18
Use props
djiuser_BlYYlUJeb3Xj
lvl.1

United States
Offline

Hello, I have same problem made all settings,  but the sticks do not work in the betaflight app and do not launch the drone.
1-12 22:33
Use props
djiuser_kwFmfXYJjJId
lvl.2

United Kingdom
Offline

Same for me , multiple hours wasted. Jeez i bought this to have easy plugs and play. What a nonsense
1-19 11:23
Use props
djiuser_JlYo17V3LLMn
New

United States
Offline

A lot of the videos that I watched show setting up the O3 Air Unit on 1 UART, I'm pretty sure this is because they are not using the DJI Controller 2 and will be setting up a seperate receiver. For my SpeedyBee F405 V4 flight controller, next to the DJI Connector it shows UART 1 for OSD, and UART 2 for receiver. If you don't set up your receiver on UART 2 the DJI Controller 2 won't connect. Once I switched to 2 UARTs for the O3, everything started working. Also checked SBUS baud Fast in DJI Integra goggles, which was not correct by default. Hope that helps someone.
2-4 10:59
Use props
NINIVAGGI DOMENICO
New

Italy
Offline

Salve sto avendo problemi con il cavo dei Goggles però non lo trovo in commercio
2-5 09:11
Use props
NINIVAGGI DOMENICO
New

Italy
Offline

Salve sto avendo problemi con il cavo dei Goggles però non lo trovo in commercio
2-5 09:11
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules