Please select Into the mobile phone version | Continue to access the computer ver.
TB47 fully charged but Inspire will not activate
1070 8 2015-8-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
KenRobbins3D
lvl.1

United States
Offline

Hello,

Just received my Inspire two days ago. I have the TB47 and purchased a second TB47. I charged everything right out of the case. I have then updated all firmware. However, one TB47 battery now shows all leds green when the button is pressed once, but when attempting to power up Inspire it just makes a clicking sound and turns off. I have tried searching the forum for any other TB47 issues, but I do not see this one. Has the firmware update "bricked" this battery? It is new right out of the case. The second battery shows perfect in the DJI Go app, with 00:00 flight time and 0 recharges. The other should show this as well but it will not power up. Any thoughts or suggestions? I have viewed the threads about taking off the top and unplugging the board to force a reset. I am hesitant to do this since the battery has been in my possession only two days. Not even off the ground yet.

Thanks.
2015-8-28
Use props
KenRobbins3D
lvl.1

United States
Offline

A Post Script,

The TB47 button when pressed once shows all four leds green. When I hold down the power button the second time it will stay on for a moment. I then tried connecting the controller charger and connecting to the TB47. It powers up and appears that it is going to work, then powers off. It just will not stay on.
2015-8-28
Use props
w1der
Second Officer

Sweden
Offline

My thought is ... send that battery back ... even if you get it to work I wouldn´t use it ... that is not normal behavior!
2015-8-29
Use props
KenRobbins3D
lvl.1

United States
Offline

I have contacted support and sales support. I am requesting an exchange. When I placed my order I also added a set of replacement props. I always order replacements for all of my drones. They sent me an Inspire with the new 1345s props, but the old 1345 set as replacement! In the same box no less. Useless replacement props. I have already started a refund on those old props and they sent me an email and said to use the attached shipping label to return, but no label attached to the email. I have yet to receive a reply on that issue. It is not looking too promising.
2015-8-29
Use props
w1der
Second Officer

Sweden
Offline

Good luck with that ...
2015-8-29
Use props
Tournique80
lvl.2

Mexico
Offline

I have the same problem with a new battery.
2015-9-2
Use props
KenRobbins3D
lvl.1

United States
Offline

Tournique80 Posted at 2015-9-3 14:21
I have the same problem with a new battery.

Mine are also brand new out of the box batteries. Firmware update killed one. DJI sent me an RMA and shipping label for return. We will see. At least 3-4 weeks they say. I find this unacceptable but what can you do? I think the fix that some are doing on their own will work, but I don't want to take the chance with a brand new battery. My Inspire has not even left the ground!
2015-9-6
Use props
RichJ53
Captain
Flight distance : 1837356 ft
  • >>>
United States
Offline

do you have the latest firmware installed on the battery?

Rich
2015-9-6
Use props
dgmultimedia
lvl.3
Flight distance : 216526 ft
United Kingdom
Offline

Did you re-run the FIRMWARE update using EACH battery???

There are firmware components that are loaded to the communications board in EACH battery - if the firmware does not match it won't work...

clear the .txt files from the MicroSD card leaving only the Firmware file and put it back in the camera.
Load the second battery and turn it on - LEAVE THE CONTROLLER OFF...
It might clear the problem - it can sometimes take a couple of attempts to do the update...
2015-9-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules