Please select Into the mobile phone version | Continue to access the computer ver.
Upgrade The firmware of The Ronin and now it does not work
838 1 2015-9-1
Uploading and Loding Picture ...(0/1)
o(^-^)o
Winslow
New

United States
Offline

I just can't believe this. I upgraded the firmware IMU to 3.0 and the GCU to 1.0 , current version to 1.8 and the Ronin does not work at all now. It worked initially with moderate noise.  The reason why I did this was because I purchased the thumb controller and it was not working. I thought that if I upgraded to the most latest version that the thumb controller would work. Well nothing works now. I also looked at this forum and it states that once you upgrade , you should then pushed the default button. This did not work either. I also called DJi today from 2pm - 6pm eastern time and could not get a live person. I really need help because I have a job coming up in 2 days and need the Ronin to work. If any of you out there could help me I would truly appreciate it. If I can't get this matter solve then the Ronin may have to sent back. Thanks
2015-9-1
Use props
DJI-Cathy
Second Officer

Hong Kong
Offline

Please downgrade your ronin with Ronin assistant software v1.4 to see if it works again
If it goes back to work, then you can upgrade it again,  the latest version are GCU1.0, IMU3.0, make sure you upgrade both
2015-9-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules