Please select Into the mobile phone version | Continue to access the computer ver.
Don`t have image in my Iphone with Phantom 2+
12Next >
6572 56 2014-9-22
Uploading and Loding Picture ...(0/1)
o(^-^)o
gbfurtado
lvl.1
Brazil
Offline

Hi,
I don`t know if you guys can help me. I`m turning everything on but the image in the Iphone app is not showing on the screen. Shows all data but no image. I can take photos and videos and see after but no live image.
Tks
Gui
2014-9-22
Use props
hd_ultra
lvl.4

United States
Offline

You should have a live image. Try restarting the phone and the phantom. And reconnect to the phantom.
2014-9-22
Use props
gbfurtado
lvl.1
Brazil
Offline

hd_ultra@msn.co Posted at 2014-9-23 06:57
You should have a live image. Try restarting the phone and the phantom. And reconnect to the phantom ...

Yes, I tried. Everything is working, the Gimball, all the controls but black image. I thought it was a camera problem but if i took a picturem it shows if i go to the album>
2014-9-22
Use props
hd_ultra
lvl.4

United States
Offline

Ok turn everything off.

Startup the
WiFi on 1st
Radio Controller 2nd
Turn on the phantom 3rd
Connect phone to the phantom WI Fi 4th
Open the app it should show that the phone is connected to the camera.
Settings: Check that you have turned on FPV mode. Go back into the camera menu and see if you can see a live image.
Let us know if this has worked.
https://www.youtube.com/channel/UC6fqGgjRbBF83v1MF-TqfHA






2014-9-22
Use props
gbfurtado
lvl.1
Brazil
Offline

Nope,
it shows everything and no image. Its showing as the iphone is loading. That little circle that appears when you turn your iphone off.
2014-9-22
Use props
hd_ultra
lvl.4

United States
Offline

gbfurtado Posted at 2014-9-23 09:54
Nope,
it shows everything and no image. Its showing as the iphone is loading. That little circle tha ...

Did you turn on the FPV MODE
2014-9-22
Use props
gbfurtado
lvl.1
Brazil
Offline

Yes. Turn on and nothing!!
2014-9-23
Use props
hd_ultra
lvl.4

United States
Offline

GB,
The only thing I think of trying is to reinstall the app on the phone. Other than that I'm at a loss. Try that and if it's still not working, may someone else here can help. Or try to contact technical support. Hope you can get it going. Good Luck !
2014-9-23
Use props
T J Gilbert
Second Officer
Flight distance : 74659 ft
United States
Offline

hd_ultra@msn.co Posted at 2014-9-23 10:24
Did you turn on the FPV MODE

I don't understand why you feel FPV MODE needs to be turned on.
It merely locks the camera in a forward direction instead of being controlled by the IMU.
As far as I know, the camera works showing live image in either FPV or stabilized mode.
Maybe gbfurtado should try a reduced fps on the preview quality...

And I have no idea how my post jumped up to the top under the original question???
FPV 1.png
FPV 2.png
Preview 1.png
Preview 2.png
2014-9-23
Use props
hd_ultra
lvl.4

United States
Offline

I was trying to think of ways to help the man. I was thinking maybe FPV mode had something to do with it. Thanks for the input.

So he is saying go into your Setting, Go to Preview Quality and the check 320x240 15 fps  or   640x480 fps. It's worth a try.
2014-9-23
Use props
T J Gilbert
Second Officer
Flight distance : 74659 ft
United States
Offline

hd_ultra@msn.co Posted at 2014-9-23 21:21
I was trying to think of ways to help the man. I was thinking maybe FPV mode had something to do wit ...

The higher res and fps settings are the cause for latency.
He may have preview set so high that his latency is permanent...
2014-9-23
Use props
gbfurtado
lvl.1
Brazil
Offline

IMG_3060.PNG
2014-9-23
Use props
gbfurtado
lvl.1
Brazil
Offline

THATS MY IPHONE IMAGE ALWAYS. TKS TO ALL YOU GUYS BUT STILL THE SAME!!
2014-9-23
Use props
webstereo
New

United Kingdom
Offline

This is exactly the issue I had before the ribbon cable completely broke. I wonder if your ribbon cable is damaged.
2014-9-23
Use props
gbfurtado
lvl.1
Brazil
Offline

webstereo@mac.c Posted at 2014-9-24 15:22
This is exactly the issue I had before the ribbon cable completely broke. I wonder if your ribbon ca ...

Whays the Ribbon cable?
2014-9-24
Use props
hd_ultra
lvl.4

United States
Offline

Thats the only thing left in my mind is to check all the wire connections and ribbon cables for damage or defects.
I hope you figure it out.
2014-9-24
Use props
gbfurtado
lvl.1
Brazil
Offline

hd_ultra@msn.co Posted at 2014-9-24 22:12
Thats the only thing left in my mind is to check all the wire connections and ribbon cables for dama ...

Ok. How am i can check this??
One more question?
My camera is working fine. Everything!! Just not live image. This will not probably be wireless connection?
2014-9-24
Use props
hd_ultra
lvl.4

United States
Offline

Check the ribbon cables for cracks very carefully. Make sure that all the wires (connectors) are in place.
If all fails you could open up the shell and make sure all the wires from the camera are firmly in place.

It could be that the Wifi Module is not getting the signal. And this may be a dealer repair or DJI.

At this point I think I would call your dealer and or Technical Support.

http://www.dji.com/support

Hopefully a DJI Rep could better assist you on here also.
2014-9-24
Use props
jprpires
lvl.2

Portugal
Offline

gbfurtado Posted at 2014-9-25 07:38
Ok. How am i can check this??
One more question?
My camera is working fine. Everything!! Just not  ...

Hy.
I am having an issue with a Huawei android phone, in portugal, and solved the problem setting the preview in the app to 320 at 30 fps. It's strange, because we would think it would work better with less fps, causing less weight to the wi fi band, right?
Good luck.
2014-9-25
Use props
bob
New

United States
Offline

I am having the SAME EXACT PROBLEM. Everything was working fine until I did the 3.0.6 upgrade. I lost the FPV feed.  Have all the functions of the camera except have a black screen on my Nexus7, iPad  and iPhone. I made sure all by apps were up-to-date etc. Contacted RcDepot where I purchased the copter and they told me to rebind the camera which I did.. still nothing.  Reverted back to previous firmware version, still nothing. Called DJI customer service and was on hold for over an hour and hung up. DJI customer service has much to be desired.  Called back RcDepot they told me to contact DJI.. what a run-a-round! Then I go online and find that there are MANY people with the same problem and the list is growing everyday!  Maybe a class action lawsuit is in order to get DJI to fix this problem. Firmware upgrade turned my V2+ into a useless piece of crap that I have invested over $2K into.
2014-9-25
Use props
gbfurtado
lvl.1
Brazil
Offline

I don`t understand. You send an email to DJI and they come back to you as call DJI costumer. Have you guys try to call them?? If i knew the assistance was so bad, i would never bought this!! The worst is that you see a lot of complain in there website and they don`t do nothing!!
2014-9-25
Use props
hd_ultra
lvl.4

United States
Offline

I just think that they are very overwhelmed by the product popularity. And did not plan on having this kind of technical support issues.
Simply I don't think they can keep up with the call volume. I had called there one time and was thru within 15min. With my problem fixed.
I had a new Phantom within in 2 days. Thus the reason for this forum is to resolve their customer issues and develop new ideas.

You guys seem to be have probably a firmware issue. There is a Youtube video the will show you how to do a hard reset on your firmware if all fails. I'll check and see if I can find it again and post it.
How to do a Hard Reset FIRMWARE:


2014-9-25
Use props
bob
New

United States
Offline

However if you open the body of the copter you void the warranty..
2014-9-26
Use props
hd_ultra
lvl.4

United States
Offline

bob@bcervelli.c Posted at 2014-9-27 06:50
However if you open the body of the copter you void the warranty..

You are correct Bob. You also loose it if you crash it on the ground. LOL
2014-9-26
Use props
bob
New

United States
Offline

Still no response from DJI on this problem and now we have three more people with the same problem on the DJI forums alone.

I even went to extent of posting something on DJI's Facebook page about the problem and looks like they deleted the post.

They are in for a rude awakening as I am in the process of contacting all the customers with this problem and rounding them up for a class action lawsuit which I will gladly pay for. When a company sells a faulty product and they totally ignore the customer complaints and they offer no solutions.. they deserve to get sued.. plain and simple.

These are not cheap toys.. many  of us have $1500-200K+ plus tied into this product and for DJI to snub us.???  Not right!
2014-9-28
Use props
FromAdronesEye
Second Officer
Flight distance : 93146 ft
Dominican Republic
Offline

Im my opinion I have had some contact with support over email and they have respond me every time with 12 hours! but i have read a lot of the call back and stuff
2014-9-28
Use props
quadrofilmning
New

Sweden
Offline

I had the same problem after the update but some how i successfully got i to work. I had also problem to connect my Iphone to wifi. But I closed the app and restarted the wifi and phantom many times. And now it works for me. I charged the wifiextender in the meantime.
Sorry for my english
2014-9-28
Use props
hd_ultra
lvl.4

United States
Offline

jprpires@gmail. Posted at 2014-9-26 05:59
Hy.
I am having an issue with a Huawei android phone, in portugal, and solved the problem setting  ...

It does work better with a lower FPS. there is a lot of less lag.
2014-9-28
Use props
hd_ultra
lvl.4

United States
Offline

Solution: Some Android devices do not allow for both a Wi-Fi connection and a mobile data connection at the same time. When trying to connect to the Phantom 2 Vision+ Wi-Fi network, most devices will check whether an Internet connectionhas a certain Wi-Fi setting enabled, e.g. Auto network switch or Test for Internet connection. If no Internet connectionis found because the Phantom 2 Vision+ creates a non-routable connection it will drop the Phantom 2 Vision+ Wi-Fi network connection and scan for the next available connection. Example: For the Samsung Note 3, carry out thefollowing procedures to solve this issue. Tap Settings -> Wi-Fi, and then tap the “Menu” button. Select “Advanced”then uncheck the “Auto network switch”. You might see a warning that indicates the Internet connection is unstable thismessage can be ignored.
2014-9-28
Use props
joels805
lvl.1
United States
Offline

There is also a very similar thread that I have commented on and that the "solution" above does not work or apply for.  Check it out.  

http://forum.dji.com/forum.php?m ... &page=1#pid2775

2014-9-30
Use props
scottapes
lvl.1

United States
Offline

I have the same problem as well! I am using an iPhone 4. I wonder if that has something to do with it?
2014-10-6
Use props
marioalbu
lvl.1

Australia
Offline

Count me in with the same problem on an Phantom Vision.
I updated my phone to iOS8, and updated the phantom firmware (from stock to latest 3.0.6).
Everything works but no live image, only the Loading/Busy indicator:


* I have resetted the extender and re-bind the camera:


* I have selected lowest preview quality:


* I have re-installed an older version for the software and downgraded to 3.0.4, same results

* I have re-installed 3.0.6, same results

* I have deleted and reinstalled the app multiple times

* I have killed all apps, only DJI running

* I have put the phone on Airplane mode, only allowing WiFi

* I have installed the DJI app on an ipad 3 (iOS8), same results

* I tried on an iPad mini with iOS7 -- same results (people above are saying it's not working on androids as well)

* In the DJI app, I get telemetry information, I can control the camera (rotate it up/down), I can take pictures, I can take videos, I can see the album EVERYTHING BUT SEE LIVE VIDEO  -- here are pictures taken with the camera:



I called the distributor in my country, and basically said to reinstall the app, re-bind camera, restart, etc.

NOTHING WORKS.

And it's not me - there are several forum posts about this already.

I HOPE SOMEONE AT DJI READS THIS, AND AT LEAST ACKNOWLEDGES THIS AS AN ISSUE SO WE KNOW THEY ARE WORKING ON A FIX, OR ARE WE LEFT TO DEAL WITH THIS BY OURSERLVES???

2014-10-7
Use props
DJI-Terry
lvl.3

China
Offline

marioalbu@yahoo Posted at 2014-10-8 15:32
Count me in with the same problem on an Phantom Vision.
I updated my phone to iOS8, and updated the  ...

Hi, Marioalbu, did you try other ios device, such as iphone 5, ipad mini etc? Pls do not use ios8 at the moment since it's recently released and seems has compatibility issue.
2014-10-8
Use props
DJI-Terry
lvl.3

China
Offline

bob@bcervelli.c Posted at 2014-9-28 23:46
Still no response from DJI on this problem and now we have three more people with the same problem o ...

Hi, Bob, if you have any issue with the product, you can contact the nearest service center for help. If it is the product is defect, you can send back for repair.  Let us know if you have any difficulty in contacting them. Thanks.
2014-10-8
Use props
daniel.huang
lvl.2
Flight distance : 233 ft
China
Offline

marioalbu@yahoo Posted at 2014-10-8 15:32
Count me in with the same problem on an Phantom Vision.
I updated my phone to iOS8, and updated the  ...

Dear Sir,
Please contact the nearest support center for service if that's the case. Something is not working inside and please send in your unit for service.
Thank you for your understanding and patience.
2014-10-8
Use props
marioalbu
lvl.1

Australia
Offline

DJI-Terry Posted at 2014-10-8 16:21
Hi, Marioalbu, did you try other ios device, such as iphone 5, ipad mini etc? Pls do not use ios8  ...

Hi,

I tried iPad mini on iOS7 then iPhone5s and iPad3 on iOS8...
Are there any plans for iOS8 soon?

Thanks.
2014-10-8
Use props
marioalbu
lvl.1

Australia
Offline

daniel.huang@dj Posted at 2014-10-8 16:44
Dear Sir,
Please contact the nearest support center for service if that's the case. Something is n ...

I already phoned, and been told to re-bind. I will phone again.
Is there an "official" support center for Australia?

Before doing the software update everything was fine, so I cannot see what is "broken" by doing the software update.
2014-10-8
Use props
DJI-Daniel
lvl.1

China
Offline

marioalbu@yahoo Posted at 2014-10-8 16:48
I already phoned, and been told to re-bind. I will phone again.
Is there an "official" support cen ...

Hi Sir,
If rebind couldn't fix the problem, please send your unit back to service center. There's one in Australia.
EE Hobbies  +61 432554847
ONLY for Phantom series        3 / 6B Railway Ave., Oakleigh, Vic. 3166 Australia       
Please call before sending in.
2014-10-9
Use props
roberr
New

Norway
Offline

Hi! I have/had the same problem here in Norway,lost of connection with camera(freezes),tried to restart everything but nothing happend,then I delete the app from iphone and reinstal the app and the connection was back,I have now also set the preview quality to 320+240 30fps and the connection is longer before it freezes again,I sure it is a App bug in the app that is the problem and hoping on a upgrade from DJI soon.
2014-10-12
Use props
marioalbu
lvl.1

Australia
Offline

DJI-Daniel Posted at 2014-10-9 19:23
Hi Sir,
If rebind couldn't fix the problem, please send your unit back to service center. There's  ...

I have talked again to the service center - but my Vision was purchased more than 1 year ago and it's out of warranty?
How to proceed? I don't want to pay shipping (I don't live in Victoria), then a potentially expensive repair because of something i did not broke.
2014-10-12
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules