Please select Into the mobile phone version | Continue to access the computer ver.
Firmware upgrade Order..
1011 6 2015-9-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
shed14
lvl.3
Flight distance : 6854 ft
Australia
Offline

My P3P is still on old version firmware 1.6..Does the firmware upgrade have to be in order I.e 1.6 to 1.8 to 1.26 etc or can it be go straight from 1.6 to current??????
2015-9-11
Use props
sploodge
Captain
Flight distance : 809350 ft
  • >>>
United Kingdom
Offline


To be safe I would go to 1.3.20 on the P3 and TX first then update the Phantom to 1.4.10
2015-9-11
Use props
shed14
lvl.3
Flight distance : 6854 ft
Australia
Offline

Yep I was leaning that way too.. Big jump from 1.6.. Cheers splooge
2015-9-11
Use props
gaston
New

Canada
Offline

I dont know how to up grade app vis 2.2.0
Aircraft 1.1.9
RC 1.3.20
2015-9-12
Use props
Phantom Help
Captain
Flight distance : 183694 ft
  • >>>
United States
Offline

Install 1.3.2 on your Phantom, remote controller, and batteries. And, then install 1.4 on your Phantom. There is no need to install anything older than 1.3.2.





www.PhantomHelp.com
Find the latest must-haves, fixes, mods, how-tos, guides, and accessories for your Phantom.
Phantoms in stock and ready to ship worldwide! (see availability)

2015-9-12
Use props
shed14
lvl.3
Flight distance : 6854 ft
Australia
Offline

Phantom Help Posted at 2015-9-13 04:50
Install 1.3.2 on your Phantom, remote controller, and batteries. And, then install 1.4 on your Phant ...

thanks for the info..
can i just reconfirm, there is no need for me to do a sequential update.. ie 1.1.6 -1.1.9 -1.2.8..?
your saying i can just go from 1.1.6 straight jump to 1.3.20 and then to 1.4.0010... is this correct?
also what app version needs to be on my iphone when i initially update to 1.3.20?
im currently on 1.20 (dji pilot)
i also have archived versions
2.0.0
2.1.0 and
2.2.0.

cheers and thanks your replies
2015-9-18
Use props
shed14
lvl.3
Flight distance : 6854 ft
Australia
Offline

happy to report the upgrade from 1.1.6 to 1.4.010 went smooth!
did 1.1.6 to 1.3.20
then to 1.4.010.

imu calibration
compass calibration
test flight - 2mt height hover - 10 mt radius flight
everything A-OK!

whats more is that the altimeter is now reading more accurately.
and the visual altimeter is spot on too.. (was inaccurate on 1.1.6)

so props to dji for fixing many bugs.

my advice when upgrading software is be patient.. my update took more than 35 mins to do for some reason , but success in the end. i was tempted to turn off the phantom as i thought it failed but i was just working its magic at a slower pace.

anyways time to charge the batteries and enjoy some flyin..

thanks for all the help
good friends


2015-9-18
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules