Please select Into the mobile phone version | Continue to access the computer ver.
RS4 SDK Control - No Signal via CAN Ports
2878 3 7-5 01:49
Uploading and Loding Picture ...(0/1)
o(^-^)o
kudaaa
lvl.1

France
Offline

Hi everyone,
I recently bought the DJI RS4 and I'm trying to control it through the SDK. However, I'm encountering issues with getting any signal through the ports. I'm hoping someone here can offer some advice or share their experiences.
Setup Details:
  • OS: Linux
  • Adapters Tried (I am connecting adapters using the common jumper wires and dupont connector GND, CANH, and CANL):
    • Canable 2.0 Adapter
    • CANUSB


Commands Used with Canable 2.0:
sudo slcand -o -c -s8 -t hw -S 1000000 /dev/ttyACM0
slcan0 sudo ip link set up slcan0
candump slcan0

Commands Used with CANUSB:
sudo slcand -o -s8 -t hw -S 3000000 /dev/ttyUSB0
sudo ip link set up can0
candump can0

Issue:
Both setups result in no signal being detected (candump is silent).


Additional Observations:
  • The DJI website mentions the "RS" SDK for RS4, but the downloads are for the usual DJI "R" SDK meant for RS2. Could this be an issue?
  • The pin location on the RS4 has moved from the power button area to a different side. I tried various pin configurations but had no luck.

I'm considering exchanging my RS4 for an RS3 to see if that resolves the issue, but before doing so, I wanted to check if anyone here has faced similar problems or has any suggestions.


Questions:
  • Could there be a mistake in my setup or commands?
  • Has anyone successfully used the RS4 with the SDK?
  • Are there known issues with the RS4 SDK or its documentation that I should be aware of?
Any help or advice would be greatly appreciated. Thank you!



Best regards,
Kuda


Screenshot 2024-07-05 at 11.20.10 AM.png
Screenshot 2024-07-05 at 11.12.00 AM.png
7-5 01:49
Use props
kudaaa
lvl.1

France
Offline

Update: after some multimeter stuff I found that for RS4 the pins are reversed. The correct order is showed in the picture

This way the signal is being read with Canable 2.0 Adapter, but not with CANUSB, for some reason.
I was successfully run the following code https://github.com/rileycoyote87/DJI-Ronin-RS2-Log-and-Replay
7-6 06:03
Use props
fkay26
lvl.1
Flight distance : 126194 ft

Turkey
Offline

CanBUS should be terminated with 120 ohms. Tie a 120 ohm resistor between CanH and CanL pins if you have not done it already.
7-16 03:46
Use props
kudaaa
lvl.1

France
Offline

fkay26 Posted at 7-16 03:46
CanBUS should be terminated with 120 ohms. Tie a 120 ohm resistor between CanH and CanL pins if you have not done it already.

Thanks for your response. But the problem got solved. The issue was in the order of pins as mentioned in the second comment. The CAN adapter had the resistor inbuilt
7-16 06:44
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules