Please select Into the mobile phone version | Continue to access the computer ver.
Remote Contoller Firmware Update
1250 10 2015-9-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
paulsheaves
lvl.2
United Arab Emirates
Offline

Hi Guys and Girls,
I am trying to update my phantom to the 1.4.1 version of software.

As I understand it, I have to update to 1.3.2 first as I was on an older version of software.

I have managed to do this with no problems on the phantom. However I am struggling with the controller and haven't started with the batteries (ive never done a battery update before, cross that brudge when it comes!).

The instructions said to try and do it via the dji go app, but because its on an older version it does not support this way of doing it, alas I have to do it the old way.

However I don't have a USB stick converter/adapter that holds an SD card (and inserts using the usb hole) - and so I am wondering how do I update the firmware on the remote, is there a way or do i need a usb stick?

The videos i see on youtube all seem to use the USB stick adapter :-(

Any help on this would be much appreciated.

Paul
2015-9-28
Use props
sploodge
Captain
Flight distance : 809350 ft
  • >>>
United Kingdom
Offline

You can connect the controller to the Phantom using the USB cable that came with the P3.

1: Just have the SD card in the P3 with the 1.3.20 on it
2: Connect the P3 and controller together using the USB cable ( plug it into the mini USB port on the GIMBAL not the front of the P3 ).
3: Power on the RC and it should update like that.
2015-9-28
Use props
paulsheaves
lvl.2
United Arab Emirates
Offline

sploodge Posted at 2015-9-28 14:30
You can connect the controller to the Phantom using the USB cable that came with the P3.

1: Just ha ...

Hi Sploodge,

Thanks for this.

I assume power on both the P3P and the RC to do this... without the P3P on the RC obviously wont do anything...

So i tried with both on, and got slow beeping on phantom - RC remote LED stayed green throughout...

Thoughts?
2015-9-28
Use props
nabesarawak
lvl.3

Malaysia
Offline

Your RC may be already updated to 1.3.2 ? Check your virsion of RC from Dji Go app..  
2015-9-28
Use props
pdani67
lvl.2

Romania
Offline

Hi guys, sorry but I struggle with same..

I made the upgrade of the P3P to 1.4.10
DJI GO app is 2.2.0
RC 1.2.6

The update for the aircraft was done without any issues..
But how do I upgrade the RC and to what version? I can't do it via the app...there is no options for this within the app...
So what firmware version should the RC be at? And how do I do it as I tried to put the bin file with FW 1.3.2 on a USB stick but it doesn't do anything! If I need to connect the RC with aircraft via USB (from gimbal to RC), then I should power both units and wait??? Just want to make sure I do it in the next day as I have a project after that and I need this asap! Please help. Thank you in advance!

Regards,
Danny
2015-9-28
Use props
dji.blitzk
lvl.3

United States
Offline

You have the latest.... for now.
2015-9-28
Use props
CFM01
lvl.3

United Kingdom
Offline

Not sure what you are doing? I tried the usb stick into the controller without success.
However, if you are running the latest app the controller upgrades from the app. This is how I did the upgrade to 1.3.2

Forgot to say you need your RC on, P3P off, RC connected to the pilot app before it will give you the option to upgrade.
2015-9-28
Use props
kevin.noble.mac
New

United States
Offline

pdani67 Posted at 2015-9-28 15:35
Hi guys, sorry but I struggle with same..

I made the upgrade of the P3P to 1.4.10

Danny, did you get this resolved? I have the exact same issue.
2015-10-2
Use props
kevin.noble.mac
New

United States
Offline

pdani67 Posted at 2015-9-28 15:35
Hi guys, sorry but I struggle with same..

I made the upgrade of the P3P to 1.4.10

Danny, did you get this resolved? I have the exact same issue.
2015-10-2
Use props
kevin.noble.mac
New

United States
Offline

Danny, did you get his resolved? I have the exact same issue.
2015-10-2
Use props
kevin.noble.mac
New

United States
Offline

pdani67 Posted at 2015-9-28 15:35
Hi guys, sorry but I struggle with same..

I made the upgrade of the P3P to 1.4.10

Danny, did you get this resolved? I have the exact same issue.
2015-10-2
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules