Please select Into the mobile phone version | Continue to access the computer ver.
Melt Down
1372 7 2015-10-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
henry
lvl.3
Flight distance : 52457 ft
  • >>>
United States
Offline

Hi all,

Tried to fly yesterday and had a tip over.  I gave it full power as always, but this time it tipped.  I thought it must have been a wind gust until today, when I looked closer.

After replacing one propeller, I started the engines and all but one engine started, the forward left.  I took it inside and inspected.  Could not see anything loose so started the engines again.  This time the front left and left would not start.  Today I took the top plate and round plate off and here is what I found:

resizedround.cap.inside3.jpg resizedclose.melted.contacts22.jpg
I did notice that the screw was loose.  Can anyone tell me what the underlying problem might be?  I can solder new connectors, but does this mean I have a more serious problem?  Thanks for any direction you can provide.  Cheers.

2015-10-11
Use props
dennismurry08
Captain
Flight distance : 5948264 ft
  • >>>
United States
Offline

Thanks for the pics...I've not seen this before but will always be checking in the future..
2015-10-11
Use props
ducpeter
Captain
Flight distance : 62175 ft
  • >>>
Germany
Offline

it looks like not the original golden screw,
when it's lose you have an contact resistance and ended up in heat. check your bottom plate and the resistance between your positiv connections
2015-10-17
Use props
henry
lvl.3
Flight distance : 52457 ft
  • >>>
United States
Offline

ducpeter Posted at 2015-10-17 14:32
it looks like not the original golden screw,
when it's lose you have an contact resistance and ende ...

Thank you, sir.  That may be it.  I did not build this one, but I did build another one.  Thanks for the hot tip.
2015-10-17
Use props
dennismurry08
Captain
Flight distance : 5948264 ft
  • >>>
United States
Offline

ducpeter Posted at 2015-10-17 13:32
it looks like not the original golden screw,
when it's lose you have an contact resistance and ende ...

Good catch
2015-10-18
Use props
henry
lvl.3
Flight distance : 52457 ft
  • >>>
United States
Offline

ducpeter Posted at 2015-10-17 13:32
it looks like not the original golden screw,
when it's lose you have an contact resistance and ende ...

Been out of touch for a while but you are dead right on the screw.  I bought 2 S900s a while back, one was built for me and I built the 2nd one copying the first.  This was the one that the distributor built.

I cleaned the connectors, tightened them all down and tested; all engines are okay.  Any idea where I can get a replacement cover for the bottom plate?
2015-11-1
Use props
SFOS900
lvl.1

United States
Offline

One thing I did right away I removed the shrink tubing and soldered all the connections.

While the screw is wrong it might be the only fault here..... I DO NOT LIKE crimped wires they always will cause hot spots

Funny the S900 screw kit has a special key to tighten those screws.
2015-12-29
Use props
jteeple
lvl.3

Offline

I have a spare damaged bottom plate (broken arm pivot mounting point) but all electrical components are 100 percent PM me if your interested
2016-4-20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules