Please select Into the mobile phone version | Continue to access the computer ver.
Why Android 4.1?
469 0 2015-11-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
John Osmo
lvl.2
United Kingdom
Offline

I finally received my OSMO today (10the Nov) and was dead excited to jig things up for a test run. I have an old Sony Ericsson Xperia Arc LT15i which is still on Android 2.3.4 (Gingerbread I think). When I attempted to download the DJI Go app I realised that app requires at least Android 4.1. OK. I may have just come back to planet Earth from Mars but let's face it, my Xperia Arc isn't all that old? Why on earth have the developers chosen Android version 4 to compile the app as that would cut out a great number of decent Android oldies out there from using the app! This probably explains why there were so many one star against the app. As a developer, I am not convinced that the app requires Android 4 to do what it is designed to do. Come on DJI, you can do a whole lot better than that.

As Sony does not think that my Xperia Arc warrants an OS update, I now have to do it manually. Duh!

2015-11-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules