Please select Into the mobile phone version | Continue to access the computer ver.
GPS on device not recognized (Follow Me)
12Next >
7724 66 2015-11-27
Uploading and Loding Picture ...(0/1)
o(^-^)o
ARCTiC
lvl.1
Flight distance : 190 ft
Spain
Offline

I tried to use the Follow Me Mode on my P3 PRO for the first time yesterday, but then i noticed a RED error pop-ing on the DJI GO app, telling me that the GPS on the device is not found and cannot integrate IMU data. The P3 stays in position then, without following me.

I own a Dual boot Android/Windows tablet with a GPS receiver in Adroid 5.x mode, and the GPS is ON (in high precision mode), I had enough satellite in view and I tested the google map to verify that my position was correctly read.


It's pretty like the DJI GO app doesn't recognize the GPS I have aboard. Analyzing the flight log I didn't found much than the obvious:


P10m 07s58.1 ft34 ftTipEnter Follow Me mode.__Exit F-Mode to end Intelligent Navigation Modes.
Q10m 07s58.1 ft35 ftModeMode changed to 25
R10m 07s58.1 ft35 ftWarningNo sensor is found on the mobile device. Cannot integrate IMU data.



Any idea? Others functions are working fine, the app is smooth and I'm not having any other issue apart this.


Link to my tablet: http://www.e-tab.it/e-tab-3g-3/
It should be a rebranded version of the TECLAST X98 AIR II.


2015-11-27
Use props
nchua2009
lvl.1
  • >>>
United States
Offline

I have the same issue with my galaxy tab 4 4G 8.0 (wifi ON) running Android 5.1. Interestingly, the follow-me mode works with my galaxy s4 (wifi ON). Not sure what's going on but I suspect it's a compatibility issue - although that would make little sense since both units have built-in, working GPS?  Let's let DJI give a definitive answer....
2015-11-27
Use props
ARCTiC
lvl.1
Flight distance : 190 ft
Spain
Offline

It would be a shame, since i had already two tablets without the GPS, and i bought this one with GPS specifically to use with the Phantom!
2015-11-28
Use props
daniel.distasio
lvl.1
Uruguay
Offline

I have the same issue with my Galaxy Tab3.  Android version 4.4.2   Model SM T311  8"

Phantom 3 Standard
2015-11-29
Use props
ARCTiC
lvl.1
Flight distance : 190 ft
Italy
Offline

When you say you're having the same issue, it is exactly the one described in the first post, including the error message? (on the device it was something like: "..cannot stream the data..", I don't remember atm)? I'm asking to be sure that it is a firmware bug then (it doesn't recognize that particular type of GPS) and not something else.
Thanks.
2015-11-29
Use props
DJI-Patrick
Captain

Hong Kong
Offline

Hi ,
I'm afraid your device may not be compatible with the APP . Please try another device ! Thank you !
2015-11-29
Use props
Dipolo
lvl.1
United States
Offline

ARCTiC Posted at 2015-11-30 02:10
When you say you're having the same issue, it is exactly the one described in the first post, includ ...

A mi también me aparece un mensaje de error en rojo que dice: "The GPS on the device is not found and cannot integrate IMU data". El Phantom 3 queda quieto en su lugar y no se inicia el "FOLLOW ME"
2015-11-30
Use props
Dipolo
lvl.1
United States
Offline

ARCTiC Posted at 2015-11-30 02:10
When you say you're having the same issue, it is exactly the one described in the first post, includ ...

Creo que el problema radica en la compatibiliad de tu tablet y de mi tablet con el Phantom 3
2015-11-30
Use props
ARCTiC
lvl.1
Flight distance : 190 ft
Italy
Offline

DJI-Patrick Posted at 2015-11-30 08:14
Hi ,
I'm afraid your device may not be compatible with the APP . Please try another device ! Thank y ...

Actually it's quite the opposite: it's your APP to not be compatible with those devices , including a common one apparently (Galaxy Tab 3).
The GPS on those devices is recognized by every Android app, except yours, so it's clearly a software problem, rather than a hardware issue.

My question is: if your app is having trouble to recognize the GPS on some device, what about correcting the bugs in your software instead of suggesting people to buy another device that have costed to me 250€ just to be used with your hardware?
Should we put our devices in the trash bin, and buy some others, because you couldn't check and fix your app.. or what?

Thank you.
2015-12-2
Use props
Dipolo
lvl.1
United States
Offline

ARCTiC Posted at 2015-12-2 22:39
Actually it's quite the opposite: it's your APP to not be compatible with those devices , includin ...

ARCTIC, I have an outstanding ticket with Technical Support about this issue. (3 days ago)
I own a Galaxy Tab3. Android version 4.4.2 Model SM T311 8" and the GPS is ON (in high precision mode too).
I'm waiting for de answer.
2015-12-3
Use props
ARCTiC
lvl.1
Flight distance : 190 ft
United Kingdom
Offline

Dipolo Posted at 2015-12-3 15:45
ARCTIC, I have an outstanding ticket with Technical Support about this issue. (3 days ago)
I own a ...

Thank you, let me know what they will reply please.
2015-12-4
Use props
garyberg
lvl.2
Flight distance : 2372530 ft
United States
Offline

I'm having the exact same problem as the OP, using a Samsung Galaxy Tab A with a P3 Pro.  Follow Me worked fine on 1.4, has quit working on 1.5.

Sorry for the crappy photo of my screen, but you can see it's telling me I have a strong GPS signal from the device.

2015-12-4
Use props
ARCTiC
lvl.1
Flight distance : 190 ft
Italy
Offline

DJI could you please recognize the bug (it worked in 1.4), as you can see it even recognize the GPS on the device reporting a "strong signal", and tell us when it will be fixed please?
2015-12-5
Use props
snatsios
lvl.1

Greece
Offline

Dear friend that represent DJI you must realize that since we've payed 1400 euro i believe that this racistic behavior in different tablets is wrong. I have the samsung tab E which is the best of kind but unfortunately you do not concluse it in compatible devices and as a result we have to buy another tablet which costs enough money also..... I am very sorry for that tragic marketing plan of yours. It is awfull the most of the time to accept this kind of behavior from you
2015-12-5
Use props
marcoa64nikon
lvl.1

Italy
Offline

garyberg@hotmai Posted at 2015-12-4 23:10
I'm having the exact same problem as the OP, using a Samsung Galaxy Tab A with a P3 Pro.  Follow Me  ...

I have the same problem as in the photo, Lenovo tab2 10 with new Android 5
2015-12-6
Use props
snatsios
lvl.1

Greece
Offline

we can overcome the problems of incompatibility with litchi for dgi app
2015-12-6
Use props
Dipolo
lvl.1
United States
Offline

I have opened a ticket with technical support from a week ago about this issue as you can see in the picture.

I think everyone should do the same

Ticket #227100

Ticket #227100

2015-12-7
Use props
marcoa64nikon
lvl.1

Italy
Offline

snatsios@yahoo. Posted at 2015-12-6 22:35
we can overcome the problems of incompatibility with litchi for dgi app

Today I installed litchi, follow me it worked, but then the program has crashed preventing me automatic landing, djigo no longer works, it works only after clearing litchi.20 euro down the drain, I hope dji fix the bug as soon as possible.Google traslate
2015-12-7
Use props
DJI-Patrick
Captain

Hong Kong
Offline

garyberg@hotmai Posted at 2015-12-5 06:10
I'm having the exact same problem as the OP, using a Samsung Galaxy Tab A with a P3 Pro.  Follow Me  ...

Hi ,Gary
Please post the full screen of that . By the way , please confirm the firmware and APP versions are the latest .  Thank you !
2015-12-7
Use props
marcoa64nikon
lvl.1

Italy
Offline

DJI-Patrick Posted at 2015-12-8 07:55
Hi ,Gary
Please post the full screen of that . By the way , please confirm the firmware and APP ve ...

I confirm latest software and firmware versions
2015-12-7
Use props
DJI-Patrick
Captain

Hong Kong
Offline

marcoa64nikon Posted at 2015-12-8 15:01
I confirm latest software and firmware versions

Hi ,Marcoa and other guys
Sorry about that ! We've noticed that case and  we'll give you an answer as soon as possible .
2015-12-8
Use props
Dipolo
lvl.1
Uruguay
Offline

Hi, this is the answer that I received from the DJI Tech Support:

.....
Dear Daniel,

Thanks for contacting DJI Tech support.

Sorry for the late reply.

For the error message on the APP, which refers to the device GPS is not detected, it's recommended to try a device within our compatibility list:
Please kindly go to the link below for recommended device list:
http://www.dji.com/product/phantom-3/spec

iOS Version v2.1.0. Requires iOS 8.0 or later. Compatible with iPhone 5s, iPhone 6, iPhone 6 Plus, iPad Air, iPad Air Wi-Fi + Cellular, iPad mini 2, iPad mini 2 Wi-Fi + Cellular, iPad Air 2, iPad Air 2 Wi-Fi + Cellular, iPad mini 3, and iPad mini 3 Wi-Fi + Cellular. This app is optimized for iPhone 5s, iPhone 6, and iPhone 6 Plus.
Android Version v2.0.0. Requires Android 4.1.2 or later. Compatible with Samsung tabs 705c, Samsung S6, Samsung S5, Samsung NOTE4, Samsung NOTE3, Google Nexus 9, Google Nexus 7 II, Ascend Mate7, Nubia Z7 mini, SONY Z3 EXPERIA, MI 3, MI PAD.
*Support for additional Android devices available as testing and development continues

Any further question, feel free to contact us.

Best regards,
DJI Tech Support
2015-12-8
Use props
DJI-Patrick
Captain

Hong Kong
Offline

Hello guys ,
Sorry to keep you waiting for so long . I've confirmed that it is a device compatibility problem . But please don't worry about that , we'll get that solved in the next version . And also , we'll clearly indicate that what devices are compatible with the Follow Me function in release note .
2015-12-10
Use props
Dipolo
lvl.1
Uruguay
Offline

DJI-Patrick Posted at 2015-12-10 08:32
Hello guys ,
Sorry to keep you waiting for so long . I've confirmed that it is a device compatibilit ...

Thank you very much Patrick . I look forward to the new version so I can use my tablet.
2015-12-10
Use props
DJI-Patrick
Captain

Hong Kong
Offline

Dipolo Posted at 2015-12-10 20:39
Thank you very much Patrick . I look forward to the new version so I can use my tablet.

Really sorry about that . We'll try our best to make the App being compatible with more devices .
2015-12-10
Use props
garyberg
lvl.2
Flight distance : 2372530 ft
United States
Offline

DJI-Patrick Posted at 2015-12-7 22:55
Hi ,Gary
Please post the full screen of that . By the way , please confirm the firmware and APP ve ...

Sorry for the delay, but here's a slightly better photo.



And the other specs are as follows.

Phantom 3 Pro
DJI Go app 2.4.2
R/C 1.5.70
Firmware 1.5.30

Samsung Galaxy Tab A, model no. SM-T350
Android version 5.0.2

And like I said in my earlier post, Follow Me worked at 1.4, has quit working at 1.5.  Thanks for any help you can give!

2015-12-11
Use props
DJI-Patrick
Captain

Hong Kong
Offline

garyberg@hotmai Posted at 2015-12-12 03:58
Sorry for the delay, but here's a slightly better photo.

Hi , Gary
Please check my former relpy
http://forum.dji.com/forum.php?m ... &fromuid=145141
We'll get this in the next version . Sorry to have brought you inconvenience .
2015-12-12
Use props
libertyvgy
lvl.2
Flight distance : 176486 ft
Germany
Offline

I have a Sony Xperia Z3, and I have a similar problem with the Follow Me mode. My error message is: Device not support GPS, unable to start Follow Me.
I'm upgraded the new version of everything (RC, Cam, Helo), and it's still the same. I hope in the next verison will fix it too.
2015-12-23
Use props
DJI-Patrick
Captain

Hong Kong
Offline

libertyvgy Posted at 2015-12-24 04:46
I have a Sony Xperia Z3, and I have a similar problem with the Follow Me mode. My error message is:  ...

Please kindly try another device . Thank you !
2015-12-23
Use props
coucoutahiti.ho
New

French Polynesia
Offline

ARCTiC Posted at 2015-12-2 05:09
Actually it's quite the opposite: it's your APP to not be compatible with those devices , includin ...

Tout à fait d'accord !
I completely agree with you! The same with my SAMSUNG GALAXY TAB 4 7"
2015-12-30
Use props
astonfranck
New

France
Offline

DJI-Patrick Posted at 2015-12-12 09:09
Hi , Gary
Please check my former relpy
http://forum.dji.com/forum.php?mod=redirect&goto=findpost&p ...

Good afternoon

I'm facing exactly same issue with my Phantom 3 Pro + tablet Samung Galaxy Tab E (SM-T560)
(No sensor found on the mobile device. Cannot integrate IMU data)
That's a pity because I choose the DJI Phantom 3 especially for this "Follow me" function

An idea about when the next firmware or next App update will be released ?

Thanks in advance for your support
Franck
2016-1-10
Use props
efhcruz
lvl.2
Flight distance : 689787 ft
Philippines
Offline

daniel.distasio Posted at 2015-11-29 19:25
I have the same issue with my Galaxy Tab3.  Android version 4.4.2   Model SM T311  8"

Phantom 3 Sta ...

Same issue with mine (Tab 3V). It must be a compatibility issue that the said tablet cannot support compass app somewhat. But when I switch to iPhone, the follow-me & course-lock worked. I assumed its about lacking a sensor that supports compass. If I tried loading a compass app from google play, the compass won't work. Just a hunch...
2016-1-10
Use props
DJI-Patrick
Captain

Hong Kong
Offline

astonfranck Posted at 2016-1-10 20:41
Good afternoon

I'm facing exactly same issue with my Phantom 3 Pro + tablet Samung Galaxy Tab E ( ...

Sorry Franck . We still don't  know when will the next firmware be released .  You can still use your compatible mobile phone for that .
2016-1-10
Use props
astonfranck
New

France
Offline

Thanks Patick for the answer.
With my brand new tablet Samsung Galaxy Tab E, I cannot modify Gains, Yaw:
If I change the value from 0,4 to 0,37 the new value is writen in red and if I close and reopen the window the value is back to 0,4

Additionnal question:  
If I use my iPhone and modify these value, will the value be stored inside the RC ?
If yes, when I will use again my Samsung tablet, will the value be restored to the default value or will I keep the modifications I made with the iPhone ?

kind regards
Franck
2016-1-12
Use props
Brainwerks
lvl.1

Malaysia
Offline

I'm having the same FOLLOW ME mode on my Note 3 but it does not mention anything about GPS. It just wont follow when activated. No problem with other Intelligent Mode. Any idea on how to solve this?
2016-1-12
Use props
micioangelo
New

Italy
Offline

Hello to all
Yesterday I also got me this problem. and the message that appeared to me is
Device not support GPS, unable to start Follow me.
is an app issue, or tablet?
2016-2-10
Use props
Walk
lvl.1
Cyprus
Offline

I have the same problem with Phantom 3 Professional with latest software (1.6) + Samsung GT-I9295 on Android 5.0.1
Please help.
2016-2-16
Use props
libertyvgy
lvl.2
Flight distance : 176486 ft
Hungary
Offline

DJI-Patrick Posted at 2015-12-24 04:50
Please kindly try another device . Thank you !

Okay, then I have to buy another expensive device to control well with every options.
Which one? Which devices compatible fully with Dji Phantom 3? Than I'm looking for that devices to buy a new one too.
2016-2-16
Use props
skytraintovenus
lvl.1

Thailand
Offline

I am getting the same error  with follow me mode.home lock and POI are ok! but I bought the P3 and was looking forward to 'follow me'feature! I even bought a new Sony Experia C5 ULTRA . lollipop 5.1 etc good specs but why the app doesn't work and when we get updates n fix!?? GPS signal is reported STRONG .and google maps ,OSMAND app etc are spot on with my location even without WIFI!
after spending $350 for a new phone I second this: !!

"actually it's quite the opposite: it's your APP to not be compatible with our brand new devices " and not the other way round!

939120_10153534729473174_478051163_o.jpg
2016-3-11
Use props
skytraintovenus
lvl.1

Thailand
Offline

skytraintovenus Posted at 2016-3-11 15:23
I am getting the same error  with follow me mode.home lock and POI are ok! but I bought the P3 and w ...

their answer is lame ! new phone and top specs !they blame it on the phone........ GPS works like a charm! follows every step i make on Maps ,OSMAND app, etc etc...  DJI you need to provide a working app selling your products!here their answer! :

Home lock ,COURSE LOCK, and POI are using the GPS on the aircraft, which is much more stronger than the GPS on the mobile device; and the GPS signal info on the DJI GO App is showing the GPS signal of the aircraft.
While Follow me is using the mobile device's GPS, 'GPS on the device is not found and cannot integrate IMU data.' refers to that the mobile device's GPS signal is not strong enough for positioning; therefore for safety concern, our aircraft would restrict to use this feature.
2016-3-11
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules