Please select Into the mobile phone version | Continue to access the computer ver.
Lightbridge.Samsung Galaxy s5
2123 6 2014-12-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
gregsp71
lvl.2
Australia
Offline

I have been using a Lightbridge with Ipad but I now want to use my Galaxy S5 but cant get video or OSD.(Connection broken) Is this phone compatible?
2014-12-29
Use props
mark97564
Second Officer
Flight distance : 2067749 ft
United States
Offline

How are you using light bridge with an iPad?
2014-12-31
Use props
mark97564
Second Officer
Flight distance : 2067749 ft
United States
Offline

Try using usb  2.0 cord that comes with lightbridge or a different cable it would not work on my note 3 when I used the sub 3.0 cable that came with the phone..  Also you have to enable the developer options in s5's settings and then select developer options and turn on the usb debugging option and then plug it into lightbridge and approve debugging access that pops up on the task bar..  Next time my friend stops by I will use her s5 and see what I've gotta do to make it work with lightbridge if these tips don't help you..  She will be by tomorrow sometime so I will check back here to see your response
2014-12-31
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

Any android device needs debugging turned on. I have verified it works on s3 and above.. Note 2-4. Best device is the ipad air imho. Super smooth on all transmission modes.
2015-1-1
Use props
hhackbarth
lvl.2
Flight distance : 375761 ft
Germany
Offline

I am using the LB ground system with a Galaxy S5. The option to activate developer mode and USB debugging is automatically opened when the LB app is started. Works perfectly fine and smooth on the S5 !
2015-1-1
Use props
gregsp71
lvl.2
Australia
Offline

mark97564@gmail Posted at 2015-1-1 11:41
How are you using light bridge with an iPad?

ios app from here. http://www.dji.com/product/dji-lightbridge/download
2015-1-2
Use props
gregsp71
lvl.2
Australia
Offline

mark97564@gmail Posted at 2015-1-1 11:53
Try using usb  2.0 cord that comes with lightbridge or a different cable it would not work on my not ...

Thanks. Its now working. Sorted itself out in the end.
2015-1-2
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules