Please select Into the mobile phone version | Continue to access the computer ver.
Desperately seeking help after Update Firmware 1.6.0.40 and iOS 9.2
929 3 2016-1-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
swedish_viking6
lvl.1

Offline

Hi there, my first post in this forum regarding my DJI Inspire 1.
Owned the Inspire since March last year and everything has really worked perfectly until last released update 2015-12-22
Runned and worked fine together with ie Google Nexus9, iPad Air(wifi&cell), iPhone 6 and at the moment iPad Air 2 (wifi&cell)

3 days ago, updated both aircraft,rc and App, then following happened:

Can´t get into Camera mode in App, nada happens when tapping Equipment icon in App
Before when connecting the USB-cable, had to confirm/agree on iPad or other devices and up and running few seconds later.

Tried to change USB-lightning cable, no luck. Also done some procedures/tips/hints a couple of times as below which I read on the forum.
Green light on RC and aircraft, OK RF-communication since I tried motors idling (indoor)



Any idea would be very appreciated!! (sorry for my bad english but hope it´s readable)

-----------------------------------------------------
From my Sd-card after update

Delete history success.

Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:08 remo-con disconnect======
Packet: WM610_FW_V01.06.00.40.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2016.01.18 21:51:38 =====================
Packet: WM610_FW_V01.06.00.40.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

-------------------------------------------------

Search and found very nice tips as follows below and tried them all.



"quote from sthuemmel"
Do you have the latest version of the DJI APP Installed on the IPAD? I am running version 2.5 on the RC. The DJI APP installs updates on the Controller, you can no longer use the USB Port for updates. Updates must be done over the internet via the WiFi on your IPAD.
First thing to check.....
If the app says disconnected, that means the transmitter is not communicating with the app and that's because a faulty USB cable or the USB port on the radio. Try using a different USB cable, if you only have one than use the one that you know works from your master controller. After that, the app should recognize your controller. And if not then it has to be a USB port and the radio has a 1yr warranty.
Another possibility is the RC (transmitter) has other issues, you can try this:
I got this from TE
Delete the App from IPAD,  Reset the RC, then reinstall the App.
First - Delete the App
Second - Reset the RC, Please press C1+C2+Shutter (Video on the left side) at the same time, turn off and turn on the RC without releasing these buttons. After resetting, the indicator of RC should be Red.
This procedure resets the output board..
Third -  then reinstall the App on the IPAD. There have been issues updating the APP from one version to another.
Fourth - Connect the IPAD to the RC via the USB.  Launch the DJI APP,  turn on the RC, turn on the Inspire.
Are you connected, are you asked to update?

-------------------------------------------

"Quote from forum by david.p.mann"

I was having exactly the same problem - the new DJI GO app version 2.5.1 was crashing to iPad desktop 10-20 seconds after starting the app.  Deleting the app (and all its data) and reinstalling it did not fix this problem. I then followed recommendations from DJI-Ken to uninstall app, power cycle the iPad and reinstall app from the app store. Tried this three times but app crashed every time I attempted to get in to flight records, which were blank, and enter my DJI login and password - the app would crash before I could finish entering my login password.  Note - at this point the iPad is not connected to the RC and my P3 Pro is turned off.

Here's what I did to get past FIRST app crash issue.  Some of these steps may not be necessary, but I report what worked for me:
1) Uninstall DJI GO app
2) Hard reset the iPad by turning screen on and then holding down the Power button and the home button at the bottom of the iPad screen simultaneously until the screen goes blank and the Apple icon appears. Note: The iPad will take longer than usual to reboot.
3) Reinstall DJI GO app from the appstore
4) Get into DJI GO app and go to Flight Records where you will be asked to input your DJI Login and password.  DO THIS QUICKLY. The app crashed the first time, but I was successful the second time.
5) Once I successfully entered my DJI login and password, I was able to sync all my previously saved Flight Records from the DJI server and the app did not crash for 20 minutes while I was reviewing flight records.
6) My educated guess is that the first app crashing problem is related to difficulties with initially connecting to the DJI server.

HOWEVER, as soon as I tried to get into camera mode, there were two new problems - the app came up showing I was attempting to connect to a "Phantom 3 Standard", which was incorrect, and when I tried to select "Phantom 3 Professional" from the drop down menu - the app froze and then crashed to the iPad desktop. Damn! Not again!

OK - Here's what I did to get past this SECOND app crashing problem and get my system fully functional:

1) I updated P3 Pro firmware from v1.5.0030 to the latest v1.6.0040 firmware.  I  was hoping to avoid this, but gave up and did it thinking this might solve the problem.  If you don't want to upgrade your firmware, you might try steps 2-8 FIRST to see if that solves your app crashing problem when trying to enter camera mode.  If not, then install the latest firmware on your aircraft and all batteries, as I did, and then try steps 2-8, below, again.
2) You must follow the next 4 steps in EXACTLY the order shown as instructed in the DJI GO app "How to Connect" instructions the FIRST time you attempt to connect to your aircraft:
    3) With iPad NOT connected to the Remote Controller, turn ON the Remote Controller.
    4) Next, turn ON your aircraft battery and wait for the green status light on the Remote Controller - this indicates the Remote Controller is linked to the aircraft.
    5) Only then should you connect the USB lightning cable between the Remote Controller and the aircraft (a P3 Pro in my case).
    6) Start the DJI GO app. A few seconds after the "2016 I Will" intro screen pops up the app should come up with a picture of the aircraft that is now connected to the remote controller - in my case, it correctly showed I was connected to my Phantom 3 Pro.  Yeah!

7) Enter Camera mode and ensure you can see live video from the aircraft camera.
8) Be sure to check and change as needed the following settings, which may have gotten reset to defaults:
   - Units of Measurement (feet or meters) under General Settings   
   - Return-to-Home Altitude under MC Settings, then Advanced Settings, then Failsafe Mode
   - Maximum Flight Altitude (in meters) under MC Settings

NOTE - NO MORE APP CRASHES HAVE OCCURRED SINCE SUCCESSFULLY LINKING TO MY AIRCRAFT THE FIRST TIME.

If you have updated your firmware, I also recommend that you perform an IMU Calibration with a cold aircraft sitting on a perfectly level surface, and then do an Auto Gimbal Calibration.

Finally, I can now connect my iPad to the Remote Controller before powering ON the Remote controller and then the P3 Pro and everything still works fine.  I think, for some reason, it is CRITICAL to follow the exact power on/connect sequence shown in the instructions - at least the FIRST time after a new version of DJI GO is installed.

HOPE THIS HELPS OTHERS HAVING APP CRASHING PROBLEMS WITH DJI GO VERSION 2.5.1!


IMG_0792_resize.jpg
2016-1-19
Use props
Starship
Second Officer

United States
Offline

I had this happen..... delete the App from your iPad, and re download and install it.  That fixed mine.
2016-1-19
Use props
swedish_viking6
lvl.1

Offline

I´ve already done this twice from scratch and also step by step like the text I quoted above in my first post. The only thing right now to test is with my Android device
2016-1-19
Use props
swedish_viking6
lvl.1

Sweden
Offline

For some reasons, I've now started to suspect a faulty USB port in RC since IT doesn't matter if an Android or iOS device is connected.
Camera mode refuse to appear in App and also can't verify FW-version in RC. Have re-linked RC with the Inspire a couple of times and are able to fly anyway without a tablet/phone.

Can I be the only one having trouble with USB-port after updating to newest FW?

Please, fire away with thoughts and tips. I'm not a kind of superuser of drones, still at hobby-stage so everything would by appriciated.

Thanks in advance.
2016-1-23
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules