Please select Into the mobile phone version | Continue to access the computer ver.
firmware update RC inspire 1 pro
1924 10 2016-1-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
olivier.madar
lvl.1
Flight distance : 272 ft
  • >>>
France
Offline

i try to be up to date but what a pain !!
After searching a long time why the firmware update of the inspire pro has to be older than the inspire 1, after updating all batteries firmware, now the RC. My master RC of the inspire pro is OK, but i can not do an upgrade for my RC slave (the RC that i bought with my inspire 1, not the one i get with the inspire 1 pro). Both RC have 2.5.1 firmware but the RC for the slave is always asking an update. What can i do ??

2016-1-29
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

The latest Inspire update is 1.6 and for the Pro 1.3, two totally different things. If your Slave RC was on an older update, it may be needed to be updated through the USB port. And 2.5.1 is the app firmware, not the RC firmware.
What firmware does the RC say it is when viewing the abut page in the app?
Put the firmware into a SD card reader and put that in the RC and see if that will update the RC to 1.5.7
2016-1-29
Use props
olivier.madar
lvl.1
Flight distance : 272 ft
  • >>>
France
Offline

Hi Ken,

thank you for your help. The firmware i see in the about page in the application is 1.2.1.03
I tried to upgrade with the usb port of the RC with two different key and the .bin i used with the inspire (1.3). But the upgrade does not start.
2016-1-30
Use props
olivier.madar
lvl.1
Flight distance : 272 ft
  • >>>
France
Offline

Please, help me, tell me how to upgrade the RC !
In the manual, you have to connect to internet, but on the RC, you have to use a stick. I tried to re initialize the RC with a combination of(b+c+left on bottom+record) but it does not do anything.
2016-2-1
Use props
olivier.madar
lvl.1
Flight distance : 272 ft
  • >>>
France
Offline

Here is the .txt i got on the stick :
==========1970.01.01 00:00:13==========
Packet: /mnt/usb/WM610_FC550_FW_V01.03.00.60.bin,
Result: Abort
The firmware on the SD card is identical to or older than the current firmware on the remote controller.

but in the rc, i have 1.2.1.03 and the app tell me to do an upgrade.
2016-2-1
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

olivier.madar Posted at 2016-1-30 22:02
Hi Ken,

thank you for your help. The firmware i see in the about page in the application is 1.2.1.0 ...

If you have ONLY the 1.3 Inspire1 (NOT PRO) firmware BIN file on the SD card and your RC is on 1.2.1.03 then there's no reason why your RC would not update to 1.3.
Your sure your using correct 1.3.
Download from here.
http://www.dji.com/product/inspire-1/info#downloads
2016-2-2
Use props
olivier.madar
lvl.1
Flight distance : 272 ft
  • >>>
France
Offline

Thank you Ken !

I downloaded your file and the upgrade has been done perfectly. Now, the RC want to upgrade on line with 1.5.70. I am doing it.

Olivier
2016-2-8
Use props
fans82955c96
lvl.1
Flight distance : 203 ft
Ghana
Offline

68A351A3_3A3B_4744_8B6E_AEF61963693A I get this error says I don't firmware
IMG_3017.PNG
2016-11-9
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

fans82955c96 Posted at 2016-11-9 04:25
68A351A3_3A3B_4744_8B6E_AEF61963693A I get this error says I don't firmware

You need to make sure the Go app device is hooked up to the RC transmitter and the Go app has a solid wireless Internet connection .

Then go to the "system status" on the go app , and it will tell you there is an update and follow the directions accordingly.  Make sure Aircraft is OFF

donnie  
2016-11-9
Use props
fansb91bf415
New

United Kingdom
Offline

Hello guys, I have a inspire 1 running on the latest firmware v1.10.01.40. I have 2 remotes, one set up as master and the other as slave. They are running on an old firmware. I think it's v1.1? Not the newer 1.3 anyway.  I know I can't update it using the app so I've been trying a few USB sticks using the same file I used to update the drone. The remote won't start the update with the the USB in the back, formatted to fat32 and I've tried mosdos32, both with the update file unpacked or packed (.gzp? And .bin). Now!  I think I need the old update first before I can have the new one OR try a number of different USB sticks.

PLEASE HELP.    I'm going to try the download link above for the suggested RC update, but still, I could do with this being confirmed.      

Can ANYONE tell me where I can download older versions of the firmwares outside of the app secret screen (which I've tried already).  I think I only need the drones firmware to also the remotes but in may be wrong.  Is there a separate file? If so, where can I get it?  
2017-5-12
Use props
Henry M.Y.
First Officer
Flight distance : 10094199 ft
  • >>>
Hong Kong
Offline

fansb91bf415 Posted at 2017-5-12 01:30
Hello guys, I have a inspire 1 running on the latest firmware v1.10.01.40. I have 2 remotes, one set up as master and the other as slave. They are running on an old firmware. I think it's v1.1? Not the newer 1.3 anyway.  I know I can't update it using the app so I've been trying a few USB sticks using the same file I used to update the drone. The remote won't start the update with the the USB in the back, formatted to fat32 and I've tried mosdos32, both with the update file unpacked or packed (.gzp? And .bin). Now!  I think I need the old update first before I can have the new one OR try a number of different USB sticks.

PLEASE HELP.    I'm going to try the download link above for the suggested RC update, but still, I could do with this being confirmed.      

If the firmware version of your remote controller is below v1.2, you should upgrade it to v1.3 (the Inspire 1 v1.3 released by DJI in Aug 3015, NOT the Inspire 1 Pro v1.3 released in Dec 2015) by means of card reader connecting to the USB port of the remote controller. After that, you may upgrade the remote controller firmware to the latest version by means of DJI GO App.

You need to select "Zenmuse X3" from the "SELECT PRODUCT" pull-down manual on the DJI Inspire 1 Download page in order for it to reveal the link "Inspire 1 Firmware v1.3.0.00". It is a zip file, and you have to unzip it, extracting the "WM610_FW_V01.03.00.00.bin" file which shall be copied to the root directory of any SD card formatted in FAT filesystem for upgrading the firmware of the remote controller.

I have copied DJI's link here so that you won't get lost in trying to reveal the downloadable link.

Remember, NEVER turn on the aircraft when you upgrade remote controller firmware. Also NEVER turn on remote controller when you upgrade aircraft firmware. Your aircraft video transmission module can be permanently damaged.

You should upgrade your aircraft firmware before upgrading the remote controller firmware, otherwise your remote controller may not be able to talk to your Inspire 1 to take it out of travel mode.

Fellow Member Donnie had posted detailed instruction and cautions in this post "Tips for loading NEW firmware to SD card and transmitter"

Hope the above are helpful to you.

Henry
2017-5-12
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules