Please select Into the mobile phone version | Continue to access the computer ver.
Trying to use DJI vision with camera app I get Phantom connection broken error?
38683 24 2014-9-26
Uploading and Loding Picture ...(0/1)
o(^-^)o
hoota1231
lvl.1

United States
Offline

I have a fairly new Phantom 2 vision and  Phantom 2 vision + (both have same error) and I have never been able to use either one with the camera DJI vision app with the camera, help please, I had this for over a month and can't get the camera app to work but once for a minute or two. I used a galaxy s3 and s5 phone, samsung tablet, nexus 7 tablet and ipad 2. I did connect once with the s3 and Ipad 2 for a few minutes, then went to  Phantom Connection Broken  error and never connected again. I binded range extender, all new firmware in phantom 2v and camera, using Android 4.4.2 and 4.4.4  in airplane mode, all other wi-fi's put in forget modes, using correct turn on sequences . I get the wi-fi connected on phone to range extender, DJI vision app light is green wi-fi connected but once I hit on camera icon, goes to FPV screen and right away I get Phantom Connection Broken. the wi-fi icon picture of range extender is lite up green, but everything else is grayed out then. I tried all the you tube videos I can find on this, do as they say but cant stay connected??? Or even get a picture.  when I go back to main vision screen it still shows I'm connected to the wi-fi. I live in the country, no powerlines I'm at a loss what to do, no one's been able to help me . DJI just gives me a case number and says to send it in for repair..I know this worked fine as I bought it from someone that used it with no problems. with a Motorla phone but he lives in another state. seems like either i'm missing a setup on Android system  I got to turn off that I can't find?  I did firmware upgrades 2 times also.. Can anyone help me?  (Using 320x240 15 fps, tried them all) * I'm beginning to think it's the new firmware update 3.06 the problem.






2014-9-26
Use props
hd_ultra
lvl.4

United States
Offline

You say you have the green light in the app showing the WiFi Connection.
What is the color of the light on the camera.
                                
                        
               


2014-9-26
Use props
hd_ultra
lvl.4

United States
Offline

Gerry1124 Posted at 2014-9-27 21:05
Is your phone a sprint service model?  Sprint phones and equipment are basically not compatible.   ...

Gerry
Wondering if you could have dropped the other networks. Like on the IOS devices you are allowed to forget the network to avoid connecting to other networks.
2014-9-27
Use props
hoota1231
lvl.1

United States
Offline

hd_ultra@msn.co Posted at 2014-9-27 12:44
You say you have the green light in the app showing the WiFi Connection.
What is the color of the li ...

all lights are green, my s5 is 4.4.4 Verizon, every other device I us Android 4.4.2, but you don't have to have cell phone  service anyway. it can't be something wrong with both phantom's it's got to be in my setup of phone, tablet something on that should be off? or new firmware is the problem on both phantom's..  I don't have a clue anymore what to try..  No one's been able to help me on this in any forum either........  No dealer has no clue.
2014-9-27
Use props
hd_ultra
lvl.4

United States
Offline

Mine has done that on occasion to. I just kept on trying the startup process and it started to work. Do you know anyone that has a Iphone, that you could try to see if it works ?

Try uninstalling the Assistant software and reinstalling. Sometimes the files can become glitched.
Try to reinstall firmware after that.

Firmware upgradable items: (1)Flight Controller (2)GPS (3)5.8G Receiver (4) Main Board (P330CB) (5)Battery (6) Gimbal IMU
2014-9-27
Use props
hoota1231
lvl.1

United States
Offline

But I tried it with a galaxy s3, s5,  nexus 7-2  tablet, galaxy tab S 8.4" the app on all of them can't be bad, it did work when I first got it before I updated firmware once. But two bad phantoms now?   I can't believe it.. Everyone of them connect's wi-fi  but when I try the camera I lose the green icon led  for extender and get connection broken error but when I go back to main screen it show connected to Phantom green led. And all my tab's, phone's show wi=fi connected, somewhere there's got to be in Android I'm missing to shut off or something..Can anyone list how you got to set up android 4.4.2 etc. steps?
2014-9-27
Use props
hoota1231
lvl.1

United States
Offline

hd_ultra@msn.co Posted at 2014-9-27 23:54
Mine has done that on occasion to. I just kept on trying the startup process and it started to work. ...

I upgraded everything I could at DJI Assistance web site, did it over also... like I said can't be 2 bad phantom's all updated. has to be my Android setup something's on shutting connection I think but tried everything I could shut off  on Android?
2014-9-27
Use props
hd_ultra
lvl.4

United States
Offline

But if the file was corrupt and you updated both phantoms, it could be one problem.

I dont know if the android will allow you to shut of networks like the Iphone does. I do it just in case it wants to join other networks while I'm in the air. It is a problem here at the house and connects to the house network. That is why
I turn them off when I'm at home and flying.
2014-9-27
Use props
hoota1231
lvl.1

United States
Offline

Yea!!!!!  After over a month I got it to work !!!! What I found I had to rebind again phantom to DJI vision app, reset range extender bind and I got it working with my galaxy s5, galaxy tab S 8.4 Android 4.4.2 and 4.4.4 . I even put on my Phantom 2 vision, a Vision plus range extender and everything working fine so far, camera records etc. Now, later I going to go out and see if it all continues to work, I'll keep you all posted and thanks for all the help. I don't know what I did wrong before? maybe the order I was doing everything?
2014-9-28
Use props
hd_ultra
lvl.4

United States
Offline

TRY THIS

Solution: Some Android devices do not allow for both a Wi-Fi connection and a mobile data connection at the same time. When trying to connect to the Phantom 2 Vision+ Wi-Fi network, most devices will check whether an Internet connection has a certain Wi-Fi setting enabled, e.g. Auto network switch or Test for Internet connection. If no Internet connection is found because the Phantom 2 Vision+ creates a non-routable connection it will drop the Phantom 2 Vision+ Wi- Fi network connection and scan for the next available connection. Example: For the Samsung Note 3, carry out the following procedures to solve this issue. Tap Settings -> Wi-Fi, and then tap the “Menu” button. Select “Advanced” then uncheck the “Auto network switch”. You might see a warning that indicates the Internet connection is unstable this message can be ignored.
2014-9-28
Use props
hoota1231
lvl.1

United States
Offline

hoota1231@gmail Posted at 2014-9-28 02:28
I upgraded everything I could at DJI Assistance web site, did it over also... like I said can't be ...

this was the answer, I had to bind camera with phantom every time I used it,works OK now.
2014-9-28
Use props
hd_ultra
lvl.4

United States
Offline

hoota1231@gmail Posted at 2014-9-29 11:52
this was the answer, I had to bind camera with phantom every time I used it,works OK now.

Awesome I'm glad it got figured out. Now go and have fun.
2014-9-28
Use props
hoota1231
lvl.1

United States
Offline

Thank's     I did today, cool but I was looking at something in a tree, but to close and hit the balsam tree fell and broke 2 cheap prop guards and it work's fine still..
2014-9-28
Use props
phildanieljohns
lvl.1

United States
Offline

hoota1231@gmail Posted at 2014-9-29 12:23
Thank's     I did today, cool but I was looking at something in a tree, but to close and hit the bal ...

I have a motorola smart phone and its worked fine with my vision 2 for months and now all of a sudden I'm getting Phantom connection broken message ALL the time.  I just read your string, how do I fix this? What does it mean to bind?
2014-11-13
Use props
rare1a1
lvl.2

United States
Offline

I'm having a broken connection feed with my HTC One M8 by Sprint.  Interestingly prior to trying to bind, I was connected with a camera feed but it would keep dropping the connection, even when killing wifi scan and forgetting the home network.  I then reset the range extender and binded the ap with the code one the box and that's where I'm at now - absolutely no camera feed even though I'm connected and both a green light on the app connection as well as the camera. Vision 2+.  *Edit* just tried the ap on the iPad and it functions perfectly!!
2014-11-27
Use props
jmtw000
lvl.4

United States
Offline

Try a different SD card if you haven't already. I had a bad SD card that was causing the app to randomly say the connection was broken.
2014-11-27
Use props
rare1a1
lvl.2

United States
Offline

^ interesting as I actually do not have an SD card in it yet, the seller forgot, and is sending seperately. Thanks!
2014-11-27
Use props
rare1a1
lvl.2

United States
Offline

Damn, that did the trick.  Thanks so much jmtw000!! Now, the connection keeps dropping out until I put the phone into airplane mode seems to solve the problem.  Prob not a bad thing to put the phone in that mode anyway when in the air.  Thx again
2014-11-27
Use props
jjjack87
New

United States
Offline

I have a sprint notes 2 and was having the same problem. I tried an Irulu 7" tab and it works just fine with out binding. Took my phone to the Sprint store and he turned off the Connection optimizer and my phone works like it should not. The steps are settings, more networks, mobile networks, connections optimizer, and uncheck at the top.
2014-12-29
Use props
mdblack98
New

United States
Offline

jjjack87@gmail. Posted at 2014-12-30 01:32
I have a sprint notes 2 and was having the same problem. I tried an Irulu 7" tab and it works just f ...

That worked for me on my Samsung phone.  It was dropping the phantom connection and the wireless status on phone would say "Turned off".
Turned off the connection optimizer and all is well.
2015-2-23
Use props
opina72
New

Dominican Republic
Offline

I have same problem (Phantom 2 Vision), with the difference that connection is steady and I can shot photos and videos even tilt the camera with the sliders, but blind. No FPV feedback. I think the issue is related with the range extender. As there is no firmware for it once you upgrade all other components and app, range extender ran out connection.  So I conclude this updates only work for Vision 2 plus range extender.
I have tried out all of the solutions showed here, Dji suggestions and other forums with no success.   
2015-2-26
Use props
dmctom.gmail
lvl.3
Flight distance : 126804 ft
Poland
Offline

opina72 Posted at 2015-2-27 09:49
I have same problem (Phantom 2 Vision), with the difference that connection is steady and I can shot ...

Hi everyone!
This is my first post on this forum ;)

I have a suggestion which might help you figure out if the range extender is your problem. You can actually connect directly to your Phantom bypassing the range extender. It works for me on my P2V+ V3.0. Here's what you have to do:
Turn everything on in proper order and open your DJI Vision app. Then go to SETTINGS and scroll down until you see Binding and tap on that. There the top line will show you your camera's SSID. Write it down. Now you can exit the app and turn everything off.
Turn on your controller and your phantom but leave the range extender off. Here comes the fun part:
On your phone go to WiFi and find an option to ADD a new network (on Android Lollipop I have three dot menu button on top).
For the SSID enter the code that you have written down earlier. It will look something like FC200_xxxxxx - the FC200_ seems to be static and the last six characters are the last six numbers of the camera MAC address.
Choose NONE for security setting.
Choose Advanced options and scroll down
Choose Static for IP settings and for your IP use 192.168.1.5 (actually anything where the last number is any number from 3 to 254)
Gateway will be 192.168.1.1
SAVE and exit.
Your phone should now connect directly to the Phantom without the range extender. You can now open the DJI Vision app and check your video stream. Everything should work fine except the range extender icon will be gray with no battery level. All other data should be displayed and you should get a clear picture from the camera.
One note - in my case P2V+ V3.0 plus Nexus phone with Android 5.0.1 my Vision app will sometimes say "Please connect WiFi network" even though I am connected to the Phantom (with or without the extender). I found out that to fix that I tap on this note in Vision app and that will open my network connections. I then tap on some other network and either connect to it or just try connecting using a random password. Then I tap on the FC200_xxxxxx network to reconnect to my Phantom. Then after tapping back on my phone the Vision app will detect the connection.
Remember that in order to connect directly to the Phantom the range extender needs to be OFF!
If you get a picture now you can safely say that your range extender is at fault. If you still don't see the picture you can suspect either the WiFi module in your Phantom or more likely the ribbon cable going from the camera. I would remove and reinstall the ribbon cable first and if that doesn't help I would go ahead and replace it. This is the most likely cause of no live video situation
Good luck!

Tom
2015-2-27
Use props
crash1sttime
First Officer
Flight distance : 1047503 ft
United Kingdom
Offline

@ dmctom.gmail

well worth a sticky that, well done, just to add though the P2V+ is at risk of a faulty WIFI unit in the quad itself, this can cause FPV loss but keeps telemetry data, only answer is to replace the WIFI module.
2015-2-27
Use props
weclark1
New

United States
Offline

Hello All,

  I'm a beginner and have yet to make my first flight with the Phantom.  I was having a similar problem with my new $39 LG phone (on the Sprint network), connecting fine only to have the connection dropped.  To make this story short what resolved the issue was to turn off the Connection Optimizer.
2015-3-29
Use props
opina72
New

Dominican Republic
Offline

dmctom.gmail Posted at 2015-2-27 20:55
Hi everyone!
This is my first post on this forum ;)

Thanks. Now I know that my problem is the wifi module or the camera ribbon cable. If I had read your post before I had not  wasted in a new range extender. Now I'll figure out how to solve it.

  
2015-6-17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules