Please select Into the mobile phone version | Continue to access the computer ver.
Nexus 7 II (2013) does not connect - HELP!!! - SOLVED!
2921 10 2016-3-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
James'ik
lvl.3
Flight distance : 126804 ft
Poland
Offline

Hello everyone,

I'm really getting angry here... please help me before I crush this P3 and throw it out the window!

I've used my small Nexus 4 phone and it works fine but the screen is tiny so I've decided to get something bigger. I got a cheap no-name tablet with good processing power but it doesn't work. It will connect to the P3 and show just a single picture of the video feed and stop. I also get WEAK SIGNAL warning at the top of the screen. OK, I've been told that it's not compatible... fair enough. So, I went out and got a Nexus 7 2013 as it is listed as compatible. Now this damn thing would not connect at all! I've tried different USB cables and USB Debugging on and off and nothing is making it work. It doesn't even say that anything is connected... HELP PLEASE!!When I launch the DJI Go app I only get the screen with:
Connect your DJI device
How to Connect (button)
And a picture of Inspire 1. Nothing else... like the cable is not connected at all.
All I can do is charge the battery in my tablet from the RC battery as this is the only thing that works.

The tablet is running Android 6 Marshcrapamallow, USB port works when connected to a PC (not without trouble but it does work).
When connected to a PC an option appears for charging only, file transfer, picture transfer and MIDI. When connected to P3 controller this option does NOT appear.RC and P3 on latest firmware, Nexus unmodified (no root). Everything is stock.

My Nexus 4 phone works fine. I've tried it just to make sure.

I appreciate any help as I'm so frustrated by this that I am literally ready to hit this P3 with a sledge hammer!

Thanks


2016-3-6
Use props
James'ik
lvl.3
Flight distance : 126804 ft
Poland
Offline

I'm replying to my own post so anyone with a similar issue will be able to find a solution...

The problem with my Nexus 7 tablet was an Android system component called Google Connectivity Services. It appears in the Play Store as an update and the latest version (as of March 10, 2016) simply does not work! It destroys WiFi, mobile data and in some cases even USB data transfer. DO NOT UPDATE until Google fixes the issue. Just read recent comments in the app store and notice if other users are giving positive reviews.
Reverting to default version under Android 6.0.1 made the tablet a bit better and I got intermittent charging but still no data connection. Restoring the tablet to factory defaults fixed the issue and now it connects to my P3 every time.
After restoring the tablet to factory defaults make sure you open the app store, go to settings the uncheck the automatic updates option. You will have to do updates manually but it will not download the broken Connectivity Services app and mess up your data connection.
2016-3-9
Use props
robie
lvl.1

Philippines
Offline

I disabled my Google connectivity services but it still didn't work. I also did the factory reset 2x but it didn't fix the problem. Hope someone can help
2016-3-22
Use props
mrGREEK360
lvl.4
Flight distance : 236414 ft
Canada
Offline

How was it solved?
2016-3-22
Use props
robie
lvl.1

Philippines
Offline

Mine is not yet solved. Upgraded to the 2.7.1 app today, but i have the same problem
2016-3-23
Use props
James'ik
lvl.3
Flight distance : 126804 ft
Poland
Offline

robie Posted at 2016-3-22 16:03
I disabled my Google connectivity services but it still didn't work. I also did the factory reset 2x ...

Robie, you are not suppose to disable the Google connectivity services because something has to take care of the connectivity. As mentioned in my previous post you are suppose to UNINSTALL updates to Google Connectivity Services and revert to the old default version. You do need it running and working.
First open your Play Store app and go to settings. Make sure "Auto-update apps" is set to "Do not auto-update apps". On system restore Google sets this option to auto-update and that will cause the bad update to install again. Once that is done go to Settings -> Apps -> [select tab} All - [scroll to] Google Connectivity Services and uninstall updates.

It that doesn't work you need to make sure that you can connect to your PC using the same USB cable. Is it being detected? Can you browse the Nexus memory from your PC? If not, you might have a bad USB socket or even a bad sub-board where the socket is mounted to.

BTW, Debugging option does NOT have to be on. It works on my Nexus 7 just fine, while my Nexus 4 would not connect unless debugging is on.

Good luck!
2016-3-23
Use props
robie
lvl.1

Philippines
Offline

Hi James. Thanks for the quick reply. Mine doesnt have the uninstall updates option. The right button is to force stop while the left button is to disable the google connectivity services. It wasnt working so i tried to disable, but it still didnt work (probably because of reasons you stated)
2016-3-23
Use props
robie
lvl.1

Philippines
Offline

I tried the nexus on my pc with the same usb cable. Initially, it was intermittent but it went ok after a clear cache and factory reset. It worked on the p3a on the first time i tried it, but it does not work again now. So, have no problems with the hardware and software only works after a reset
2016-3-23
Use props
robie
lvl.1

Philippines
Offline

Since the dji app is still having problems, i installed the litchi app. After installation, i tried the dji go app and it now works! Tried 3x already and dji app now works
2016-3-23
Use props
robie
lvl.1

Philippines
Offline

Somehow, it seems that litchi has some files that makes the dji work
2016-3-23
Use props
RayCorona
lvl.1
United States
Offline

James'ik Posted at 2016-3-23 13:28
Robie, you are not suppose to disable the Google connectivity services because something has to take care of the connectivity. As mentioned in my previous post you are suppose to UNINSTALL updates to Google Connectivity Services and revert to the old default version. You do need it running and working.
First open your Play Store app and go to settings. Make sure "Auto-update apps" is set to "Do not auto-update apps". On system restore Google sets this option to auto-update and that will cause the bad update to install again. Once that is done go to Settings -> Apps -> [select tab} All - [scroll to] Google Connectivity Services and uninstall updates.

Hi James.

Thank you for the info it has really helped.

Do you happen to know what is the app that carries the Connectivity Services as to not update it.

Thank you.  
2018-3-18
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules