Please select Into the mobile phone version | Continue to access the computer ver.
I cannot see the camera through DJi vision app
104581 324 2016-3-17
Uploading and Loding Picture ...(0/1)
o(^-^)o
bnewman
lvl.3
Flight distance : 6285066 ft
  • >>>
United States
Offline

Freindship7 Posted at 2017-4-21 02:19
Hi all, I've attached the recovery procedure here that I used to restore FPV on my P2V+. Hopefully you all find this useful. If you have any queries with the information in the document then I'm happy to help. Good luck with fixing your Wi-Fi modules!

Thanks for posting the recovery procedure.  It worked for me!
2017-5-10
Use props
irishgrumpy
New

Ireland
Offline

bnewman Posted at 2017-5-10 14:53
Thanks for posting the recovery procedure.  It worked for me!

Yeah, same issue here. Used camera just before Christmas all ok, took out now, black screen......
Anyways, read the "cure", fantastic work bt Friendship7, but, hey, I am an oldie and a bit above me....

@Friendship, sent you a PM, (I think), hoping you can help.
2017-5-11
Use props
Jon Tagle
New
United States
Offline

Wonder what dji will do with friendship's knowledge/discovery... will they make this right?? Or look the other way?  
2017-5-11
Use props
Eran Haviv
New

Israel
Offline

Hi all,
I have the exect same problem with P2V (NOT +).  After sitting for almost 2 years, everything is working except I can't get the live camera view in the Vision app (I can still take pictures and video blind whithout knowing what I'm filming).  Any solution for P2V (not + version)??  Will DJI address this issue??
Thanks
2017-5-11
Use props
fans76590968
lvl.1

Italy
Offline

Eran Haviv Posted at 2017-5-11 10:50
Hi all,
I have the exect same problem with P2V (NOT +).  After sitting for almost 2 years, everything is working except I can't get the live camera view in the Vision app (I can still take pictures and video blind whithout knowing what I'm filming).  Any solution for P2V (not + version)??  Will DJI address this issue??
Thanks

Hi,
i have same problem (only telemetry but not FPV) with old P2V me too...
I hope anyone knows a solution for us!
2017-5-12
Use props
irishgrumpy
New

Ireland
Offline

I did contact DJI  two days ago, and to be fair they did reply. But a load of gobbleygook........One of the issues I have is that I do not own this unit, but look after it for a friend of mine who is resident in both the US and Ireland. This unit was bought in the US, so of course as far as DJI is concerned, if it was to be repaired it would have to be in the US. For an international company, I think this is totally unacceptable.
One of the things they suggested doing, (well the only thing really...), was to re-bind the P2 and rangefinder by turning on unit and pressing the re-set on the wi-fi extender, etc, etc.......
Does anyone think this might work. in other words, is it worth a try??????
I would love to be competent enough to do the fix as Friendship7 and ricom831 suggest, but unfortunately I am more a mechanical rather than electrical person, so would have no issues taking module out, but after that.................
Hoping someone can help, ie, volunteer to re-flash unit, I would be happy to send it to them........
I am not used to this forum so find it hard to send pm's. If any one wants to contact me, irishgrumpy@gmail.com is my contact.
Thanks to all, (anyone ) for reading this.
Irish (not so) grumpy.
2017-5-12
Use props
Eran Haviv
New

Israel
Offline

Hi,
I've contacted DJI support about this broblem, this is there response:

Dear Ehaviv,

Thank you for contacting DJI Technical Support.

Sorry Ehaviv this problem has to repair the wifi module
Because your drone has already out of the warranty, we can't afford any freight or maintenance cost, you should pay for it.
Considering the freight and time loss we suggest you contact your nearby dealer to avoid the huge logistic cost by sending to China.
Here are their info.

I've also contacted dealers here in Israel but they say that P2V is a very old model and they don't stock the necessary parts to repair this problem.

So I gess I'm running out of options... may be try to re-bind the range-extender like irishgrumpy suggested, but not sure it will help if there a firmware/hardware problem with one of the wifi modules.
2017-5-13
Use props
irishgrumpy
New

Ireland
Offline

I have tried all things suggested here to get the FPV back on my phone, all to no avail.
I have realised that mine is a Vision 2, NOT a plus........
I had contacted Friendship7 about re-flashing the wi-fi unit, but I don't know where it is in mine......see picture.

If anyone can shed some light on where it is, I would like to hear.....Thanks...
IMG_20170515_144436ww.jpg
2017-5-15
Use props
fanse4c86214
New

Italy
Offline

some advise to solve this problem?
now its impossible to use my dji phantom 2 vision plus v3.0

https://ibb.co/gDaF6Q
2017-5-16
Use props
fans76590968
lvl.1

Italy
Offline

irishgrumpy Posted at 2017-5-15 12:21
I have tried all things suggested here to get the FPV back on my phone, all to no avail.
I have realised that mine is a Vision 2, NOT a plus........
I had contacted Friendship7 about re-flashing the wi-fi unit, but I don't know where it is in mine......see picture.

Hi irishgrumpy
in the P2V (not Plus) the wifi module is the board #3 placed inside the FC200 camera, look at http://www.phantompilots.com/thr ... update-on-p2.84482/

but i don't know if and how it is possible to link that board to PC, and rewrite the NAND like P2V+

2017-5-17
Use props
irishgrumpy
New

Ireland
Offline

fans76590968 Posted at 2017-5-17 06:04
Hi irishgrumpy
in the P2V (not Plus) the wifi module is the board #3 placed inside the FC200 camera, look at http://www.phantompilots.com/threads/wifi-extender-update-on-p2.84482/

Thanks a lot for info fans76590968, very interesting..........probably not much help, but interesting....


2017-5-19
Use props
Rob Clack
lvl.1

United Kingdom
Offline

I fixed this on my P2 by removing the micro-SD card from the camera and reformatting it.  The first time, doing so on my Android tablet worked, but then after a while it went black again and this time I had to do a full reformat using my Windows PC.  Even then, it didn't work properly the first time I fired up the bird.  But then I noticed that my range extender battery was a bit down, so charged that up, and now all is ticketyboo.  Makes me wonder whether it's more complex than a simple one-cause issue.
2017-5-19
Use props
bnewman
lvl.3
Flight distance : 6285066 ft
  • >>>
United States
Offline

I followed Friendship7's procedure and it fixed the problem and I had video for a few days. But now, less than a week later, video feed is gone again. Any ideas why it would revert to not working?
2017-5-19
Use props
Friendship7
lvl.2

United Kingdom
Offline

bnewman Posted at 2017-5-19 08:44
I followed Friendship7's procedure and it fixed the problem and I had video for a few days. But now, less than a week later, video feed is gone again. Any ideas why it would revert to not working?

bnewman, can you try the ping test in the recovery procedure which will narrow down the fault? Since restoring my video feed I have been powering up the drone at least once a week for a few minutes to try and prevent the problem from occurring again.
2017-5-20
Use props
bnewman
lvl.3
Flight distance : 6285066 ft
  • >>>
United States
Offline

Friendship7 Posted at 2017-5-20 01:52
bnewman, can you try the ping test in the recovery procedure which will narrow down the fault? Since restoring my video feed I have been powering up the drone at least once a week for a few minutes to try and prevent the problem from occurring again.

As before, 192.168.1.2 and 192.168.1.1 ping successfully but 192.168.1.10 does not.   
Looks like I'll be performing the recovery procedure again.  Hopefully, it will last longer this time.
2017-5-24
Use props
I.Kraemer
lvl.1
Flight distance : 126355 ft
Germany
Offline

Translated Friendship7's procedure into german (thanks for your permission) and posted it in some german forums.
Received feedback from two users that the procedure worked for them...
2017-5-24
Use props
I.Kraemer
lvl.1
Flight distance : 126355 ft
Germany
Offline

bnewman Posted at 2017-5-19 08:44
I followed Friendship7's procedure and it fixed the problem and I had video for a few days. But now, less than a week later, video feed is gone again. Any ideas why it would revert to not working?

Because I think that overheating of the NAND chip is part of the problem, I've added this to the german translation of Friendship 7's procedure:

Inside the old WiFi modules (without ventilation holes) the NAND chip doesn't have direct contact to the aluminum housing of the module (probably a design error of DJI). In some modules, the air gap (approx. 0.5mm) was bridged with a heat-conducting pad, in others only by some heat-conducting paste. As a result, the heat from the working NAND chip is not properly dissipated and the chip is heated excessively. It is advisable to bridge this air gap with an aluminum or copper plate in the size of the NAND chip (chip - heat transfer paste - spacer - heat transfer paste - housing). In the old housings, additional ventilation holes should also be inserted according to the newer WiFi modules.
The overheating of the chip probably causes the software error of the board.
If the measures for better heat dissipation are not carried out, this software error could occur again.
2017-5-24
Use props
fans39ef8779
lvl.1
United States
Offline

Hi guys. Same issue as all of you. I want to follow Friendship's suggested procedure, but I just can't seem to download it from the DJI source or from his off-site link. It shows 724kb/725kb and then after minutes it'll say "Connection to server failed". I have tried this multiple times with the same results. I will try again when I get home, but if anyone has his step-by-step, can they upload it to another source for us? It'd be a horrible shame if in a year or two, someone comes by needing help and the one-and-only download spot is no longer working.
2017-5-25
Use props
LemonX
lvl.1

Czechia
Offline

fans39ef8779 Posted at 2017-5-25 12:36
Hi guys. Same issue as all of you. I want to follow Friendship's suggested procedure, but I just can't seem to download it from the DJI source or from his off-site link. It shows 724kb/725kb and then after minutes it'll say "Connection to server failed". I have tried this multiple times with the same results. I will try again when I get home, but if anyone has his step-by-step, can they upload it to another source for us? It'd be a horrible shame if in a year or two, someone comes by needing help and the one-and-only download spot is no longer working.

Heloo:

https://drive.google.com/open?id=0B-j_Eb5YU8okTDJjOENXYXlJLU0

https://drive.google.com/open?id=0B-j_Eb5YU8okWEU5Ulk5MkhyY1E¨
My setup:
http://ok1mhk.blogspot.cz/2017/0 ... -nefunkcni-fpv.html
+ tuniing cooling chips
2017-5-31
Use props
clos82
lvl.1

United States
Offline

has anybody created a video on this fix yet? How do i connect to my laptop when it doesn't come w/a COM port? And what would be the easiest way to power up the board? i don't have a DC variable power supply...

i live in WASHINGTON STATE. maybe someone from the PNW can ping or email me cavila82@gmail.com with suggestions or your how to's.


thank you friendship7 for your work.
2017-6-1
Use props
Suko
lvl.1
United States
Offline

LemonX Posted at 2017-5-31 09:38
Heloo:

https://drive.google.com/open?id=0B-j_Eb5YU8okTDJjOENXYXlJLU0

Thanks for sharing. It turns out there was an issue at my work preventing me from downloading the file. I got it now, so thank you!

And good news!, I just did the process described and I got my FPV back. I don't know how long it'll last, but I will keep everyone posted. I got done pretty late tonight, so I'll take it out tomorrow and see if/how it works out.

Definitely good news if this is a potential fix. It did take me about 1.5 hours though. I could probably do it faster now, but having to resolder all those connections takes time.
2017-6-2
Use props
clos82
lvl.1

United States
Offline

i will pay someone to diagnose and fix this for me. I'm not at all tech guy
2017-6-3
Use props
mapp3d
New
Spain
Offline

I have the same error with the P3P. I was not using the PeP for a year, and yesterday I tried to use it and seems that I must update all, App, Drome and RC. I updated to the last version, 1.10 in the drone and 1.8 in the RC. The drone update dind´t update well, I tried 10 times and all the times with error, I tried with the previous version and the same, error. If I check the DJI go, seems that the firmware is correct, but I have not a live image transmission. I tried with differents memory cards, firm versions, checked cables,.... nothing, same issue. Any idea??
2017-6-4
Use props
Lasernerd
lvl.1
United States
Offline

Mine sat for a few months,,now no video,I checked all the cables etc.I noticed my wifi unit has the 1 wire,I did the mandatory update video is gone! what to do now? buy a new wifi module or does someone have a reflash service available?
2017-6-4
Use props
Suko
lvl.1
United States
Offline

It's a shame. There's so many people with this issue, but fixing it is very time consuming. If someone wanted to streamline the process, I imagine they could make a jig that you could slip the wifi board into and easily run the procedure as necessary. I'd love to help others out, but TBH, to make this worth my time to do, I'd have to charge people $150 per attempt and at that price, what's the point? It would be simpler to just buy a new Wifi board or get a Phantom3.

Question for Friendship; Any idea what causes this issue? It sounds like it has to do with the Phantom going for extended periods of time without power. However, my FPV was working fine just a week or two before the black screen hit me. I did two flights and recorded some video, it then sat for 2 weeks (with battery in the Phantom), then when I brought it back out I had black FPV screen. This occurred AFTER I had added some thermal paste to prevent the unit from overheating.
2017-6-5
Use props
Lasernerd
lvl.1
United States
Offline

Well,this is just weird.I have the vented wifi module V3.0 Once I am out of local wifi routers etc range. I get a picture..It is the app that is causing my problems..they (DJI) need to fix this asap!
2017-6-5
Use props
El_Diablo
New

Belgium
Offline

Hi all,

I've followed all the discussion here (very interesting). I've bought a Phantom 2 vision plus to a friend but I've also the black screen. All telemetry are ok, and I can ping all boards without any problem!! even the x.x.x.10 ...
I tried with another phone android but no image in the DJI vision app.

As all ping are ok, do you have an idea how to fix this? I use a huawai P8lite phone.
I tried also to remove the SD card, and I've the same issue - black screen

Someone can help me on the investigation?
In advance many thanks,

El diablo
2017-6-8
Use props
bnewman
lvl.3
Flight distance : 6285066 ft
  • >>>
United States
Offline

Friendship7 Posted at 2017-5-20 01:52
bnewman, can you try the ping test in the recovery procedure which will narrow down the fault? Since restoring my video feed I have been powering up the drone at least once a week for a few minutes to try and prevent the problem from occurring again.

I re-programmed it again and restored video feed but less than a week later it was gone again.

Can the board be programmed per the tutorial but without disconnecting anything?
I would solder connectors to the board and cut the shielding to allow connection to the board for programming without any disassembly.
Taking it all apart to re-program before each day of flying gets old fast.  
2017-6-11
Use props
Friendship7
lvl.2

United Kingdom
Offline

Suko Posted at 2017-6-5 15:24
It's a shame. There's so many people with this issue, but fixing it is very time consuming. If someone wanted to streamline the process, I imagine they could make a jig that you could slip the wifi board into and easily run the procedure as necessary. I'd love to help others out, but TBH, to make this worth my time to do, I'd have to charge people $150 per attempt and at that price, what's the point? It would be simpler to just buy a new Wifi board or get a Phantom3.

Question for Friendship; Any idea what causes this issue? It sounds like it has to do with the Phantom going for extended periods of time without power. However, my FPV was working fine just a week or two before the black screen hit me. I did two flights and recorded some video, it then sat for 2 weeks (with battery in the Phantom), then when I brought it back out I had black FPV screen. This occurred AFTER I had added some thermal paste to prevent the unit from overheating.

Hi Suko, this issue is caused by the software image contained within the NAND flash on the bottom PCB - the software image becomes corrupt. The corruption is caused by 'bad blocks' within the NAND flash device which prevents the software from running. To be honest its pretty poor software engineering because most NAND flash software drivers are written to be able to recover such bad blocks, it appears in this case DJI didn't consider this when the Wi-Fi module was designed.
2017-6-14
Use props
Friendship7
lvl.2

United Kingdom
Offline

bnewman Posted at 2017-6-11 14:51
I re-programmed it again and restored video feed but less than a week later it was gone again.

Can the board be programmed per the tutorial but without disconnecting anything?

Hi bnewman, sorry that you have lost FPV again after performing the recovery procedure. I think also in your case the NAND flash could be faulty as well since you still have loss of FPV after performing the procedure twice. I guess you could add the hooks into the board so that you can reprogram it again without disconnecting anything but you'll need to modify the Wi-Fi module shield can quite heavily to do this.
2017-6-14
Use props
fans9f9f57b5
New

United States
Offline

Try to plug your micro usb cable into your drone and your computer and take it out again, that worked for me
2017-6-14
Use props
dwwd
New

United Kingdom
Offline

Hi Ricom831.  Are you still looking for UK volunteers to try your UART fix?  Like many others, after a period of inactivity, my video feed does not work.  I have resisted making any updates on teh basis that it wasn't broken when I stored it.  You say you are in a cold place... colder than Fife?
2017-6-19
Use props
fans1f8d2213
lvl.4
Pakistan
Offline

my phantom 2 vision plus redy for fly with live view
2017-6-24
Use props
Friendship7
lvl.2

United Kingdom
Offline

fans1f8d2213 Posted at 2017-6-24 07:13
my phantom 2 vision plus redy for fly with live view
https://youtu.be/x9ad6aSCkNE

fans1f8d2213 thanks for posting the video and I'm glad the procedure worked for you, happy flying
2017-6-24
Use props
mazo78
lvl.4
Pakistan
Offline

Some modification in my phantom 2 vision plus for Easy NAND Flashing

2017-6-26
Use props
Phantom Brick
New
United States
Offline

Northofthe49th Posted at 2016-3-17 05:52
Check the cables around the base of the gimbal, they are most often the culprit as they have been a bit prone to come loose, especially in a hard landing or someting....

nope not the issue
2017-6-28
Use props
El_Diablo
New

Belgium
Offline

El_Diablo Posted at 2017-6-8 02:33
Hi all,

I've followed all the discussion here (very interesting). I've bought a Phantom 2 vision plus to a friend but I've also the black screen. All telemetry are ok, and I can ping all boards without any problem!! even the x.x.x.10 ...

Any suggestions for me?
All boards responds to the ping, so it should be a small issue in my case  :/
2017-6-30
Use props
El_Diablo
New

Belgium
Offline

El_Diablo Posted at 2017-6-8 02:33
Hi all,

I've followed all the discussion here (very interesting). I've bought a Phantom 2 vision plus to a friend but I've also the black screen. All telemetry are ok, and I can ping all boards without any problem!! even the x.x.x.10 ...

Any suggestions for me?  AS all boards responds to the ping command, the problem should be easy to solve   :/
May be it is due to the smartphone that I used, did you have some problems in the past with some type of smartphone?

many thanks
2017-6-30
Use props
Harbourside
First Officer
Flight distance : 6467 ft
United Kingdom
Offline

El_Diablo Posted at 2017-6-30 01:39
Any suggestions for me?  AS all boards responds to the ping command, the problem should be easy to solve   :/
May be it is due to the smartphone that I used, did you have some problems in the past with some type of smartphone?

hi El-Diablo,
For a start we need to know what firmware you are on.
With everything turned on and connected, go to the about page of the app and list what the firmware versions are for Naza, camera and app.

2017-6-30
Use props
Jetlagged
lvl.1
Flight distance : 9980 ft
Portugal
Offline

Like other users my Vision 2+ has been standing idle for over a year and now I have the black screen problem. Unlike most others, it is only intermittent. I flew three batteries recently; with the first and third I had the black scree but the second was fine. Now I have it back home and have tried the ping test and it passed and I had vision back.

Friendship - you have done a fantastic job putting his fix together for us and I am really grateful for the time and effort you have put in. I have all the necessary parts en route from Amazon. I am reluctant to go ahead with it though is this is intermittent. Could it be that my NAND is actually OK and that I have a different problem?

Above you said, "...this issue is caused by the software image contained within the NAND flash on the bottom PCB - the software image becomes corrupt. The corruption is caused by 'bad blocks' within the NAND flash device which prevents the software from running." Surely, if mine was corrupt, wouldn't I have the fault every time I powered up? I am not questioning your diagnosis in any way as I did not even have a clue what a NAND was until I read your explanation. I am not technically gifted at all, hence my reluctance to reflash the NAND unless it is absolutely necessary.

Any thoughts please?
2017-7-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules