Please select Into the mobile phone version | Continue to access the computer ver.
I cannot see the camera through DJi vision app
104500 324 2016-3-17
Uploading and Loding Picture ...(0/1)
o(^-^)o
Friendship7
lvl.2

United Kingdom
Offline

Jetlagged Posted at 2017-7-6 07:03
Like other users my Vision 2+ has been standing idle for over a year and now I have the black screen problem. Unlike most others, it is only intermittent. I flew three batteries recently; with the first and third I had the black scree but the second was fine. Now I have it back home and have tried the ping test and it passed and I had vision back.

Friendship - you have done a fantastic job putting his fix together for us and I am really grateful for the time and effort you have put in. I have all the necessary parts en route from Amazon. I am reluctant to go ahead with it though is this is intermittent. Could it be that my NAND is actually OK and that I have a different problem?

Jetlagged, your symptoms were very similar to mine. A few times I flew I had the black screen issue but then once or twice it seemed ok and then all of a sudden I had a permanent black screen, actually for more than a year, until I found the fix. I would suggest the next time you fly and have the black screen issue perform the ping test and see if it fails, this will diagnose if it is the NAND flash image within the Wi-Fi module.
2017-7-8
Use props
LakeExplorer
lvl.1

Pakistan
Offline

@Friendship7 Need some help - I am trying to fix my wifi module based on your instructions. I have purchased the same FTDI USB to UART chip. Installed drivers in both my Mac and windows machines. I have done the solders but I am unable to see any output except 2 or 3 dots "." in the terminal enumerator program. I have double checked all my connections. Solders seem solid. I will post the pics when I get back home. Is there anyway to confirm that CHIP is communicating with board correctly. The red light on bottom wifi board and FTDI chip both turn red when board is powered on.
I did the PING tests as well, 192.168.1.1 and 192.168.1.2 responded correctly while 192.168.1.10 one failed.
2017-7-9
Use props
LakeExplorer
lvl.1

Pakistan
Offline

I think I have found the issue. I was connecting FTDI chip RX with board RX and TX with TX . Sad I was not careful in the instructions. I hope I haven't burned anything doing this. I will redo the connection at home tonight. I hope it works this time.
2017-7-9
Use props
LakeExplorer
lvl.1

Pakistan
Offline

@Friendship7 - I can also confirm that your solution worked for me too. I was just not careful in connecting TX/RX pins. Process was very simple and well explained in your PDF. Just add an image with drawn lines from PCB to FTDI chip for layman like me so that they can confirm pins are correctly connected.

Thanks a lot for your effort and writing a perfect guide.
2017-7-10
Use props
El_Diablo
New

Belgium
Offline

Harbourside Posted at 2017-6-30 05:39
hi El-Diablo,
For a start we need to know what firmware you are on.
With everything turned on and connected, go to the about page of the app and list what the firmware versions are for Naza, camera and app.

Oh I do not received any email stating that someone answered to me !
Sorry, when back at home I will go through this menu but as far as I know, all firmware are up to date.

I will keep you posted soon,
2017-7-14
Use props
El_Diablo
New

Belgium
Offline

Harbourside Posted at 2017-6-30 05:39
hi El-Diablo,
For a start we need to know what firmware you are on.
With everything turned on and connected, go to the about page of the app and list what the firmware versions are for Naza, camera and app.

OK so,

My current configuration is:
SW 1.0.61
Cam 1.3.0g
NAZA-M 3.14

Could someone told me if a version is not the good one in this case?
2017-7-15
Use props
El_Diablo
New

Belgium
Offline

El_Diablo Posted at 2017-7-15 05:28
OK so,

My current configuration is:

And inside the DJI vision assistant software, I found these information:

- Main controller : 3.14
- GPS: 6.0.1.6
- Receiver-5.8G 1.0.1.3
- P330CB 1.0.2.10
- Battery 1.0.0.9
- Zen IMU 1.0.0.6

2017-7-15
Use props
Harbourside
First Officer
Flight distance : 6467 ft
United Kingdom
Offline

That all looks ok, so unfortunately  it seems that the Wi-Fi module inside the Phantom is faulty.
Spares parts are hard to come by now, and if you cant find a local repair shop, then opening a repair case with DJI will be an option.
Others on here have been quoted around £200 for the repair, so you might think about putting that towards another model instead.
Good luck.
2017-7-15
Use props
Jimbo49
lvl.1

United Kingdom
Offline

ricom831 Posted at 2017-1-14 13:48
Hi all,

I've been suffering from the same issue after starting up my Phantom since 9 months ago... no live view!

Hi Ricoh, new to this but I see you are offering to reflash vision 2 plus wifi bottom pub at a cost, how do I go about having you do this for me please?
Jim
2017-7-16
Use props
Jimbo49
lvl.1

United Kingdom
Offline

ricom831 Posted at 2017-4-6 00:26
I have a couple of units to work on this weekend - I will take pictures and write up some detail on how to flash the unit - I am also willing to repair units for a small cost if that's helps folk.

Hello, new to this but how do I get my wifi module to you please?  Jim 07772575088
2017-7-17
Use props
Jimbo49
lvl.1

United Kingdom
Offline

ricom831 Posted at 2017-1-14 13:48
Hi all,

I've been suffering from the same issue after starting up my Phantom since 9 months ago... no live view!

New to this, how do I contact you with regard to a module repair please?
Jim. 07772575088
2017-7-17
Use props
Jimbo49
lvl.1

United Kingdom
Offline

ricom831 Posted at 2017-1-18 08:38
Hiya,

Well funilly enough I have the vented unit and live in one of the coldest parts of the UK so there's no way this was an overheating issue that they like to use as an excuse! I was actually in 3 degree weather when I last used the unit and it was then kept in my car for 9 months (in the boot) - again, always kept in cool conditions. I've heard the overheating issue but I'm not convinced - it was perfect 9 months previously so I was in complete shock when it no longer worked. The only reason I was testing it out was to stick it on Ebay and upgrade to a 4... well forget the upgrade as I don't trust it to last more than 2 years like this unit. DJI has let me down with this to be honest

Will you look at mine also please? Jim 07772575088
2017-7-17
Use props
El_Diablo
New

Belgium
Offline

Harbourside Posted at 2017-7-15 06:55
That all looks ok, so unfortunately  it seems that the Wi-Fi module inside the Phantom is faulty.
Spares parts are hard to come by now, and if you cant find a local repair shop, then opening a repair case with DJI will be an option.
Others on here have been quoted around £200 for the repair, so you might think about putting that towards another model instead.

OK but if the wifi module is broken, why I can ping the board to the address 192.168.1.10 !
I've seen on some different forums that the wifi module breaks only if the ping fail ...
This is why I was asking for another idea ...  I became a bit lost with my DJI  :-)

Anyway thanks for your reply Harbouside ;)
2017-7-17
Use props
Harbourside
First Officer
Flight distance : 6467 ft
United Kingdom
Offline

Good point, sorry I missed that.
You have checked the 3 small white plugs that connect to the gimbal ?
Never had a single problem with my V+ so cant really help from experience.
2017-7-17
Use props
Jimbo49
lvl.1

United Kingdom
Offline

ricom831 Posted at 2017-4-6 00:26
I have a couple of units to work on this weekend - I will take pictures and write up some detail on how to flash the unit - I am also willing to repair units for a small cost if that's helps folk.

Hi ricom831 new to this forum & trying to contact you for reflash repair not even sure if you can see any posts I have left. Could you message me please ? 07772575088. Thank you. Jim
2017-7-18
Use props
Jimbo49
lvl.1

United Kingdom
Offline

Freindship7 Posted at 2017-4-20 10:46
Hi all, flight test this evening was successful and its great to have FPV back. I'm now in the process of putting the repair document/instructions together and will aim to get this posted as soon as possible.

Hi, is this fix something you could do for me please for my v2+, ping failed on bottom board. I understand there will be a cost. New to this forum so not sur of any protocol. Thank you in advance.
2017-7-20
Use props
Jimbo49
lvl.1

United Kingdom
Offline

fansd52dbeb7 Posted at 2017-4-10 02:45
ricom381 can you please help me

Me to please?
2017-7-20
Use props
Jimbo49
lvl.1

United Kingdom
Offline

ricom831 Posted at 2017-1-16 04:40
It was 9 months since my last flight so it's certainly something to do with leaving the units for a while. Either replacemant or reflash will fix it.

As you are based in the UK, I'm happy to have a look at your WiFi unit and confirm if it's the same issue as me and also if the fix applied will work for all units with the issue. I'm looking for volunteers based in the UK so it's easier to ship/meet.

Could you look at mine please???
2017-7-20
Use props
Ph
lvl.2
United States
Offline

Wow!  This is some kind of joke.  There are so many people with this problem, it has to be due to faulty design or a faulty product.  It doesn't sound like DJI is doing anything about it.  I guess we are all just SOL?  Unbelievable
2017-7-20
Use props
darrenh
lvl.1

United Kingdom
Offline

hi Ricom831 i am requiring your services aswell, i have 2 fc200 that need your special touch.
could you contact me to arrange how i can get these to you.
many thanks in advance darren 07772 133238.
2017-7-20
Use props
darrenh
lvl.1

United Kingdom
Offline

Hi can anyone please come and do this repair forme, i am in the uk, i will pay you for your services.
I know friendship7 has helped out a lot of people with this cure, does anyone know if he does repairs for others and also is he in the uk.
Replies would be very gratefull .
Or email me direct hardy.d3@sky.com
Many thanks
Darren
2017-7-20
Use props
Versluys_Tom
New

Belgium
Offline

Thanks for the wonderful and detailed instructions.
I also have a DJI Phantom Vision 2+ and after sitting more than 1 year in the box (due to the awful Belgian Law) I wanted to see if it was still operational.
At first I thought that the missing preview image was due to the app because I upgraded my iPhone.
I found it very strange that the last time I used the drone it was fully functional and I didn't crash it, it was stored in a proper case.
Very strange that this memory chip becomes corrupt.
I now have applied a better silver conducting thermal paste to the chip to keep it cooler, but I think it was just the time corrupting the data.

If anyone needs my assistance to fix their module in the same way, I'm happy to help.
I'm living in Belgium at the coast.
Send me an e-mail: Tom_Versluys@yahoo.com .

DJI should inform owners of these drones that there is a fix.

Many thanks to anyone who has contributed to this solution. I'm so happy to have a fully functional drone again.
2017-7-22
Use props
darrenh
lvl.1

United Kingdom
Offline

Hi i have managed to get my fpv working on my vision and it does work every time.
First thing is can you see everything on your phone or tablet apart from live feed.
If you can then do the following.
Turn transmitter on then the drone.
Turn your wifi on on your phone or tablet.
Turn on wifi extender.
Look and see when your devive has connected.
When it has connected then open the dji app.
Then press on camera.
And there you go it works every time.
2017-7-22
Use props
darrenh
lvl.1

United Kingdom
Offline

darrenh Posted at 2017-7-22 13:25
Hi i have managed to get my fpv working on my vision and it does work every time.
First thing is can you see everything on your phone or tablet apart from live feed.
If you can then do the following.

Forgot to mention don't turn wifi extender on for at least 30 seconds after you power up your drone
2017-7-23
Use props
fansd8fe2711
New
United Kingdom
Offline

Ok - So I bought all the stuff to fix my Phantom after getting a really poor response from DJI customer care. Tried to build a jig to flash the card but I couldn't get a reliable connection so I bit the bullet and started to solder the wires on. When I did it everything worked fine until I tried to solder on the power connectors. The contacts seems to get covered in some melted plastic from somewhere and the solder wouldn't take. I scraped away the plastic and now the two contacts are shorting out so I guess this board is now useless? Unless anyone knows if there is another way to safely power the board.
I did get as far as getting then and boot error on my gig but the connection was too unreliable to risk the flash. I also couldn't get sfh_DM36.exe to run on my computer. it kept opening then closing immediately - tried it on a windows 10 machine and an old XP laptop I had lying around. Has anyone else experienced this?

I'm posting this just to let people know that you have to be even more careful than I was when you are soldering and believe me I was REALLY careful.

I'm absolutely fuming with DJI - cost of drone £1000 number of flights 5 - cost per flight  £200. Was thinking about buying a Mavic Pro but I'm not giving DJI another penny.
2017-7-24
Use props
fans76590968
lvl.1

Italy
Offline

darrenh Posted at 2017-7-22 13:25
Hi i have managed to get my fpv working on my vision and it does work every time.
First thing is can you see everything on your phone or tablet apart from live feed.
If you can then do the following.

Hi darrenh,
do you have a vision (FC200 "egg" camera) or vision+ Phantom?
2017-7-26
Use props
Friendship7
lvl.2

United Kingdom
Offline

fansd8fe2711 Posted at 2017-7-24 14:29
Ok - So I bought all the stuff to fix my Phantom after getting a really poor response from DJI customer care. Tried to build a jig to flash the card but I couldn't get a reliable connection so I bit the bullet and started to solder the wires on. When I did it everything worked fine until I tried to solder on the power connectors. The contacts seems to get covered in some melted plastic from somewhere and the solder wouldn't take. I scraped away the plastic and now the two contacts are shorting out so I guess this board is now useless? Unless anyone knows if there is another way to safely power the board.
I did get as far as getting then and boot error on my gig but the connection was too unreliable to risk the flash. I also couldn't get sfh_DM36.exe to run on my computer. it kept opening then closing immediately - tried it on a windows 10 machine and an old XP laptop I had lying around. Has anyone else experienced this?

fansd8fe2711, as you are based in the UK (and so am I), I'd be happy to try and help you recover your Wi-Fi module. Could you send me a private message and we'll discuss next steps.
2017-7-26
Use props
darrenh
lvl.1

United Kingdom
Offline

fans76590968 Posted at 2017-7-26 02:53
Hi darrenh,
do you have a vision (FC200 "egg" camera) or vision+ Phantom?

Hi i have the egg f200
2017-7-27
Use props
darrenh
lvl.1

United Kingdom
Offline

Friendship7 Posted at 2017-7-26 09:28
fansd8fe2711, as you are based in the UK (and so am I), I'd be happy to try and help you recover your Wi-Fi module. Could you send me a private message and we'll discuss next steps.

Hi i seem to have sorted out the problem the other day but now it is not working again.
Do you offer a service where i can send you my fc200 and you could sort it and i pay you through pay pal or by mobile banking.
I live in essex the uk.
Regards
Darren
2017-7-27
Use props
Friendship7
lvl.2

United Kingdom
Offline

darrenh Posted at 2017-7-27 12:21
Hi i seem to have sorted out the problem the other day but now it is not working again.
Do you offer a service where i can send you my fc200 and you could sort it and i pay you through pay pal or by mobile banking.
I live in essex the uk.

Hi Darren,

I'm only familiar with how to recover the Wi-Fi module in the P2V+ and not the P2 with FC200. I had another forum member contact me about the same issue on the P2 but I'm afraid I'm not familiar with the P2 and its Wi-Fi module.

Thanks
2017-7-27
Use props
darrenh
lvl.1

United Kingdom
Offline

Friendship7 Posted at 2017-7-27 22:40
Hi Darren,

I'm only familiar with how to recover the Wi-Fi module in the P2V+ and not the P2 with FC200. I had another forum member contact me about the same issue on the P2 but I'm afraid I'm not familiar with the P2 and its Wi-Fi module.

Hi thanks for getting back to me.
2017-7-28
Use props
fans76590968
lvl.1

Italy
Offline

darrenh Posted at 2017-7-27 12:09
Hi i have the egg f200

me too...
if you find a repair for us, please share it!
2017-7-31
Use props
stev bo
lvl.2
United States
Offline

I purchased the Phantom from an individual, not a store. 6 months later, after winter storage, I han no live video feed.
I tried all the internet fixes, nothing worked. Called dji, since I did not buy from dji or an authorized rep, there was no warranty.
Cost to fix was in the hundreds of dollars, then some reported that after the wifi module was replaced, the same black screen appeared.
I got frustrated with an expensive quad and not being able to use it as intended. So I did some major modifications, didn't cost much. Now I have video, osd and actually like it better.
Here is a link to my youtube fix. I discuss what I did in video.
Hope this helps.
Stev
2017-8-4
Use props
crash1sttime
Second Officer
Flight distance : 1226368 ft
United Kingdom
Offline

darrenh Posted at 2017-7-27 12:09
Hi i have the egg f200

Hi

ive got a couple of spare cams with no FPV issue, you can send me yours with the RE and i can take a look at it, im not guaranteeing a fix mind you as the 3rd board failure is common but at least i can put your mind at rest.

email me if you want flymyphantom@outlook.com, i live in Manchester


Ive also flashed fixed the wifi on the P2V+ which seems to be fine, its easy to do if you dont mind a bit of find soldering work,
2017-8-5
Use props
pissed
lvl.1
United States
Offline

Bought my Vision 2 Plus when it first came out.  Haven't used it for a while.  Took it out a week ago; made a couple of flights with no issues -- except my batteries seem to need cycling.  Updated iOS to 10.3.3.  Tried to fly tonight and got no video feed.  Nothing has happened to the PV2+ -- just the iOS update.  "No internet connection,"  No video stream.  Did all the rebinding and steps suggested in these posts.  Interesting that DJI only responds "Send it in (for the $250 repair.)"  There goes my Mavic plan until I hear they actually have a customer service mentality.  I took the P2V+ out because I wanted to check it out before I sell it and buy the Mavic.  That's not going to happen.  Has anyone solved this?
2017-8-5
Use props
SteveR80
lvl.1
United States
Offline

Friendship7 Posted at 2017-7-27 22:40
Hi Darren,

I'm only familiar with how to recover the Wi-Fi module in the P2V+ and not the P2 with FC200. I had another forum member contact me about the same issue on the P2 but I'm afraid I'm not familiar with the P2 and its Wi-Fi module.

Hi Friendship7,
I have the same problem and will use your procedure.  However, I don't have a PC, only a MacBook Pro.  Can this be done on a MacBook Pro?
Thanks.
2017-8-6
Use props
Friendship7
lvl.2

United Kingdom
Offline

SteveR80 Posted at 2017-8-6 13:17
Hi Friendship7,
I have the same problem and will use your procedure.  However, I don't have a PC, only a MacBook Pro.  Can this be done on a MacBook Pro?
Thanks.

Hi SteveR80,

The sfh_DM36x flash programming tool only runs under Windows and/or Linux. MAC is not supported.

Thanks,
Friendship7
2017-8-8
Use props
MaxAdj
lvl.1
Flight distance : 177 ft
United States
Offline

I have the P4P+ with their built in screen and it won't show the camera view either. Firmware's updated, shows the right map, will take shots etc like you.  You aren't the only one!
2017-8-8
Use props
SteveR80
lvl.1
United States
Offline

Friendship7 Posted at 2017-8-8 05:14
Hi SteveR80,

The sfh_DM36x flash programming tool only runs under Windows and/or Linux. MAC is not supported.

Thanks Friendship7,
I'll get my hands on a windows machine and do the update.  I'll let you know how it goes.  Thanks again!
2017-8-8
Use props
Lasernerd
lvl.1
United States
Offline

Well crap,I have the updated P2V+ V.3.0 I have now lost all live video!! DJI step up to the plate,,,lots are moving to other makers of these type of aircraft..DJI you are losing customers...sad day.
2017-8-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules