Please select Into the mobile phone version | Continue to access the computer ver.
DJI P3 Pro No Signal
1750 33 2016-3-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
jerryjonz
lvl.2

United States
Offline


DJI phantom 3 Pro - No Signal
Quad is DJI Phantom 3 Pro (P3P) with Radio Control (RC), Nvidia Shield K1 (NS) tablet
Here is what I did
1 Charge P3P, RC, and NS batteries
2 Connect NS to RC
3 Download DJI Go, install on RC, set sw to P
4 Update RC and P3P software and firmware
5 Run DJI Go, set P3P, click Camera
6 Turn on P3P, green lights flashing, Radio Channel Quality flips between Good and Poor
7 Momentary RC handles down
8 RC shows good signal, HD shows good signal, battery 75%
9 No Signal in RED, NO video, motor's don't start

I see some other threads with this problem, they have no answer though.
Anyone know how to fix this problem, seems to be a common problem.
2016-3-19
Use props
jerryjonz
lvl.2

United States
Offline

Can ANYONE help me here?
2016-3-19
Use props
connorschulte
lvl.4
Flight distance : 261030 ft
United States
Offline

Looks like this is an error with the new firmware update. Other users have been reporting the same issue.
2016-3-19
Use props
GM01
lvl.3

Belgium
Offline

Try changing the sequence to: switch on remote control, switch on phantom, plug cable into remote control and Nvidia and the start the go app. If you still get the no signal, push the home button on go app (top left of the screen, the house symbol) and then push camera view.
2016-3-20
Use props
jerryjonz
lvl.2

United States
Offline

GM01 Posted at 2016-3-20 01:05
Try changing the sequence to: switch on remote control, switch on phantom, plug cable into remote co ...

Did all except Camera View, where is that button or switch?
still no picture
2016-3-20
Use props
jerryjonz
lvl.2

United States
Offline

connorschulte@g Posted at 2016-3-19 19:19
Looks like this is an error with the new firmware update. Other users have been reporting the same i ...

I see a lot of error reports, but no answer from DJI on how to correct problem
2016-3-20
Use props
GM01
lvl.3

Belgium
Offline

jerryjonz Posted at 2016-3-20 16:58
Did all except Camera View, where is that button or switch?
still no picture

On the Go App, where you select the type of DJI device you have.
2016-3-20
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

jerryjonz Posted at 2016-3-19 21:15
Can ANYONE help me here?

Make sure you have updated both the Aircraft and the Transmitter.    You may have to re-link the RC to the aircraft as well.  When you turn on EVERYTHING what color are the lights flashing under the aircraft?
this will let you know if you have connection from the rc to aircraft.  Also what color is the First light on the transmitter, not the white lights is it green or red, once again with everything on.  We need to establish if you have connection to the RC and aircraft.  If not must re- link first.  If you have a green light on the transmitter and green light on the aircraft then you are linked.    If you do have connection   but cant start the Motors you may have missed the RC update.  On the main start page does it say you need to update anyuthing ?  Also try and start your motors with the Auto-takoff option.  

Also go to the "General Settings"  turn everything On and  go to the "About" tab on general settings .  Please list all the versioons of firmware for the  RC   Aircraft  Go App and Camera

For example RC 1.5.80  Aircraft 1.7.60   Go APP 2.7.0   Please list yours like that so I can tell if you are indeed up to date.

Also did you register with DJI when you first bought this and before you did any updates.  If you updated before registering we may have a problem.  



Let me know -donnie
2016-3-20
Use props
raveneapoe
lvl.3

United States
Offline

I recently purchased a Nvidia Shield K1 to use with my Phantom 3 Professional.  Phantom, RC and tablet are all updated and charged, RC set to P.
My first try it connected but while flying I lost video and the screen froze at the point I lost video and was monotone B&W. Regained signal and everything was OK   My second attempt I didn't get off the ground,
good signal to RC but Go app didn't receive video from camera, just a black screen where the camera image should have been.  Reinstalled Go app, connected in proper sequence and got a giant image of the Go app on the screen, could only see a fraction of the app, finally managed to connect aircraft and it was also too large, the image wouldn't size to the screen on my tablet, much too large.
Reinstalled Go app, powered up in proper sequence and everything was back to normal...But I have a feeling it's not going to stay that way.   
2016-3-20
Use props
FAS1
Second Officer

United States
Offline

You guys need to be certain that your home wi-fi network isn't connected on the tablet and that the Phantom is. That has been my only source of not connecting.
2016-3-20
Use props
jerryjonz
lvl.2

United States
Offline

FAS1 Posted at 2016-3-20 12:03
You guys need to be certain that your home wi-fi network isn't connected on the tablet and that the  ...

Can ;you restate that another way, I do not understand it.
I can update my Ndivia Shield thru Wi fi. Is that bad?
2016-3-20
Use props
powersofts
lvl.2

Netherlands
Offline

Phantom 3 Advanced:
Yesterday "everything" updated:, RC and aircraft from 1.4 to 1.7 . no problems. But today when checking in my house I got  NO Signal on my nvidia shield k1, picture was Black and white.  To get things working I had to shut off the dji Go application and restart that. I didn't touch the aircraft.
after starting up dji go the camera picture was where!
I think the problem is related to dji go , maybe in combination with  the new firmware.

Not so happy with this behaviour. You don't want this happening in the air when flying.
2016-3-20
Use props
waynegknott
lvl.1

Canada
Offline

I just want to know when is DJI  going to address the growing issues with this update.  I think we could agree that just a simple acknowledgement would go along way. I  for one bought my PS as a starter in this new hobby with every intention to upgrade to either the Phantom pro or the P4, but since this upgrade I have have no camera view most of the time, weak signal or no signal and do not trust the app or the rc and any flight time has been with distrust in the equipment. My experience before the upgrade was great and was thrilled with both the photos and video and my standard was just fun to fly.
2016-3-20
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

jerryjonz Posted at 2016-3-20 16:22
Can ;you restate that another way, I do not understand it.
I can update my Ndivia Shield thru Wi f ...

  No , he is talking about the Standard you have the pro.  Do you have connection between aircraft and RC ?  if you want help please answer the questions in my post above .  I need the list of your firmware and do you have a green light on your transmitter when everything is on?
****Before anything:  DID YOU REGISTER WITH DJI BEFORE YOU DID THE UPDATES  ?    If you did not register with dji, where you give your e-mail information etc and did the updates beforehand . We may have a breach of protocal that I dont know if it can be corrected.
-donnie
2016-3-20
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

powersofts Posted at 2016-3-20 16:25
Phantom 3 Advanced:
Yesterday "everything" updated:, RC and aircraft from 1.4 to 1.7 . no problems. ...

You must start in this order: Transmitter First , Aircraft Second Then open the Go App  ,  do not even open the go app until you have the other 2 turned on and in proper  order..

Turn off procedure  Aircraft First, Tramsmitter Second Go app device third. The order is very important for proper function and retention of settings that get changed.

-donnie
2016-3-20
Use props
raveneapoe
lvl.3

United States
Offline

FAS1 Posted at 2016-3-20 15:03
You guys need to be certain that your home wi-fi network isn't connected on the tablet and that the  ...

Mine was in airplane mode. No WiFi.
2016-3-20
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

raveneapoe Posted at 2016-3-20 17:17
Mine was in airplane mode. No WiFi.

That Forum member was referring to the Phantom  Standard not Advance or Pro.  You situation sounds like a faulty Cable Between the Device and Transmitter ( Maybe ).  Also Enable  "Hardware Decode" on the Go App in the General settings, also clear the Video Cache as well.  Go to your Image transmission settings and make sure you are on a clean channel  signal.  Llower the slider settings to lower the range but increase the mbs to improve image quality ( This is on" Image Settings" page ) as well .  Also make sure your antennas are not crossed and are vertical when you are holding the transmitter.  If all else fails try another device like an I-pad.  You can also Re-set the Video on the Transmitter by pressing: Refresh the video link Press the C1 + C2 + Trigger (photo) buttons and keep them pressed and TURN OFF the controller.
By still keeping pressed the C1 + C2 + Trigger (photo) buttons TURN ON the controller.

good luck and let me know what helps, reply to MY post so I know..

-donnie
2016-3-20
Use props
connorschulte
lvl.4
Flight distance : 261030 ft
United States
Offline

jerryjonz, have you tried downgrading your firmware? You can download earlier versions from the product homepage on the DJI site. This issue seems to be coming from the newer firmware. Downgrade and see if that changes anything.
2016-3-20
Use props
FAS1
Second Officer

United States
Offline

Donnie Posted at 2016-3-20 18:39
That Forum member was referring to the Phantom  Standard not Advance or Pro.  You situation sounds ...

Absolutely correct, I was.
2016-3-20
Use props
FAS1
Second Officer

United States
Offline

jerryjonz Posted at 2016-3-20 17:22
Can ;you restate that another way, I do not understand it.
I can update my Ndivia Shield thru Wi f ...

I thought ...well, it doesn't matter, I was wrong. I apologize.
2016-3-20
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

FAS1 Posted at 2016-3-20 18:16
I thought ...well, it doesn't matter, I was wrong. I apologize.

No worries FAS1  you were trying to help,  that is what counts,  I was confused not knowing the Standard has a different system than the Advanced and Pro In the beginning too.

Thanks for trying,

-donnie
2016-3-21
Use props
jerryjonz
lvl.2

United States
Offline

Donnie Posted at 2016-3-21 05:26
No worries FAS1  you were trying to help,  that is what counts,  I was confused not knowing the St ...

I cannot update because my SD card (tried 4) will not click into the SD slot.
sent a note to customer service this morning, but no answer yet.
2016-3-21
Use props
leeandelson
lvl.2
Flight distance : 2128648 ft
  • >>>
United States
Offline

Did you upgrade to the most recent version of IOS. This solved my problem.
2016-3-21
Use props
Geebax
Captain
Australia
Online

jerryjonz Posted at 2016-3-22 04:18
I cannot update because my SD card (tried 4) will not click into the SD slot.
sent a note to custo ...

Take a look closely at the SD card slot, there have been a few people make the same report only to find they are trying to insert an SD card on top of the one that is already there.
2016-3-21
Use props
raveneapoe
lvl.3

United States
Offline

Donnie Posted at 2016-3-21 06:39
That Forum member was referring to the Phantom  Standard not Advance or Pro.  You situation sounds ...

Hi Donnie,  Thank you for the tips.  I haven't checked this thread for awhile, sorry for the delay. Cable is brand new DJI, plus I tried two others.
I did enable developer mode on the shield and changed the USB settings, that seemed to clear up the problem.
Weather has been bad here and has me grounded. If the problem persists I'll try all the things you've suggested.
And thanks for your help!
2016-3-26
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

raveneapoe Posted at 2016-3-26 10:10
Hi Donnie,  Thank you for the tips.  I haven't checked this thread for awhile, sorry for the delay. ...

Sure Raven, Happy to help,   do me one favor and let me know what helped,  I am always trying to help others and by getting some feed back as to what helps sure would  be nice.
Also the Apple I pads have been proven to provide the least amount of lag time and most user friendly to DJI products. A lad on You tube did a comparison, and I have to agree, my I pad air has been just great and I am about to upgrade to the I-pad Pro.  It is huge I know, but very light weight, and at My   age I nedd things as large as possible.   Just something to consider in the future Rave.  

Love your Avatar by the way.

Cheers- donnie
2016-3-26
Use props
raveneapoe
lvl.3

United States
Offline

Donnie Posted at 2016-3-26 13:58
Sure Raven, Happy to help,   do me one favor and let me know what helped,  I am always trying to he ...

I was using an older iPad that worked, but it pixelated with fast movement and there was too much time lag. ( not the latest processor)
I've purchased two Phantom 3's in the last 5 months, plus a lot of add-ons, I just can't bring myself to spend too much money an a tablet, thus the nvidia shield!
Sometimes I wish DJI had incorporated a dedicated FPV into their RC.

Have a great day!
2016-3-26
Use props
hilton571
lvl.3
Flight distance : 10220 ft
  • >>>
United States
Offline

I had a very similar problem when I updated my P-3, P-4 & Inspire 1. I was using a IOS iPad mini 3. I had to completely wipe out the Go-App and reinstall the app on both my iPad mini 3 and Nvidia Shield tablet. Now it seems to work. Its raining here today so no test. My Inspire 1 would not install the firmware update  until I loaded it with my Nvidia Shield android tablet. I got the red On Signal and my camera was so dark you could barely see an image. That all corrected when I used my android tablet with an updated version of the Go- App.
2016-4-8
Use props
sschu982
New
United States
Offline

Just in case someone else has this issue, this is what fixed it for me.  First, my situation: I have a Phantom 3 Professional.  I have an Android phone (Samsung Galaxy Note 5, unlocked).  I haven't used my Phantom in many months.  I flew it yesterday for the first time and it worked perfectly fine.  Today (as I should have before I flew it yesterday) I updated the DJI Go app, the new firmware for the controller, drone, camera, and battery.  Today, everything worked, except the image from the camera to my phone ("No signal").  I could control the Phantom, I could read everything it was doing (altitude, etc), I just couldn't see what it was seeing... again, it worked perfectly yesterday before updates.  It even took pictures (that I couldn't see until I downloaded them to my phone but they were there).  So, I read something on here about Wifi.  I turned the wifi off on my phone.  No luck.  Then, I turned the wifi off at the house... it magically worked.  Why?  I have absolutely no idea.  I rarely use this thing and I'm sure there is a lot of knowledge out that about how and why that interfered, but I had the exact same issue that other people have had for months (I was doing research to find a fix, so I saw a lot of the same thing).  Hope it helps someone.  I thought my expensive toy was trash and I needed to get it fixed.  Thankfully, not the case.  Maybe it was just me and a unique situation but if it wasn't, I hope this helps someone else.  If you're at your house, turn off your wifi at the house.  If that isn't the case, I hope you get it figured out.
2016-4-19
Use props
imagesbyjas
Second Officer
Flight distance : 286198 ft
Offline

sschu982@gmail. Posted at 2016-4-20 07:19
Just in case someone else has this issue, this is what fixed it for me.  First, my situation: I have ...

Confused..  How did turning the WiFi in your house help with an in-flight inability to see things on the screen (or am I reading it wrong)?  Sounded like you were flying when you couldn't see anything??
2016-4-19
Use props
sschu982
New
United States
Offline

imagesbyjas Posted at 2016-4-19 19:30
Confused..  How did turning the WiFi in your house help with an in-flight inability to see things  ...

I have no idea how it helped turning off my house wifi.  That is accurate, I could not see the camera display on my phone.  It said, "No signal" in red on the top of the screen.   It never left 5' off the ground but I had no camera display.  I could see all other data and had compete control.  I tried for two hours to get it to work, including other cables, devices, reloading the app.  Wifi immediately fixed it and i did nothing different at that moment.  I'm not a computer or DJI expert but it worked.
2016-4-19
Use props
imagesbyjas
Second Officer
Flight distance : 286198 ft
Offline

sschu982@gmail. Posted at 2016-4-20 09:33
I have no idea how it helped turning off my house wifi.  That is accurate, I could not see the cam ...

Are you flying this in your house, or someplace out and away from the house I guess is what I'm asking.  If in the house, have you tried it in an open field somewhere.  I guess I could see how your home wifi could be interfering if your indoors, but not if you were out and away from the house..
2016-4-19
Use props
jyurkyandsons
lvl.3

United States
Offline

imagesbyjas Posted at 2016-4-20 10:06
Are you flying this in your house, or someplace out and away from the house I guess is what I'm as ...

Sounds like someone is blowing smoke, most people on here are here to help.
2016-4-19
Use props
imagesbyjas
Second Officer
Flight distance : 286198 ft
Offline

jyurkyandsons Posted at 2016-4-20 11:10
Sounds like someone is blowing smoke, most people on here are here to help.

Agree, but trying to understand what conditions he was in that his home wifi both interrupted and then didn't by turning it off.  I have no issues with WiFi in the house if I'm testing things, but I haven't done the firmware upgrade yet...  Maybe there's something about the new fw more sensitive to WiFi??  Might explain dropouts some are experiencing when they're flying with new code??
2016-4-20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules