Please select Into the mobile phone version | Continue to access the computer ver.
P3 Standard Firmware update failed (?)
2496 6 2016-3-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
davestahr
New

United States
Offline

We just got our brand new P3 Standard.  My son was very excited, and I was doing everything I could to keep him on task with following the setup procedures.  I'd read in several forums and watched many youtube videos urging new users to be sure to do the firmware updates prior to using the unit.  So, after doing an on-ground short video clip and snapshot, that's what we did.  I used the app to do the update, the file downloaded successfully to the app, and we started the firmware updated.  The app however said firmware update failed, restart and try again.  Unfortunately, I don't think that was the case.  We were getting what I now know are the normal beeping sounds for the update.  Unfortunately, I listened to the app and restarted the drone.  Perhaps it meant restart the app?  Dunno.  Anyway, the drone comes on and now plays a loud, at first steady, long on/off beep that get more and more out of sync with each other the longer I leave the drone on.  After a few mintues it's more of a trill sound, like there are 3-5 different beeps that were once in sync with each other.

The LED on the front of the camera is just green, not flashing.


I'm an IT guy, so I popped a USB cable in to my laptop and saw the log file.


In the root of the SD card is the firmware file I presume was just downloaded: P3C_FW_V99.99.9999.bin


And an accompanying log file: P3C_FW_RESULT_AB.txt, its contents:


========== 2016.03.20 20:55:24 =====================
Packet: P3C_FW_V99.99.9999.bin
Upgrading ...


In the MISC/LOG folder is a file called P3C_FW_LOG_AB.txt, its contents:


[00384034]========== 2016.03.20 20:55:24. boot(15) ============
[00384160]Packet [C:\P3C_FW_V99.99.9999.bin] detected, card sn [0xc0ad7de6].
[00384194]Packet upgrade start...


[00384236]Packet checking...
[00384273]Packet vlink 01.04.0060 <-> 01.03.0050.
[00384345]Done.


[00384385]Version checking[1]...
[00384419][01 00][00] v1.13.4312 -> v1.14.4920 need upgrade
[00384455][01 01][00] v1.13.4312 -> v1.14.4920 need upgrade
[00384529][03 06][00] v2.4.10.7 -> v2.4.13.0 need upgrade.
[00384600][09 00][00] v0.1.0.9 -> v0.1.1.0 need upgrade.
[00384717][11 00][00] v1.7.0.0 -> v1.8.0.0 need upgrade.
[00384752]Done.


[00386786]Waiting for user confirm...
[00396819]Timeout, start upgrade automatically.


[00396904]Firmware upgrading[1]...
[00413185][01 00] Firmware upgrade start...
[00013938][01 00] Firmware upgrade finished successfully.
[00013974]Done.


[00014009]Packet [C:\P3C_FW_V99.99.9999.bin] resumed, card sn [0xc0ad7de6].
[00014045]Packet vlink 01.04.0060 <-> 01.03.0050.
[00014111]Version checking[2]...
[00014148][01 00][05] v1.14.4920 -> v1.14.4920
[00014188][01 01][00] v1.13.4312 -> v1.14.4920 need upgrade
[00014258][03 06][00] v2.4.10.7 -> v2.4.13.0 need upgrade.
[00014305][09 00][00] v0.1.0.9 -> v0.1.1.0 need upgrade.
[00014435][11 00][00] v1.7.0.0 -> v1.8.0.0 need upgrade.
[00014468]Done.


[00014503]Firmware upgrading[2]...
[00014666][01 01] Firmware upgrade start...
[00044982][01 01] Firmware upgrade finished successfully.
[00045025][11 00] Firmware upgrade start...
[00093670][11 00] Firmware upgrade finished successfully.
[00093922][03 06] Firmware upgrade start...

2016-3-28
Use props
davestahr
New

United States
Offline

I called in for support this morning and got an answer almost right away.  Thanks to the support staff, I was able to get this fixed.  A few things were causing my problem.

1) My smart phone was actually the culprit.  It was disconnecting from the wifi network on the RC.  To fix this, I went in to my phone's wireless settings, removed all previously saved networks, disabled all the fancy Google location services, scan for open networks, etc etc.  I then enabled AIRPLANE MODE to disable the cellular radio, then reconnected to the wifi on the RC.

2) The wifi is generated by the RC - not the drone.  This makes sense, but for some reason I thought the wifi originated from the drone.  During much of my testing I didn't even have the RC turned on.  Oops.  Yeah, that wouldn't work.

3) Even with the error beeping, the drone was able to be successfully updated.  I was thinking that the beeping noise meant the upgrade couldn't be started again.  That's not the case.

4) The upgrade process......... Mine hung/delayed quite awhile at 4%, 24%, 48%, 52%, and the magic one - 68% - the god forsaken error beeps stopped!  Ahhh....peace.   Something was finally happening now.  The gimbal started moving a bit, the drone is alive!  It hung then quite awhile at 69% and quite some time at 75%.  After several iterations of different beeps and noises, the app said the update was finally completed, with the percentage climbing from 75% to 100% rather quickly.

The whole process took about the documented amount of time, I would guess 20-30 minutes.

Now....all I have to do is wait for the wind to stop blowing in Nebraska.  I might have to wait awhile longer!
2016-3-29
Use props
normankong
New

Hong Kong
Offline

Thank Dave ! It works !
2016-4-3
Use props
aOsmT2HH2CjC
New

United Kingdom
Offline

You're a legend Dave, I was about to call up and send it back.
I got a call on my phone while installing the update and I think that stuffed it up the first time
2016-9-10
Use props
Greg75
lvl.1
Offline

davestahr Posted at 2016-3-29 10:27
I called in for support this morning and got an answer almost right away.  Thanks to the support staff, I was able to get this fixed.  A few things were causing my problem.

1) My smart phone was actually the culprit.  It was disconnecting from the wifi network on the RC.  To fix this, I went in to my phone's wireless settings, removed all previously saved networks, disabled all the fancy Google location services, scan for open networks, etc etc.  I then enabled AIRPLANE MODE to disable the cellular radio, then reconnected to the wifi on the RC.

Does it still show you "Packet: P3C_FW_V99.99.9999.bin" in the folder of the sdcard ?
2018-7-14
Use props
Fuzzie
New
Flight distance : 111637 ft

United States
Offline

I'm having the same issue.  I've tried several sd cards, batteries, etc.
I tried to start a new thread, but I wasn't allowed.
1-29 08:26
Use props
Fuzzie
New
Flight distance : 111637 ft

United States
Offline

I downgraded successfully, and now I am trying to upgrade again....fingers crossed!
1-29 16:15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules