Please select Into the mobile phone version | Continue to access the computer ver.
HOW TO FIX RC SIGNAL LOST ERROR AFTER UPDATE !
2761 7 2016-4-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
windwardbound
lvl.2

Offline

Short & Sweet!

Here's where I was.........I just bought a P4 and hadn't really read alot about it first.  I own a P3Pro and an Inspire 1 Pro and have been a loyal and frustrated DJI customer for a number of years.  I pulled everything out of the box discarding most of the literature, accessory junk, etc., and connected my Ipad 2 Air, the RC and turned on the aircraft.  Immediately, the RC is telling me I need upgrades.  So I follow along and upgrade evrything through the 2.7.1 GO app as I had heard that DJI wasn doing all upgrades through the GO app.  That's true up to a point.  At the end of the upgrade, the app says, "Can not fly", and, RC Signal LOST!  No other messages.  After doing some reading, I realize that contrary to the way I did things, the aircraft must be updated FIRST and then the RC.  Essential!  So I was stuck.  I called Drones Made Easy, they said there is a glitch in the firmware, blah, blah.  I said I'm sending it back and when the glitch gets fixed, call me and we'll start over.  Being the hard-headed type, I kept reading!  Great advice but nobody mentioned the process for the aircraft update and not a word about needing one of those cables that "new" owners pay no attention to.  Anyway, here's the cure when in this predicament,. (1) locate the adapter that came with the P4, I couldn't get my iPad Air 2 to help me so I pulled out my trusty iPhone 6s+, erased the DJI Go app (forget the version-do it).  Re-boot the device after loading the new (or same) app from the APP store.  Turn on the RC, DON't turn on the Aircraft and then the app.  When you get to the camera screen, push the home button, press and hold the grad hat for a few sec's and a downgrade Page will appear showing the availability to downgrade to 1.5.80 or whatever it was, download the downgrade, to your device.  When it finishes push the install downgrade to the RC.  Turn off RC when it's done.  Turn on RC, turn on Aircraft and then the GO app.  Now you will see in the aircraft status another message the you need upgrades.  WAIT until the display shows the Aircraft upgrade.  Click on the Aircraft upgrade ONLY.  You will be told to go to the HOME screen to download aircraft upgrade.  Go out of the camera screen (push on the house button on the top left corner of the app and the upgrade page will appear in a red banner acroos the top of the page.  Download the aircraft upgrade and then install it.  Next connect the device (I used my iPhone 6s+ to the aircraft using the same cable (USB to apple lightning cable) add that short adapter that came with your P4, now you can upgrade the aircraft ONLY.  After a few minutes, when it is done,  hook up everything as normal turn on RC, aircraft and the GO app and the status screen will now show just the RC upgrade. Start the upgrade process and allow it to download and then install the RC upgrade.  Turn everything off and then back on and NOW the status bar will show those beautiful words, "Safe to fly".  That's as short as I could make it, sorry, but the steps are important and the order in which there done is CRITICAL.  Man, there has to be an easier way!  When DJI starts speaking and thinking english then maybe these things might be a whole-hell-of-a-lot easier.  Probably no time soon.  I'm still waiting on my X5 to OSMO adapter, DJI!  Good luck!
2016-4-8
Use props
DJI-Paladin
DJI team
Flight distance : 2408 ft

Hong Kong
Offline

Glad to hear that everything works well.Thank you for your sharing.
2016-4-9
Use props
richardcooke
lvl.1

Offline

Very helpful!  Thank you for sharing.  This also works for the Inspire 1 - in case anybody updated the firmware on their remote before updating the firmware on the bird.
2016-4-10
Use props
nrechtman
lvl.3
Flight distance : 1555344 ft
Offline

There should be some error checking by the software to make sure and warn you not to upgrade your controller because the aircraft needs to be updated first.
2016-4-10
Use props
Livesteezy
New

United States
Offline

It worked!!!!
2016-4-21
Use props
I get "Get Firmware Version Failed"  inn the grad-hat page :/  There are no previous versions listed

Would buying a new controller work ?  (I have a wedding in 2 days which needs some aerial footage)



2016-5-12
Use props
net_box
Second Officer
United States
Offline

Why don't they just specify the following:

P4:
Latest Controller Version = 1.2.2.2
Latest Craft Version = 1.8.8.8.

Versions above are not real, they are for making my point

Then one downloads each bin file and save each on 2 sd cards, or one at a time if multiple sd cards are not available.

Just use the sd card firmware update at boot up.

The issue is that you can not use the same bin file to update both the craft and the rc.

Why don't they do it this way?  Why all these issues? Why all this chaos?

What am I missing?
2016-5-12
Use props
sigma27
New

Offline

Worked for me on my P3 Advanced.  I was just about to loose it!  Thanks!


2016-5-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules