Please select Into the mobile phone version | Continue to access the computer ver.
What Am I Missing? Go App keeps disconnecting
947 5 2016-4-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
smcfan
lvl.2
Flight distance : 14961 ft
  • >>>
United States
Offline

After the last two DJI Go updates I've had a issue with the app disconnecting from the remote control. It is happening every few seconds which makes it impossible to deal with. I have a iPad Mini 3 and a iPad Air 2 and it happens to both of them. What I have discovered is that it coincides with the iPads trying to use the remote control as a charghing source. Obviously, it can't be a charging source so the iPads constantly connect and disconnect as they try to see if they can charge off of the remote and if the Go App is running, it disconnects and reconnects right along with this action. I have tried multiple different lightning to USB cables with no success so I know its not that. I've deleted and reinstalled the Go App on both iPads and that didn't correct it but sometimes it has kept it from doing it for the first 15 minutes or so. All devices, remotes, aircraft are on their latest firmware or software versions.

I'm not in front of my iPads right now but I'm wondering if there is a setting in the iOS that will keep in from automatically trying to use whatever it is connected to as a charging source. Any ideas?

Thanks!!
2016-4-28
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

    You may have a damaged USB port on the Transmitter.  I would firmly hold the cable in place near the USB output on the RC and see if the connection breaks, or wiggle it there and see if it goes out.  It is not uncommen for these to become damaged with the constant  use of the USB.  ( This of course would be with the Ipad on and the RC on with Go app open )

Make sure all of the cables you have are of HIGH QUALITY , dont get the ones at the gas station. I purchase only Apple cables from the apple store.  

When you are using the cables to charge from a wall outlet do you loose the charge icon ? that would indicate a bad cable or bad port on the I pad.  I am not aware of any way to change the Port to not automatically try to connect,  The I pad is NOT charging when connected to the RC, so I dont quite know what you mean by that.


Make sure you have a full charge on the I -pads and you only have the Go App open.

TIP: Be sure to enable the "Hardware Decode" On the Go app so the processor does not work so hard .  (This is a bonus tip, will not apply to your problem, works well on I pads with the Go app)

Let me know- donnie


2016-4-28
Use props
Farnk666
Captain
Flight distance : 1711394 ft
Australia
Offline

There are reports of USB ports on the RC's  having an intermittent fault - you've tried different cables and iPads already.
Looks like an issue with your RC.
2016-4-28
Use props
DJI-BladeStrike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

You could try to reset the USB board.. Take off the rear USB board cover. carefully remove the three ribbon cables and power on the RC and then power off after about 5 sec.
Here is a link to my blog over on RCG, this will show you the three ribbons that I'm talking about.

http://www.rcgroups.com/forums/showthread.php?t=2422113
2016-4-28
Use props
smcfan
lvl.2
Flight distance : 14961 ft
  • >>>
United States
Offline

Thanks for the tips! I will try to reset the USB board later tonight to see if that works. Donnie-All cables tried are Apple, Hardware Decode is enabled. I know it can't be charged by the RC but the "charge" symbol keeps popping on and off next to the battery symbol on the iPad when connected to the RC. The iPads charge just fine when using a wall outlet, no issues whatsoever.
2016-4-28
Use props
markaguille
Captain
Flight distance : 2031818 ft
Guernsey
Offline

Did you try reconnecting the RC to you AC. I had a similar problem and this fixed it for me.
2016-4-30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules