Please select Into the mobile phone version | Continue to access the computer ver.
Speed in P mode problem
882 16 2016-5-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
jameswarden
lvl.2

United Kingdom
Offline

Finally managed to get out with my replacement P4 yesterday. It was fairly successful, however I did get the transmission issues with the new app which I've rolled back to the previous version. Luckily I had an iTunes backup of my iPad, the issue has now disappeared.
The main issue I noticed with this unit was that in p mode the maximum forwards speed I could achieve was around 5 m/s. It appeared normal backwards and laterally, but forwards flight seemed significantly slower than my previous unit, and this was confirmed when I checked the flight log back at home.

Has anyone else had this issue? Presumably it has to do with the obstacle avoidance, but I was under the impression that in p mode with OA on 10m/s was achievable.

I appreciate any thoughts or input on this

Jay

2016-5-29
Use props
labroides
Captain
Flight distance : 9991457 ft
Australia
Offline

It should make 10 m/s with object avoidance on and 15 without.
2016-5-29
Use props
jameswarden
lvl.2

United Kingdom
Offline

labroides@yahoo Posted at 2016-5-29 12:40
It should make 10 m/s with object avoidance on and 15 without.

Labroides, thank you for the info. That was as i suspected.

I took my P4 out again today for another couple of flights, and tried it again and in P mode the forward speed seems to be limited to 5m/s.

As i said before, laterally and backwards seems to be fine with the OA on, only the forward speed is limited. This time i tried switching between the different flight modes to see if it was some kind of glitch, no luck. In P mode with OA off, all seems normal?

Has anyone else experienced this? I may attempt to re upgrade the firmware on the unit to see if that makes a difference.
2016-5-29
Use props
jameswarden
lvl.2

United Kingdom
Offline

I have done a fresh install of firmware and completed all calibrations, so will go for another flight today to test if I'm still getting this issue.
2016-5-29
Use props
calls4u2
Second Officer
Flight distance : 211604 ft
United Kingdom
Offline

I got my P4 replaced, not flown the new bird much as I decided to break my hand :/ the new P4 appears to be significantly slower than my original. Clean all sensors, and perhaps do the obstacle calibration too. I'll test mine properly and post logs once my hand heals! Let me know if cleaning and calibration helps as it'll put my mind at rest too!
2016-5-30
Use props
jameswarden
lvl.2

United Kingdom
Offline

calls4u2 Posted at 2016-5-30 11:34
I got my P4 replaced, not flown the new bird much as I decided to break my hand :/ the new P4 appear ...

Sorry to hear about the hand hope it heals soon! I have re installed all the firmware, all sensors are calibrated and cleaned, but I still get a reduced forward speed in P mode of 5 m/s. As I mentioned laterally and backwards it can achieve the specified 10 m/s.

It's very strange! If I have the patience today I might try again a clean instal of firmware, app, calibrate all the sensors (again inc the OA sensors) and if there's time test fly again.

At least my tilted gimbal is now holding horizontal after a slight adjustment in app for the time being at least!
2016-5-30
Use props
calls4u2
Second Officer
Flight distance : 211604 ft
United Kingdom
Offline

Was hoping to read good news, I've reviewed my flights and seem similar. Just over 5mps on forward, other directions look to be around 10. Once I get her back up in the air I'll fly some squares to know for sure. Didn't know if it was just me, but my first p4 definitely seemed a lot faster.
2016-5-30
Use props
jameswarden
lvl.2

United Kingdom
Offline

calls4u2 Posted at 2016-5-30 17:02
Was hoping to read good news, I've reviewed my flights and seem similar. Just over 5mps on forward,  ...

I contacted DJI online support today, they weren't overly helpful, however they  suggested I retry downgrading and re upgrading the firmware, perform all the calibrations again and if the problem persists that it may require sending in for servicing.

I'm going to do this again and see if there is any change, but part of me rightly or wrongly is considering just accepting this issue?!? I mean i can always just turn off the OA or switch to a different mode if I require the extra speed? I don't like the thought of spending another 3 weeks waiting to use a drone I spent so much money on.

Let me know if you have any luck or find a resolution. It seems to be a relatively rare issue.
2016-5-30
Use props
calls4u2
Second Officer
Flight distance : 211604 ft
United Kingdom
Offline

Extreme wind here today, upgraded firmware and calibrated all sensors. Hopefully get to fly again soon. Firmware made any difference to yours?
2016-6-1
Use props
huntcool001
lvl.4

Hong Kong
Offline

jameswarden@bti Posted at 2016-5-30 21:45
Sorry to hear about the hand hope it heals soon! I have re installed all the firmware, all sensors ...

Have you tried a different version of the firmware?  

It does seem strange and you may have to return your bird again.
2016-6-1
Use props
jameswarden
lvl.2

United Kingdom
Offline

I've upgraded to the latest firmware, and took the p4 out this morning, the problem seemed to have resolved itself but my testing was cut short as it started to rain.
2016-6-1
Use props
calls4u2
Second Officer
Flight distance : 211604 ft
United Kingdom
Offline

So your speeds seem okay now James? Mine still seems to suffer, and the altitude drop remains though once the bird has been up awhile it *seems* to lessen.
2016-6-2
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

jameswarden@bti Posted at 2016-6-1 23:18
I've upgraded to the latest firmware, and took the p4 out this morning, the problem seemed to have r ...

I also just updated several P4's and no issues at all.
2016-6-2
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

calls4u2 Posted at 2016-6-3 05:23
So your speeds seem okay now James? Mine still seems to suffer, and the altitude drop remains though ...

Can you please post a link to your last DAT file and I will have it analyzed.
2016-6-2
Use props
calls4u2
Second Officer
Flight distance : 211604 ft
United Kingdom
Offline

DJI-Ken Posted at 2016-6-2 22:35
Can you please post a link to your last DAT file and I will have it analyzed.

Thanks Ken, I'll post it here tomorrow, There is another guy on here having similar issues though not sure if the new firmware has helped for him. Maybe if we get his too so your guys have something to compare.
2016-6-2
Use props
jameswarden
lvl.2

United Kingdom
Offline

calls4u2 Posted at 2016-6-2 22:53
Thanks Ken, I'll post it here tomorrow, There is another guy on here having similar issues though  ...

Have a day off tomorrow so planning on taking my p4 out to test properly with the new firmware and after completing all the calibrations. Will update you all on my progress and upload the flight logs if I'm still having issues
2016-6-2
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
Offline

calls4u2 Posted at 2016-6-3 05:53
Thanks Ken, I'll post it here tomorrow, There is another guy on here having similar issues though  ...

If you are seeing a slight altitude adjustment (5ft or so) while going from fast forward flight to stopped that is normal
2016-6-2
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules