Please select Into the mobile phone version | Continue to access the computer ver.
Firmware 1.2.1.06 --> ???
696 2 2016-6-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
vincenzomiceli
lvl.4
Flight distance : 1696781 ft
Ireland
Offline

Hello folks,

I have kept my Inspire 1 (X3) on 1.2.1.06 sfor the last year and I have been very happy with it. Haven't experienced any issues beside some very rare need to restart the DJI Pilot app.
However I'd like to try the FPV goggles that take a cell phone as a screen and I would probably use Litchi as control app as it supports splitting the screen. I don't think Litchi works with 1.2.1.x firmware though as even DJI discontinued the pilot app in favor of DJI GO so the question is:

what firmware should I upgrade to? I'd like to know the opinion of the owners that have followed the FW evolution with regards to stability and trouble free behaviour. I'm not interested in features like the various follow modes, tracking etc...

Thanks!!!

V.



2016-6-11
Use props
vonbaron1
Second Officer
Flight distance : 42014 ft
United States
Offline

I believe you need to go to 4.0 something for Litchi to work via FW 3.0 first.  I am also running the same FW version as you and works just great and have no plans on upgrading.  Just not worth it but that's totally up to the pilot and your needs.  Its the between the rock and hard spot thing.  Besides, your old I1 may be worth more for selling reasons as well.
2016-6-12
Use props
vincenzomiceli
lvl.4
Flight distance : 1696781 ft
Ireland
Offline

vonbaron1 Posted at 2016-6-12 22:55
I believe you need to go to 4.0 something for Litchi to work via FW 3.0 first.  I am also running th ...

Thanks vonbaron1, that's why I have stopped any updates... may be I can get a cheaper P3 to play with these other "fun" features and leave alone the Inspire 1 with its brute force 1.2.0.6.
2016-6-13
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules