Please select Into the mobile phone version | Continue to access the computer ver.
Litchi + DJI GO + Samsung Tab S2 Problem
6891 23 2016-7-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

FACTS:
Samsung Tab S2 Android version 6.0.1
DJI GO app latest version
Litchi app latest version
Phantom 3 Pro Laterst update  Controller latest update

PROBLEM:
I week ago all was good. I was able to choose which app I wanted to fly with as soon as I fired up the RC.
Today I have no choice. The last time I flew I used the Litchi app and now when I fire up the RC the Litchi app auto starts and connects to the Phantom. If I try to open the Go app after I shut down the Litchi app the Go app will start but it will not connect to the Phantom. The only way I am able to fly with the Go app is to delete the Litchi app off the Tab.

THINGS I'VE DONE:
Settings/ applications/ Application Manager/ Litchi/ clear default..............The Litchi app did not show as the default app. I tried to set it as default but the "set as default" button will not click....................................next................................

Settings/ applications/ applications manager/ DJI GO clear default............The DJI GO app was not set as the default app. I tried to set it as default but the "set as default" button will not  click....................................next................................

I reset the tablet back to factory out of the box. Ereased everything! Reinstalled the DJI GO app and the Litchi app. I connected the tab to the RC and fired up the RC. The tab gave me a choice between both apps. I selected the GO app and the GO app started and connected to the Phantom. I shut everything down and restarted. The tab did not give me a choice...the GO app started and connected. I shut down the Go app to start the Litchi app and it will start but it will not connect to the Phantom....unless I delete the GO app off of the tab.

Can someone help me with this problem!!!??

2016-7-10
Use props
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

I'm bumping this
2016-7-11
Use props
Sebb
First Officer
Flight distance : 498199 ft
Germany
Offline

well, the little i know about this probably wont help. i fly both apps, switching back and forth with no problems at all (knock on wood) on a Oneplus 2 and Galaxy Tab s 10.4.

but i would check
- if USB mode on your android device is set to "Debug enabled" and MTP connection mode.
- turn off WIFI on android device
- set Litchi Settings/Camera/Transmission Channel to: Auto
- start order: RC, phantom, (wait till gimbal beeps 2x) connect USB, wait for auto-popup asking which app to open. if it doesnt connect to Litchi, power cycle Phantom a few times and unplug/plug USB a few times. give it a minute to connect each time.

let us know.

2016-7-12
Use props
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

Sebb Posted at 2016-7-12 13:25
well, the little i know about this probably wont help. i fly both apps, switching back and forth wit ...

What I found out so far is that the android upgrade to marshmallow 6.0.1 made a change to the usb connection
2016-7-15
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
Offline

mjlstudios Posted at 2016-7-16 03:57
What I found out so far is that the android upgrade to marshmallow 6.0.1 made a change to the usb  ...

It seems your tablet wants to take control of the first app that uses the USB.
It has to be something in your settings that can remedy it.
2016-7-15
Use props
mochorm
lvl.3
Flight distance : 940148 ft
Canada
Offline

It's actually the opposite Ken, it remembers the last app that used the USB port. Android in their wisdom decided with Marshmallow we all only use one app with our USB port !!!!! Go figure ??

Solution:
So just go to settings and under applications find the DJI Go App. See where it says "Set as Default" touch that tab and clear defaults. You will then be asked which app you want to use next time.
You will have to do this each time you change apps.
2016-7-15
Use props
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

mochorm Posted at 2016-7-15 19:05
It's actually the opposite Ken, it remembers the last app that used the USB port. Android in their w ...

I wish it could be as simple as that! In settings under applications both Litchi and Go are not set as default, and both can not be set as default if you try to click on the "set as default" button, and, both will not click to clear default. So under settings/applications the only thing I am able to get to click for the Litchi and GO app is the "force stop" button which does nothing when I do click on it!
2016-7-16
Use props
rprachun
lvl.2

Canada
Offline

mjlstudios Posted at 2016-7-16 05:34
I wish it could be as simple as that! In settings under applications both Litchi and Go are not se ...

Hi. That is correct. You will NOT be able to set the "default" state. Marshmallow 6.0.1 version sets this with the actual USB connection. When you engage the controller with USB plugged in to the tablet (or disconnect and reconnect the USB cable), Marshmallow decides what app will be default and memorizes this choice. Think this way:

No Default App set previously by a USB connection - ask user for default app
Default App already set - launch the app

Only way I can find to remove this new 6.0.1 behavior is as Mochorm says, you must manually remove the default app setting through your Application/Default menu items.

Very frustrating! Thanks Google.
2016-7-16
Use props
mochorm
lvl.3
Flight distance : 940148 ft
Canada
Offline

mjlstudios Posted at 2016-7-16 03:34
I wish it could be as simple as that! In settings under applications both Litchi and Go are not se ...

Which model of the s2 do you have? I currently running the T-710. It does sound like yours is acting differently, so I'm thinking you have the T713.

In my case the default action is set when you first start the app. So if ran the DJI Go that app will always start when the USB is plugged into the R/C.
So if I want to run Drone Deploy , I have to go to Application info for DJI Go App, under "set as default" the DJI Go App is listed. I touch that tab and get a pop up with a target that says"Clear Defaults", touch that target and DJI Go disappears and the text "None Set As Default" appears.

Now when I connect the tablet to the R/C I get a pop up asking me if I want to use DJI Go or Drone Deploy and whichever app I select is now the default.

I had a T-713 (Samsung used the same S2 name for both tablets?? ) which came with v6 of the O.S. The T-710 comes with v5 of the O.S. and you need to upgrade to v6.
I could not get the T713 to work with two DJI apps installed, period. And even with DJI Go app installed the ONLY way I could get it to connect was to reset the tablet once everything was hooked up and started.
I may do a factory reset of the T710 tablet to see if vr. 5 of Android will load up and forget about v6 until they sort out the USB issues. That way things will work as they should and I'll be asked which app I want to use each time the R/C is started
I assume a factory reset will result in v5 of the O.S. being installed, but I'm not %100 sure??
2016-7-16
Use props
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

mochorm Posted at 2016-7-16 14:07
Which model of the s2 do you have? I currently running the T-710. It does sound like yours is acti ...

I have the t-710 with v6
2016-7-16
Use props
welldodo
Second Officer
Flight distance : 50430 ft
United States
Offline

mjlstudios Posted at 2016-7-16 14:00
I have the t-710 with v6

The problem with 6.01. is device dependent. My Nvidia works fine using 6.01. I have Litchi and DJI Go on it and have no problems connecting with either.

I have a Galaxy S5 and when updated to 6.01 I cannot connect to either Litchi or DJI Go. I must uninstall one to use the other. This is a known problem with Android 6.01 involving USB connections. Changing USB options in pull down menu or developer options has no affect.
2016-7-16
Use props
mochorm
lvl.3
Flight distance : 940148 ft
Canada
Offline

mjlstudios Posted at 2016-7-16 13:00
I have the t-710 with v6

Strange that your T-710 is not working the same as mine ?

2016-7-16
Use props
benleo000
lvl.2

Hong Kong
Offline

I have tab s2 T-813,android 6.0.1.  Just same as you cannot connect. Unless I hook up everything and ten restart the tab.
2016-7-19
Use props
Sebb
First Officer
Flight distance : 498199 ft
Germany
Offline

mjlstudios Posted at 2016-7-16 21:00
I have the t-710 with v6

Saw in another thread that you were flying again with Tab S2.

So how did you solve your problem? Would be nice to share it, since you were the one starting the thread.
2016-7-20
Use props
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

Sebb Posted at 2016-7-20 10:47
Saw in another thread that you were flying again with Tab S2.

So how did you solve your problem? W ...

I've never stopped flying with my Tab s2! I never said I had to stop flying with it either! I have to do exactly what I said I have to do in order to change from one app to the other in my previous posts. Android is the cause of the problem, and until android fixes the 6.0.1 version I will have to continue do what I've been doing.
2016-7-20
Use props
Sebb
First Officer
Flight distance : 498199 ft
Germany
Offline

mjlstudios Posted at 2016-7-20 16:57
I've never stopped flying with my Tab s2! I never said I had to stop flying with it either! I have ...

ah ok sorry, i thought you couldnt connect at all.

but you mean Samsung is the reason for problem, not Android 6.01. plenty people flying fine with both apps on 6.01 on other devices...
2016-7-21
Use props
dead.donkey.dd
lvl.1

United Kingdom
Offline

The problem is the combination of 6.0.1 and some but not all tabs. I have the Android's own tabs, the Google Nexus 7 and the Google Nexus 9. Neither will work with any combination of GO or Litchi whatever you do to the USB settings. I spent a harrowing day removing 6.0.1 completely from both tabs and reinstalling 6.0 Now both tabs work fine, but what a to do!
2016-7-21
Use props
mjlstudios
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

dead.donkey.dd Posted at 2016-7-21 14:20
The problem is the combination of 6.0.1 and some but not all tabs. I have the Android's own tabs, th ...

I agree! I read the procedure on deleting and installing 6.0 and it sounds a little scary!
2016-7-22
Use props
flippnbits
lvl.2
Flight distance : 487992 ft
  • >>>
United States
Offline

For what it's worth I'm having the same problem with a Samsung Galaxy Tab A. Prior to the marshmallow upgrade everything worked fine.
2016-7-23
Use props
todd10
New

Offline

flippnbits Posted at 2016-7-23 23:14
For what it's worth I'm having the same problem with a Samsung Galaxy Tab A. Prior to the marshmallo ...

Wow, what a mess this has become.

I am fairly new to quad-copters and I have only about a half dozen flights to date so this has been a frustrating experience.

I started out using DJI Go on my LG G3 and then moved up to my iPad mini 2 for a little more screen real-estate. Everything was working well and I was pretty impressed with things. (All DJI Go at this point).

I then started researching other apps like Litchi, Autopilot and Ultimate flight. I settled on Litchi as it seemed to have the feature set I wanted and also decided to stick with Android. One factor with that was I was disappointed with the Mini 2's display in sunlight.

I decided I needed a dedicated android tablet for my new quad so went the budget route and bought a Samsung Galaxy Tab A 7" on sale for $120. Found out the old adage of "You get what you pay for" applied here as this tablet was slow with a sub par display and the most awful WiFi performance of any device I have ever owned, and there have been many.

So, time to pony up for something in the premium range to augment the premium P4 and after much research went with the Galaxy Tab S2 8" (Model T713) and LOVE the display, even in sunlight. Plenty fast and 32gb storage.

.... I guess my research wasn't as thorough as I thought!


After spending many hours this weekend battling this very same  DJI/Litchi connection issue when I should have been flying I have found a workable solution, "workable", not ideal.

As has been discussed here in a somewhat fragmented compilation here is what I am doing and it works very reliably.

Of course, USB debugging ON with MTP mode for USB data transfer.

Clear the default app settings for both apps. Android 6.0.1 botched this function as earlier posters mentioned.

Now, when I plug in my USB cable from the controller I am asked for the default app to use with NO option to select "one time only" as we have become accustomed to in previous flavors of android.

Here is the trick. At this point which ever app you selected will automatically become the default app loaded when you plug in the controller. It may or may not connect at this point.

What I have found is that you need to POWER OFF the S2. Make sure the USB cable is plugged into the RC transmitter (RC powered on) and power up the S2. Which ever app you selected before powering down will auto load and connect as expected. If you want to keep using that app your set from here on out. The thing to remember is you may need to "cold boot" the S2 with the cable connected to RC (RC powered on). The Phantom doesn't need to be powered on until after the S2 has booted. Either way, Phantom powered on before or after it will connect.

Now if you want to switch to the other app (DJI Go/Litchi) unplug the USB from the S2, clear the app defaults as others have mentioned (force stop which ever was running last as a precaution). Plug the USB cable back in and you will be prompted again for which app to use. Select the one you want and it will launch but most likely will NOT connect. Here again, power down the S2 and cold boot it with the USB connected to the powered on RC, your newly selected default app will auto launch upon boot and will now connect to the bird as desired.

The trick seems to be the COLD BOOT while plugged into the powered on RC. The Phantom can be powered on either before or after cold booting the S2. It will continue to work with the same new defaulted app as long as you do NOT disconnect the USB from the RC. Even after exiting the app and relaunching it will continue to connect normally as long as you have not unplugged the USB cable. If you unplug the cable or power off the RC you will more than likely need to cold boot the S2 again with the USB connected to the powered RC.

I hope this saves at least one of you some headache.

Again, this process is not ideal but I can at least have both apps installed and can switch if the need arises. Up until this point I was uninstalling one of the apps to make the other work.

Todd
2016-7-24
Use props
RiffRaff
New

United States
Offline

todd10 Posted at 2016-7-24 21:07
Wow, what a mess this has become.

I am fairly new to quad-copters and I have only about a half do ...

One other point that have discovered this past week is depending on the device it depends on which order the applications are installed. There seems to be some correlation that if DJI go is installed after Litchi or DJI Ultimate Flight things work better in Android 6/6.0.1. Even uninstalling DJI Go and reinstalling as the last Phantom app seems to straighten things out. There is still the problem of assigning the default app in order for things to work best.
2016-7-29
Use props
benleo000
lvl.2

Hong Kong
Offline

I also have a new Tab s2 9.7 (T813), just got it couples week ago and which is natively come with Android 6.0.1, same problem, cannot connect to Phantom 4, this is not the default app setting issue, I believe that, this is the compatibility issue between DJI RC controller and Android 6.0.1.  My friend also have a old Tab S2 (T810) with Android 5.1, no problem at all.  

My symptom is, when plug in the DJI RC, the "USB mode" in android development options will flipping between charging and MTP (if working normal, the mode should be change from MTP to Charging after plugin the DJI RC, you have around 10% chance to get it work), and by default, the USB mode is MTP.  I think this is not related to apps, this is related to android and DJI controller, the apps not even started.

After playing around, I found 2 work around:

The first one is, plug in RC and power on, and then restart the tab, the DJI GO should be connected now, but every time you switch off the RC or unplug the USB cable, you have to do it again and restart the TAB.

The second work around is, before you plugin DJI RC or power it on, you have to change the USB mode to "Charging", and then power on the DJI RC, after that, you have to change the USB mode to "RNDIS", it should be good to go now, and USB mode should now be indicated "Charging" again.  Once you disconnect the cable or power off the RC, the USB mode will change back to "MTP" by default, next time before you power on the DJI RC, you have to go over the previous steps (change USB mode to "Charging" first.........)

I hope DJI can look into this problem and release a new firmware for the DJI controller to make it compatible with new Samsung Tab S2 (T713 & T813), as this is the best android tab currently available in Market.
2016-8-5
Use props
diondodd
New

Australia
Offline

I am having the same problem. Works fine on ios and figured out the same by changing usb to RNDIS it seems to work but it is a bit of a pain having to do this. Wounder if downgrading the android software might fix it?
2016-8-5
Use props
DJI_QA_sucks
lvl.1
Flight distance : 645285 ft
United States
Offline

Sorry to bump this old thread... just wondering if anyone has  advice on best versions of android to use with a galaxy tab s 10.5.
i rooted the thing and upgraded to 7.1.1 and djigo4 works perfectly.  Litchi is a pain in the butt though...doesn't start missions consistently...crashes...etc.

before i waste a lot of time flashing and restoring roms, just wondering if anyone has done the busywork for me.

thanks

by the way i recommend rooting and flashing a lightweight variant of android... the stock touch wiz android 6 was super sluggish and pathetic with djigov4 and litchi
2017-9-17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules