Please select Into the mobile phone version | Continue to access the computer ver.
Master remote disconnects in flight
2634 13 2015-1-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

I have a new Two-controller Inspire which has flown well but for one important issue. I am using iOS App 0.92 beta. When flying with only the master controller, the controller disconnects from the craft at random irrespective of the distance from the craft. Flight controls remain fine but all telemetry and video data disappears. The craft does not RTH and remains stable or in flight as instructed. Interference from other 2.4GHz transmitters can safely be ruled out. I have flown to 600m away without issues of loss of control (but loss of video). The loss of transmission does not cut out video recording as with another user who posted about a fault.
Sometimes, the link re-establishes spontaneously, sometimes, when I go to the 'transmitter' icon, I find the mode switched to 'off'. After re-engaging 'Master' mode, the link comes back after about 10s. I have searched this forum and others and have not found others with this problem so I wonder if I have a faulty electronics package or if there is some setting I've not entered correctly.


I have P2s with Lightbridges and they work fine. I've been flying for some time. Any advice Tahoe Ed in particular?
2015-1-29
Use props
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

I swapped the Master and Slave controllers after re-linking so that the Slave became Master. This seems to have resolved the problem for now. This is a very bizarre problem and I'm hoping that others chime in on this. I have been in touch with DJI support. Waiting to see if I need to replace or if there is some hidden setting or glitch that I'm not aware of.
2015-1-30
Use props
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

Looks like there was some linking related bug. The swapped controller works fine and I have had no signal dropouts. The craft is much more stable than the P2 in wind (not that the P2 is bad) but its really like having a tripod mounted camera in mid-air.

The straight lines one gets out of this camera is an understated feature. Newbies should not be coloured by the critics... The exposure, shutter and white balance control on this bird are far superior to what one can get off a P2 running a GoPro 3/3+.

Am overall very satisfied with this bird.
2015-1-30
Use props
Colonel Angus
Second Officer

United States
Offline

Might help not to use the interface cables included with the copter they are sort of crummy I use the Tablet cord that seems to work just fine.
2015-1-30
Use props
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

This was not a cable problem. After further testing, its clear that the RC is faulty as the other one of the pair works fine. In addition, I've narrowed the fault down to the 'light bridge' module of that controller. Thankfully, flight controls remained intact during the periods of 'disconnect' or there would have been a crash. Its just the video / telemetry section that fails. Have written to DJI and am awaiting a replacement.
2015-1-30
Use props
dundee
Captain
Flight distance : 33550 ft

Thailand
Offline

I have the Inspire 4 days and no maiden flight yet  (propguards, etc...)
Im testing the Inspire on my desk (without props mounted) and with 1 Transmitter.

I have same issues here. (but im using Samsung Galaxy tab S 10.5")
Ohhh and btw. The Samsung Tab5 10.5 does NOT fit the holder on the remote. ( Ipads are ok though)

Random disconnect from the craft. But then connects again automatic after a few seconds (1 to 5 seconds)

Yesterday, the 2th TX arrived, so i will try to do new tests (1 and 2 controllers connected) and see how it goes.
I will post my findings here later.

Note: App IOS version 0.9.2 for the Ipad does not work for me. (no connection at all)
But i first try and see with the ANdroid V1.02.00.16 first before i loose more time in the apple app.

Talking about time.
At the moment at least for me the Inspire1 is not 'a ready to fly' as DJI says, its a' ready to experiment'.

Anyways, these experiments before my maiden flight, brings me indepth knowleghe about this incredible bird.










2015-1-30
Use props
peter.a.bosmans
lvl.3
Flight distance : 2691007 ft
  • >>>
Belgium
Offline

Flying an Inspire dual control as well. Same problem, but here it's with the slave controller. Random signal loss. Need to restart the app (Android) completely and then everything is fine again. Going to try & swap both RC's to see what happens, but i suspect a faulty one...
2015-1-31
Use props
rwt0227
lvl.2

United States
Offline

dundee Posted at 2015-1-31 13:58
I have the Inspire 4 days and no maiden flight yet  (propguards, etc...)
Im testing the Inspire on m ...


BTW - Samsung Tab S 10.5 MOST DEFINITELY DOES FIT in the controller, as it's the ONLY thing I've been flying with since I got my Inspire nearly 4 weeks ago. You just can't be a wus about it putting it in. It's an extremely tight fit - in fact to make it better I carved the bottom foam out of the controller holder. It's still a push to shove it in there, but most definitely better than before and MOST DEFINITELY FITS. The screen size is worth it.

Don't be afraid - give it a shove (insert the top end first and shove the bottom up and in).
2015-1-31
Use props
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

Thanks all for chiming in. There might be a QC issue with a few remote controllers; either that or there is some  parameter setting (tolerance of video carrier signal degradation or some dynamically adjusting transmission bandwidth algo)  that might be addressable through a firmware upgrade;   see my cross post in another forum and other replies:
http://www.inspirepilots.com/thr ... ight.778/#post-7816
2015-2-1
Use props
Blade_Strike
Super Moderator
Flight distance : 816594 ft
  • >>>
United States
Offline

I would contact support. If the other radio doesn't replicate the issue then it has to be a faulty tx. Have you tried to load firmware again?
2015-2-1
Use props
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

Thanks Blade. The other radio is fine.  Reloading the firmware did not help. Support has been contacted and they agreed that the transmitter should be replaced. I thought you might want to broadcast this to others. Will add a video link when I have time to upload it.
2015-2-1
Use props
slabella.consul
lvl.3
Flight distance : 1483192 ft
  • >>>
United States
Offline

I too had the same issue and took my slave and made it the master and all is ok. I returned the defective master back to the distributor for a new replacement rc.

You should do the same.

Ps. I did a lot of debug before the return then master Rc, the salve always worked and never lost video or telemetry data, just the master.

Best regards,
Steve
2015-2-1
Use props
Mike-the-cat
Captain
Flight distance : 14411854 ft
  • >>>
Singapore
Offline

Thanks Steve, I sent my remote back a few days ago and am waiting to receive the replacement.
2015-2-5
Use props
s.s.gibbs1.emai
lvl.3

United States
Offline

i have the dual version as well and initially the master was losing video signal and the slave was worse. i then set  a static channel instead of leaving it on auto. it seemed to stay on 10 in auto and the channel 17 was almost twice the signal. i can not change the slave and am wondering if despite it saying it is on 10 while the master is on 17 if it actually uses the master channel?
   i did get a flight yesterday that was over 2000 ft. away from me and had not lost signal. the previous flight at the same spot was a fly away  and i had to drop it into the lowest branches of an oak tree to keep it from going to china. at least i could make it go down.
  there were high voltage lines about 150 ft. away though,,so it could have been E.M.F. interference. i have seen an A.M. radio transmitter antenna within about 80 yards reduce the signal and cause a lot of noisy channels.
2015-2-5
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules