Please select Into the mobile phone version | Continue to access the computer ver.
Osmo failed with less than 10 minutes of recording time
567 5 2016-9-5
Uploading and Loding Picture ...(0/1)
o(^-^)o
jefferyfarrell
lvl.3
Indonesia
Offline

So i needed to use my osmo the other day for its first proper shoot. It failed to turn on. I had only used it briefly 2 days before to ensure that it was going and would be working when i needed it. I have 3 fully charged batteries so i know that it wasnt a battery issue as i tried them all. No lights come on in the handle on either side. No beeping. Its just dead. I tried taking the camera off and mounting it to my z axis but still nothing. I tried the reset but i doubt that would do much as it does nothing to start with. So if anyone has any suggestions that i might have missed then that woukd be great but im thinking i have to send it back but that doesnt help with the filming i need to do now.
2016-9-5
Use props
nigelbrinkmann
First Officer
Flight distance : 577484 ft
Australia
Offline

Hi, have you checked the battery voltage on all 3 of you batteries? You may have a faulty battery charger,  or bad connection between the battery and the charger, also don't leave the batteries in the charger  once charged for long periods of time as this can flatten the battery to, I would be checking the charger connections and the battery voltage first.
2016-9-5
Use props
jefferyfarrell
lvl.3
Indonesia
Offline

I forgot to mention I went to a camera store after it failed it get a tripod for my other camera and they had an osmo. I asked to try my battery in their camera and it started up with no problem at all. So dont think it the batteries
2016-9-5
Use props
DJI-Thor
Administrator
Flight distance : 13602 ft
Offline

Hi, please see if you can find something like cosmetic tips with Ethanol to clean the metal pins inside the handle of your Osmo, it might be a bad connection.   If it still doesn't work, please contact support@dji.com to send it in. Thank you.
2016-9-5
Use props
jefferyfarrell
lvl.3
Indonesia
Offline

I shall try cleaning them but they look fine and it's only 2 weeks old so it shouldnt have gotten dirty that quickly and has barely been out of the case so had no chance to get dirty.
2016-9-6
Use props
nigelbrinkmann
First Officer
Flight distance : 577484 ft
Australia
Offline

jefferyfarrell Posted at 2016-9-6 19:13
I shall try cleaning them but they look fine and it's only 2 weeks old so it shouldnt have gotten di ...

Hi, remove the camera/gimbal then see if your osmo handle will start up.
Another thing to try is open the battery lid and push the battery in with your finger, then while holding it in, try and start the osmo.
2016-9-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules