Please select Into the mobile phone version | Continue to access the computer ver.
GPS of replacement P3P not working
1130 9 2016-9-21
Uploading and Loding Picture ...(0/1)
o(^-^)o
vr-pilot
Second Officer
Flight distance : 4304885 ft
Germany
Offline

Hello,

as originally posted in this thread  

http://forum.dji.com/forum.php?mod=redirect&goto=findpost&ptid=62973&pid=497793&fromuid=127639

I have a GPS problem with a freshly delivered replacement P3P from the first (and only) flight on.
Here is what I wrote in the thread mentioned above:  

After just one week (shipping, repair, shipping) I got my replacement  P3P back today. Really excellent timing and shipping was free. The bird  kept its camera, but the craft itself was replaced. Just the label with  the CE logo, certification, serial number etc. was missing...
So far so good.
BUT on my first (and only) test flight, I noticed that the bird behaved a  bit strange, although all systems were showing "green". I landed it  safely and checked the flight log recording. I could see that the ground  track I actually flew was not recorded (static position, just altitude  and yaw changes) and there was a sudden jump to the position (number of  satelites went from 10 to 17) where I actually landed.
After I finished watching the flight log record I noticed that the GPS  indicator was grayed out (no satellites) and the flight mode changed to  P-ATTI (yellow).
After calibrating and restarting everything the maximum number of  satellites only reached 7 with low signal level (3 red bars) only. Could  that equal this evenings 7 receivable GLONASS satellites, without the  GPS system that had 10 at this time? But that is just a guess and would  fit to the test flight's jump in number of satellites.
After a further restart the GPS indicator on the App remained grayed out again.
So now I got a bird with a GPS reception problem...
I am afraid I will have to sent it back to DJI's Service Center in Germany from where it just arrived today.
Do you have any idea?
  :-(
2016-9-21
Use props
vr-pilot
Second Officer
Flight distance : 4304885 ft
Offline

For giving the "all-clear" (hopefully) I herewith just want to report that I made 3 more test flights this evening under the same conditions like the flight yesterday: but today I had 14 stable and strong (5 bars) satellites on take-off and 20 in the air. The flight behaviour was normal and all the flight log ground track records were correct.

I don't know what led yesterday at exactly the same time and same place to GPS loss (grayed out) or maximum 7 satellites with low signal level (3 red bars) only.
Thinking of who operates GPS and GLONASS I have a certain idea of what could have been the case, but that is just a guess. Solar storm activity yesterday was high (K>5) from 00:00 to 03:00 UTC 2016-09-20, but I flew between 18:00 and 19:00 UTC and here the K value was only 3...

I hope I get my confidence back in the new replacement bird soon and concerning the again missing label (with the CE logo, certification, serial number etc.) I think I will make one of my own...
2016-9-21
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

vr-pilot Posted at 2016-9-22 04:33
For giving the "all-clear" (hopefully) I herewith just want to report that I made 3 more test flight ...

Good to hear that the issue has resolved itself thus far. Just to clarify, have you also performed an IMU calibration?
2016-9-21
Use props
vr-pilot
Second Officer
Flight distance : 4304885 ft
Germany
Offline

DJI-Jamie Posted at 2016-9-22 05:00
Good to hear that the issue has resolved itself thus far. Just to clarify, have you also performed  ...

Yes, I did a full calibration run (IMU, compass, gimbal) after unpacking the replacement P3P followed by the first "strange" flight described above.
After the GPS indicator went grey (or just showed 3 to 7 satellites and weak signal (3 red bars)) I did a second calibration run on IMU and compass but to no avail. The GPS reception was grayed out or was just very poor (only yellow P-ATTI mode).
One evening later I simply switched everything on, 14 satellites on the ground and 20 in the air, P-GPS, "all green". The flight log ground track recording was also o.k.
I hope it stays like this ;-)

EDIT: I just remember that the number of satellites grew slowly from 5 to 14 on the ground (about 2 minutes?). I read somewhere else that this could be a GPS database issue: the longer the bird had not been turned on or changed location, the longer it could take to "rebuild" the GPS table... (IIRC)
Does that make sense? (I am no GPS expert)
2016-9-22
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

vr-pilot Posted at 2016-9-22 17:50
Yes, I did a full calibration run (IMU, compass, gimbal) after unpacking the replacement P3P follow ...

I see where you're coming from, and it's possible especially if you haven't had issues after that first flight. Please keep us posted if it comes back as a persistent problem.
2016-9-22
Use props
vr-pilot
Second Officer
Flight distance : 4304885 ft
Offline

DJI-Jamie Posted at 2016-9-23 00:28
I see where you're coming from, and it's possible especially if you haven't had issues after that  ...

Thanks for your reply, and yes, the problem did come back this evening. Exactly like the day before yesterday on the first testflight:
After Startup "all systems green", 16 satellites. I took off and immediately noticed that on the GS window (ground station map display) the drone symbol kept a static place while turns (yaws) were depicted.
The app displayed a "green" P-GPS flight mode, but the bird flew actually in Atti-Mode (did not hold its position, just drifted with the light winds...). I switched the RC to A-Mode and there was no difference between the modes.
I returned to land and interestingly the number of satellites was always constant 16. Just about 20 seconds before landing the number of satellites began to differ between 16 and 18, and at that moment the GS window drone symbol became alive for the first time and showed the remaining ground track.
I landed in Atti, switched the RC back to P-Mode (16 satellites constant, "all green P-GPS"), took off, and again: no drone symbol movement on the map, just yaw (compass) indication.
In flight I switched the RC twice between P-mode and A-Mode, the app's flight mode indicator changed between "green P-GPS" and "yellow Atti" accordingly, but the drone was actually always in Atti mode. I switched back to P-Mode, "all green" and landed (actually in A-Mode with drifts).
Then I restarted the drone  (power off, power on) and again: this time the GPS symbol in the app remained grayed out with yellow Atti mode display. I did an IMU and compass calibration, to no avail: now the GPS symbol keeps being grayed out, also after restarts of RC, App and drone.
Now I am again exactly at the same "error level" as Tuesday the 20th (the day of the replacement drone delivery):
GPS not working/indicating at all...
If you like I can send you (PM?) a dropbox folder link to the following 6 flight logs:
- first problem flight on the 20th SEP,
- 3 "O.K." flights (map ground track record working) on the 21st SEP,
- 2 problem flights (described above) of today, 22th SEP
Inside the folder there are also two videos (local cache) of todays test flights and this photo:
20160922_200025-web.jpg
This is the damaged corner of the original P3P carton I sent in an intact shape to the last repair inside an extra transportation box. My transportation box was replaced by DJI service with another. That new transportation box had no outer damage on delivery at my home. So the original carton inside must have received its damage before it got in this new transportation box... mmh
If the new replacement P3P fell inside this original carton onto the floor, could it be a simple loose connection to the GPS module in the end? That could make sense because the drone might have been checked "O.K." by DJI service before it fell on the floor, and now we are dealing with a temporary error... (complicated story and just a guess)

Do you have any idea what to do now? And please tell me how to send you the dropbox link mentioned above.
Thanks in advance!
2016-9-22
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

vr-pilot Posted at 2016-9-23 04:14
Thanks for your reply, and yes, the problem did come back this evening. Exactly like the day before ...

There is a chance that it could have received damage during transit. If you could sync your flight records from the DJI Go app, then I can take a look at the flights from there. To clarify, is the email you used to contact the Europe Support team the same as your DJI Account email? If so, could you provide the ticket number from that correspondence? If it's not your DJI Account email, could you happen to provide that?
2016-9-23
Use props
vr-pilot
Second Officer
Flight distance : 4304885 ft
Offline

DJI-Jamie Posted at 2016-9-24 00:06
There is a chance that it could have received damage during transit. If you could sync your flight ...

Hello and thanks for the reply!

I have synced all 6 flights of the replacement P3P with the cloud from the DJI Go App. My flight log has quite a lot of bird entries... The actual bird's name is "P3P" (6 flights).
The ticket number was 285867 and the email adress I used for contacting DJI Europe Support is the same as my DJI account email.

Thanks in advance for your help!
2016-9-23
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

vr-pilot Posted at 2016-9-24 02:50
Hello and thanks for the reply!

I have synced all 6 flights of the replacement P3P with the clou ...

Thank you for supplying this information, I'll let you know what I can find.
2016-9-23
Use props
vr-pilot
Second Officer
Flight distance : 4304885 ft
Germany
Offline

DJI-Jamie Posted at 2016-9-23 22:06
Thank you for supplying this information, I'll let you know what I can find.

Hello DJI-Jamie,

until now I was not contacted by DJI Europe. Yesterday I received a "Customer Satisfaction Survey" email though:
"Because you recently contacted DJI Support, we would greatly appreciate your participation in this short survey about your experience."
This email normally comes on the day when DJI Support Europe contacted me.
That's why I am asking if possibly I missed something. (I have checked Spam, too.)

Is there "some action initiated" already or is everything still "on hold"?

Thanks in advance!

EDIT: I answered already the survey email for the last repair service. So this sounds like being ment for a new one...
2016-9-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules