Please select Into the mobile phone version | Continue to access the computer ver.
Is the new 3.10 version upgrade the GPS to 6.0.1.6 only in V.3 of Phantom 2?
2100 18 2015-2-1
Uploading and Loding Picture ...(0/1)
o(^-^)o
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

    I upgrade the P2 firmware to 3.10 the GPS still in 6.0.1.4 but I read at other tread that the GPS have to upgrade to 6.0.1.6 well I think that this upgrade is for V3 of P2? I have the V2 phantom?

Gps Issue.jpg
2015-2-1
Use props
steadystickrick
lvl.3

United States
Offline

I have a plain Phantom 2 Vision and the GPS firmware reads 6.0.1.3 after all new updates and latest Vision APP 1.46(1520) applied.....I think model dependent determines this & possible manufacturing date effects what GPS firmware code actually shows up after all updates are complete...
2015-2-1
Use props
johnaunderwood
lvl.2

United States
Offline

I have the V2 and after firmware update to 3.10 my gps firmware was also 6.0.1.4.
2015-2-1
Use props
johnaunderwood
lvl.2

United States
Offline

upgrade page
Update 3.10.png
2015-2-1
Use props
bjr981s
First Officer
Flight distance : 117290 ft
  • >>>
Australia
Offline


I have a Vision Plus V3 and 3.1 updated the GPS firmware.

I suspect that the GPS hardware version is not changing as it should with Model updates. That is confusing the issue.

I am also beginning to suspect that DJI may not have tested this 3.1  release on older hardware versions hence the problems being experienced.

Phantom.png
2015-2-2
Use props
godfrey.dayo.po
lvl.2

China
Offline

I have the V3 and last week, even with the old Main Controller 3.08 firmware, my GPS firmware was already version 6.0.1.6 so I think you guys are right about it being model/hardware dependent.
IMG_5988.JPG
2015-2-2
Use props
bjr981s
First Officer
Flight distance : 117290 ft
  • >>>
Australia
Offline

Thanks Good info.

It looks like the Hardware ID may have a couple more digits that don't get displayed here for the updater to pick the firmware for the hardware release.

i.e. 6.1.1.2.?  
2015-2-2
Use props
sccombs.earthli
lvl.1
United States
Offline

I have the v3 version running firmware 3.08. The gps is the current version as well as everything else. When I try to update to firmware 3.10 I get a message "Download error please refresh" Any ideas ?
2015-2-2
Use props
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

sccombs.earthli Posted at 2015-2-2 23:58
I have the v3 version running firmware 3.08. The gps is the current version as well as everything el ...

It look like DJI is working on some bug on that version. I think.
2015-2-3
Use props
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

sccombs.earthli Posted at 2015-2-2 23:58
I have the v3 version running firmware 3.08. The gps is the current version as well as everything el ...

It look like DJI is working on some bug on that version. I think.
2015-2-3
Use props
MilspecJSC
lvl.3

United States
Offline

I have a PV2+ v.3.0 and after upgrade the GPS is 6.0.1.6. I have noticed that the update has improved GPS sensitivity. Before the update, I averaged 8/9 sats but now I consistently receive 11/12. I fly around the same time each day in the same location.
Screenshot 2015-02-02 13.33.52.png
2015-2-3
Use props
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

MilspecJSC Posted at 2015-2-3 22:36
I have a PV2+ v.3.0 and after upgrade the GPS is 6.0.1.6. I have noticed that the update has improve ...


      Well that seem like a pattern for us (the user of P2 V. 2.0) there is not upgrade of GPS. In fact I have to downgrade my firmware to  3.08 due to really BIG BUG on 3.10 ( ERROR 25 ) YELLOW LIGHTS and IMU ERROR INI...  DJI don't let us behind I love INSPIRE 1 too but remember that PHANTOM was the flagship that make you that DJI is now.
BTW sorry about my pour english is not my native idiom.
2015-2-3
Use props
ronnydsosa.gmai
Second Officer
Flight distance : 21624 ft
United States
Offline

I have a Phantom 2 Vsion(not plus) and upgraded my firmware to 3.10 and my GSP firmware upgraded to 6.0.1.4
2015-2-3
Use props
nikolaospapista
lvl.2

Greece
Offline

Hi to all of you.
I make the new update and (like update screen up from other user) he said latest version in main controler etc but for batteries said no updates.In older 3.08 i have made the batteries update and in older assistance 3.06 he have and the battery update (latest version).In new 3.10 why he dont have and the section battery latest version like it is?Its normal this or dji comes out with new but fixing update like 3.04 to 3.06?
2015-2-3
Use props
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

nikolaospapista Posted at 2015-2-4 01:30
Hi to all of you.
I make the new update and (like update screen up from other user) he said latest v ...

Do not update to 3.10 yet it a version that came with a BUG.
2015-2-3
Use props
nikolaospapista
lvl.2

Greece
Offline

Its too late...like i said i make the update yesterday.How can i go back in prev.version?or maybe to wait for dji to solve the problem with other update?
2015-2-3
Use props
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

nikolaospapista Posted at 2015-2-4 06:42
Its too late...like i said i make the update yesterday.How can i go back in prev.version?or maybe to ...

You can go back download the DJI phantom assistent 3.06 and then look for "upgrade" and click to 3.08 and you will be fine.
2015-2-3
Use props
jmanaya
lvl.3
Flight distance : 40840 ft
Venezuela
Offline

nikolaospapista Posted at 2015-2-4 06:42
Its too late...like i said i make the update yesterday.How can i go back in prev.version?or maybe to ...

You can go back download the DJI phantom assistent 3.06 and then look for "upgrade" and click to 3.08 and you will be fine.
2015-2-3
Use props
nikolaospapista
lvl.2

Greece
Offline

The 3.06 is the base?If i remember the 3.06 have a problem and after that he comeout the 3.08.I fly rc heli a lot of year now and i use different assist for gyro-esc-governon etc.All of that have one program (assist) and make the update.Here for phantom they dont have one assist to make all the update but everytime that have new update you need to change and the assist.They could have done the update from update section from old assist.For me i plug the phantom to pc with old assist 3.08 and he found the new update.When i procced with this i see in forum that he have and new assist..so i download the new and i remake again the update with new assist.I dont make sence with all of this.If i run the old 3.04 im sure that in last update page he said "latest version" but the latest is 3.10 that i put before 2 days.I try to understand how it work all this.Anyway...i try to go back from assist 3.04 to 3.08.Sorry for my bad english.
2015-2-4
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules