Please select Into the mobile phone version | Continue to access the computer ver.
Datalink Issue usb disconnect
12Next >
7703 41 2015-2-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
ant.lagarde.gma
lvl.2

France
Offline

Hello,
I'm using the PC ground station with a 2.4ghz datalink.
Before I start I have two s1000 and one s900, so I've tried this on all those crafts as well as one custom built drone for photogrammetry and naza m V2.
What happens is, the datalink will randomly lose the usb connection to the PC (I've tried with 3 different PCs all updated to the last drivers, I also took care of disactivating any sleep mode on the usb ports). I hear the windows noise saying that the usb was unplugged while I don't do anything. That happens randomly between 1 to 15 minutes after handshaking with the main controller, and it's completely unpredictable. When that happens, I must unplug the usb ground station, unpower it, plug it back in and restart the ground station app on the PC before I can connect again, which is something which is in no way reliable mid flight as you can understand. I sent the first datalink to warranty and got a new one, which behaves exactly the same way.
I tried plugging the 2 usb connectors, plugging just one, plugging just one with the battery, plugging the 2 as well as the battery, no change, exactly the same stuff happening.
I can't work right now because the pc and datalink just don't work together, and I'm looking for something or someone to help me or at least let me know it's a known issue and I can start looking somewhere else for photogrammetry purposes.

If anyone has experienced the same type of behaviour let me know

Thank you

2015-2-6
Use props
ant.lagarde.gma
lvl.2

France
Offline

tested again today, disconnects after a few minutes in simulator mode. Tested in real, disconnects after 2mn causing the craft to stop, had to brind it back with the remote
2015-2-7
Use props
uptowndisco
Second Officer
Flight distance : 5486841 ft
  • >>>
United Kingdom
Offline

I have not had any problems with mine disconnecting from the USB port , I was going to suggest trying another Pc but I see you have tried already , what version of windows are you using it with , my laptop is using win 7 64bit pro,
2015-2-8
Use props
sirBruno
New

Latvia
Offline

Hi,
I have the same problem. Its always disconnecting. If I try it indoors , there is no problem. But as soon as I am outdoors, the conenction interrupts very often.
I thought maybe its if the ground station module gets cold. But i think it can't bee.
In an other forum I read that you should keep the remote controles min 5 m away. I'll try that today.
2015-2-9
Use props
DJI-Jackson
lvl.4
Flight distance : 51243 ft
  • >>>
Hong Kong
Offline

Hi guys
Please check your antennas of air unit and see if they are broken ?
2015-2-9
Use props
ant.lagarde.gma
lvl.2

France
Offline

nope they are not, same thing happened with my previous datalink ground station which I had warranty replaced
2015-2-9
Use props
uptowndisco.hot
Second Officer
Flight distance : 5486841 ft
  • >>>
United Kingdom
Offline

Seems to be a bit of confusion here the OP is losing USB connection and others are mentioning antenna i.e dji support "Hi guys
Please check your antennas of air unit and see if they are broken ?"    which one are we trying to fix , what has a lost connection on the air side got to do with loosing usb connection to the laptop ?
2015-2-10
Use props
DJI-Cathy
Second Officer

Hong Kong
Offline

Please check the following:
1. Make sure there is not any block between the air end to the ground end. you can try to change the place on your craft to install the air end to see.
2. Make sure there is not any other 2.4GHz interference around you, or you can try different place to see
After you do check all the things and it is still the same, please send your email to support@dji.com and ask for repair, thanks a lot!
2015-2-10
Use props
amjad862.yahoo
lvl.1

United States
Offline

hello guys!
i too have this problem for a little long time now. and i've worked quite a bit on it so let me clearly define the problem.
first let me mention the cases in which the problem does not occur..
1. you use WKM as flight controller and use any DJI datalink there is no problem
2. you use A2 and the 900MHz datalink there is no problem.
3. you use A2 and the old 2.4GHz datalink (i.e. without bluetooth) there is no problem.
4. you use A2 and LK24_BT (2.4G datalink with bluetooth) and iPAD ground station.

!!! the problem is only when you use A2 flight controller and LK24_BT (2.4G datalink with bluetooth) is used with the PC ground station.

now the problem:
when the PC ground station is connected to the flight controller on relevent com port and you take away the flight controller away from the datalink so that it is out of range. when this happens the com port disappears from the Ground station software and does not show again until we plug out the usb physically and put it back in the computer (the com port only disappears from the software it is vsible in the device manager).
for this problem to occur signals should be lost, maybe you turn-on a wifi booster close-by and go only 10-20 meters away from the datalink, or cover the antennas with aluminium foil or some other metalic pot so as to degrade the signals quickly.

P.S. the problem doesn't occur it we just plug out the battery of the fligh controller. i tried both putting off the complete fligh controller by pulling out the battery and just turning off datalink air end by pulling out the can-port connector. As soon as i connect it again the data starts to come as it should. its only when the data gets lost when the flight controller or the datalinkis on that the problem occurs...
2015-2-10
Use props
ant.lagarde.gma
lvl.2

France
Offline

Try plugging the new one without plugging the bluetooth, and only plugging the main usb port, I've had no disconnect since I started doing this
2015-2-12
Use props
amjad862.yahoo
lvl.1

United States
Offline

ok, i'll try it again but i do not even use bluetooth generally, so mine is always pluged in without  the bluetooth and only in the  main usb port.
2015-2-12
Use props
amjad862.yahoo
lvl.1

United States
Offline

ant.lagarde.gma Posted at 2015-2-12 19:07
Try plugging the new one without plugging the bluetooth, and only plugging the main usb port, I've h ...

i did it, but its not working for me..
2015-2-15
Use props
david.bonano
lvl.1

France
Offline

Hello
Same problem for me
I sent several e-mail to DJI support...
But no reponse at this day
It is to sell DATALINK but be it as it work !!!
2015-3-4
Use props
DJI-Cathy
Second Officer

Hong Kong
Offline

david.bonano@or Posted at 2015-3-5 12:34
Hello
Same problem for me
I sent several e-mail to DJI support...

Please tell me your zendesk number so that I can check, Thanks a lot!
2015-3-4
Use props
david.bonano
lvl.1

France
Offline

Hello cathy
My zendesk are #49255 and #49256
Thanks o lot !
2015-3-6
Use props
kherkyl
New

Estonia
Offline

Hi!

I also have the issue with losing USB connection between PC and ground end of the Ground Station. My devices are as follows:
DJI Phantom 2 version 2 with 2.4 GHz remote control
2.4 GHz data link (LK24-BT) with latest firmware
PC with Windows 8.1 64-bit
Ground Station software version 4.0.11

I have tried single and double USB, with and without external power supply but I still get random disconnections of USB. To reconnect I have to unplug and re-plug USB of the 2.4 GHz data link module.
2015-3-7
Use props
DJI-Cathy
Second Officer

Hong Kong
Offline

david.bonano@or Posted at 2015-3-6 22:40
Hello cathy
My zendesk are #49255 and #49256
Thanks o lot !

Hi, Sir
For some reason, we lost your first email, my colleague will reply you today, sorry for your inconvenience caused.
2015-3-10
Use props
Raybro
Second Officer
Flight distance : 11099 ft
United States
Offline

DJI-Cathy Posted at 2015-3-5 13:58
Please tell me your zendesk number so that I can check, Thanks a lot!

Same problem here. Just started using the datalink 2.4 Ghz. Upload waypoints, hit go, motors spin up and flight begins. Throughout flight you can hear the familiar sound when usb connects and disconnects. The screen on the laptop does not update showing phantom path, instruments don't update. The phantom continues to fly course. I just left the usb alone, but even when it reconnects, the screen does not update.
2015-3-14
Use props
Raybro
Second Officer
Flight distance : 11099 ft
United States
Offline

It is bothersome and I hesitate to use it for BVR flight. Without the ability of knowing where the phantom is on the map, you risk losing it if something catastrophic were to happen. It has to be an issue in the software, the driver, or the firmware in the datalink and I wish it would get fixed.
2015-3-14
Use props
Raybro
Second Officer
Flight distance : 11099 ft
United States
Offline

Just ran simulation mode. Ran through several waypoints then disconnected. When ground side datalink disconnected, the led went from alternating red / green  to red. Also, when functioning normally I connect using Com4 which is a virtual port created by the software. Com4 disappears when the USB disconnects. You have to close the ground station software and open it up again to get the virtual port to reappear.No indication in win7 event viewer as to the reason for the disconnect.
2015-3-14
Use props
apdiha
New

Pakistan
Offline

The DJI datalink disappears and then reappears in the "Device Manager" as soon as the drone (with A2 FC) flies beyond LOS. However, this problem does not arise with the WK-M, so I reckon it has something to do with the datalink component of A2.

DJI guys, have you any clue to the datalink disconnection problem as mentioned above?
2015-4-20
Use props
G.Lazúen
lvl.2

Spain
Offline

Having the same issue. Once started flying, in a few minutes the COM port always loses the connection. In the middle of the flight operation I have to unplug USB and replug it to recover live data. I use A2 firm 2.4, GS V4.0.11 and Win7


Regards
2015-4-21
Use props
Raybro
Second Officer
Flight distance : 11099 ft
United States
Offline

No resolution. I started using the IPad version and have had better luck, however the PC version is better. Has better features and the Google maps are much better than the Apple maps. I hope they are looking at these posts and can give us an answer.
2015-4-21
Use props
husein.rifki
New

Indonesia
Offline

i Had same problem also , about suddenly data link ground end disconnecting from my laptop, and then try to unplug and plug in again... any update about this problem ? pleaseee DJI SUPPORT
2015-5-4
Use props
nilfisch.arcor
lvl.1

Germany
Offline

I´ve got exactly the same problems as described above (GS 4.0.11, Win 8.1, Win 7, Naza M- V2, all drivers and sofware up to date).

Everey time after some minutes (or even seconds) the Ground station looses USB connection. You have to land, repower multicopter, unplug USb cable and begin again.

DJI, please fix this issue, otherweise I´ll have to give the data link package back...
2015-5-12
Use props
Raybro
Second Officer
Flight distance : 11099 ft
United States
Offline

david.bonano@or Posted at 2015-3-5 12:34
Hello
Same problem for me
I sent several e-mail to DJI support...

I have the same problem with my PC Groundstation and no help.
2015-5-12
Use props
nilfisch.arcor
lvl.1

Germany
Offline

I sent them my requst to fix this problem, too.

Only solution until the Fix:
- after the Ground End disconnected itself, click the Button "Dicsonnect"
- unplug USB(data)-cable
- plug cable back into PC/Laptop, wait a second to let the USB device be recognized by Computer
- Click "Connect"
- then it should continue to work until the next dropout...

This was only tested in simulation mode, I don´t know, how good datalink´s capability is to rebind again.

Still very annoying even if it could save your flight mission!

Hope that could help a little.

Will give it a test on the field the next days...
2015-5-13
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

nilfisch.arcor Posted at 2015-5-13 18:12
I sent them my requst to fix this problem, too.

Only solution until the Fix:

I have a similar problem. Every time I click go on the Ground Station software the GPS signal is lost and I can't see where the drone is on the monitor (only on the FPV). The drone flies to all the waypoints and then I have to manually land it.
2015-6-16
Use props
Rennie
lvl.1

United Kingdom
Offline

S1000+A2+GH4

Me too, exactly the same problem.  Intermittent loss of the data link soon after takeoff.  Have to re-start GS software and unplug-re-plug USB connection to be able to see the port again.  Am using a lipo to separately power the tx and an extended USB cable to get good positioning of the tx (e.g. on roof of vehicle).

I am so frustrated to see from this thread that this is a known issue, with no proposed cure - I just spent 6 months with loss of video link finally cured by a complete new gimbal, and could now finally turn my attention to the GS, and lo and behold, immediately another unfathomable issue!

Strange thing, that clearly some users are having success and it's working, pointing to some specific failure.  Is it the data-link transmitter?  Is it the receiver?  Is it interference, i.e. the position of either relative to other components?

I really do hope for myself and others that there might be some good advice and a fix from someone somewhere.  Personally, I purchased this kit with the intention to pre-program flights, so if it doesn't work I'm floored.  I don't know where to turn?  Any further help very gratefully received.....
2015-6-26
Use props
Rennie
lvl.1

United Kingdom
Offline

Hi again,

I'm wondering if the disconnect problem is due to the position of my airside datalink on the aircraft.  Mine is stuck with a pad on top of the IOSDMkII on the port (left) side of the machine, immediately above the landing gear servo control unit.  Is this the recommended location for the unit?  Can anyone confirm?

Many thanks for any advice.
2015-6-29
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

Any news about this problem guys? Is anyone here that has this problem fixed? I have send the hole drone to the company that sold the product.  Before this they did replaced the data link and they tested it with another drone and it worked perfectly. On Phantom it always does the same problem : disconnects. It almost looks like DJI never bothered to test this properly and what bothers me the most is that they already moved on to another series without fixing this first.
2015-8-13
Use props
paulchoppysoo
lvl.2
Flight distance : 160894282 ft
  • >>>
Australia
Offline

Having the exact same problem here too. BTU works ok but the PC drops the com port off when around 20 meters away. Unplug from the UASB and with a battery, the Ipad works well. Green light always solid when the PC com port drops so I am sure the 2.4g data link is ok, maybe its windows 8.1?
Going to remove the GS and reload with netframework, drivers etc again and see what happens.
2015-8-18
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

It seems DJI really does not have any clue how to fix this problem. They are not even allowing Phantom 3 with data link anymore. Seems like Ipad is the only solution. Can someone please tell me how good is the IPAD version of the GS? Does it have the ability to make waypoints like in the photorammetry tool of the Windows GS? Thank you!
2015-8-20
Use props
nrj
lvl.1
Flight distance : 1871119 ft
Turkey
Offline

We have same problem. No solution, no answer from DJI.

Here is the video

2015-9-16
Use props
cartorender
lvl.1
Italy
Offline

Hi,
has anyone got a solution for this?

Flying a 10k setup (S1000 with A2, Zenmuse 5D and all kind of optionals) it's pretty frustrating to see that DJI is not even giving feedback on the issue!
2015-9-23
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

The guys we bought the drone from will send it back to us tomorrow after the second time send to service. They told us the issue was fixed after instructions from DJI. I will return here with info after test but from what I know they made changes inside the drone to fix this.
2015-9-24
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

The drone was back from re-seller, they changed the autopilot with Naza-M V2 . I am yet to test due to bad weather but will get back once I do it.
2015-9-28
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

It's working now! it drops for a millisecond from time to time but that is normal and it gets back on showing the position. Like I stated they changed the autopilot inside the Phantom 2.
2015-10-5
Use props
beadvised2011
lvl.1
Flight distance : 18530 ft
United States
Offline

gheorghe.floria Posted at 2015-9-28 07:54
The drone was back from re-seller, they changed the autopilot with Naza-M V2 . I am yet to test due  ...

Glad to hear it is working for you!  Do you mean they changed the Main Controller in your Phantom 2?  Which Main Controller did you have before?
2015-10-17
Use props
gheorghe.floria
lvl.1
Flight distance : 57920 ft
Romania
Offline

beadvised2011@g Posted at 2015-10-17 18:46
Glad to hear it is working for you!  Do you mean they changed the Main Controller in your Phantom  ...

No, the Controller is the same. They only made changes inside the actual aircraft. I can no longer see the lights on the drone, I have a small LED that blinks the same colors as the LED's on the back of the aicraft.
2015-10-26
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules