Please select Into the mobile phone version | Continue to access the computer ver.
OSMO starts and both LEDs light up
545 4 2016-11-7
Uploading and Loding Picture ...(0/1)
o(^-^)o
fans999e6c9c
lvl.1
Germany
Offline

Hi all,

I just wanted to test my OSMO bc I'M going out tomorrow and I have discovered that something is wrong.

When I turn my OSMO on, I hear the beep, both LEDs light up stay on. The left one remains yellow and the right one red.

Now I have read that the red LED says that I am using a third party battery but I'm not.

Anybody knows what's going on?

Thanks & Best

Chris

IMG_1656.JPG
2016-11-7
Use props
DJI-Thor
Administrator
Flight distance : 13602 ft
Offline

Hi, if possible, try another Osmo battery, if the issue still remains, I'm afraid you need to send it back. Please email support.eu@dji.com and send it back.
2016-11-9
Use props
fans999e6c9c
lvl.1
Germany
Offline

DJI-Thor Posted at 2016-11-9 10:56
Hi, if possible, try another Osmo battery, if the issue still remains, I'm afraid you need to send i ...

Hi,

thanks for the reply. Here's a quick Video about the condition:



Do I really need to send it back right away?
2016-11-11
Use props
DJI-Thor
Administrator
Flight distance : 13602 ft
Offline

fans999e6c9c Posted at 2016-11-11 03:56
Hi,

thanks for the reply. Here's a quick Video about the condition:

Yes, I've seen it before, you need to send it in.
2016-11-11
Use props
fans999e6c9c
lvl.1
Germany
Offline

DJI-Thor Posted at 2016-11-11 10:27
Yes, I've seen it before, you need to send it in.

OK thanks for the reply
2016-11-11
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules