Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 1 Remote control upgrade problem
12
6400 51 2016-11-24
Uploading and Loding Picture ...(0/1)
o(^-^)o
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

Skyhigh Drone Posted at 2017-7-26 22:17
Hi Donnie

First of all I would just like to thank you so much for all your helpful information, I made the mistake of updating  the Controller before the AC, this "bricked" it however  I have then since been able to use the .bin file you so kindly provided to update to V01.06.

Ok you were Able  to update ( master ) the RC to version 1.6 is that correct ?  from here you will need to update the RC via a Internet HOME based wi fi connection  ( a solid wi-fi connection is what I mean ) and update the RC transmitter via the go app to the latest Firmware  1.7.8 . Make sure AC is OFF during RC transmitter update .

Now what version is the slave on ? there is No 1.0.7. Do you mean 1.7.4. or 1.7.6. or 1.7.8. ( the latest one is this )
donnie
2017-7-27
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

Skyhigh Drone Posted at 2017-7-26 22:17
Hi Donnie

First of all I would just like to thank you so much for all your helpful information, I made the mistake of updating  the Controller before the AC, this "bricked" it however  I have then since been able to use the .bin file you so kindly provided to update to V01.06.

Jess below is a video on updating the AC and the RC transmitter .  The RC upgrade is around the 4:30  minute mark.  Just for reference .  Make sure the  AC is OFF when updaing the RC transmitter via the go app,  and that you have a solid wi fi connection to the go app device .

2017-7-27
Use props
TIGGERLEE
lvl.1

United States
Offline

Hi, I know this is a somewhat old forum but I am also having trouble with this issue.

1. Before I updated my AC, I  manually connected my RC and AC by pushing the buttons on the AC and RC.
2. After I updated the AC my RC would no longer connect and so I tried going into the GO app in order to upgrade by RC but was met with a "How to connect" button, it would not let me go to the camera in general. Mind the "How to connect" basically said turn AC on and then RC then wallah... crap. I am also signed in...
3. I tried manually updating the RC with a USB but unfortunately, I have a Mac and that seems to be the reason why the file is not extracting in the RC.
4. I cannot do anything... I am sad and crying about this overly sized paperweight that seems to be super pretty now...

please help me ;-;
2017-10-10
Use props
TIGGERLEE
lvl.1

United States
Offline

I also don't know how to delete messages so  this is filler
2017-10-10
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

TIGGERLEE Posted at 2017-10-10 18:19
Hi, I know this is a somewhat old forum but I am also having trouble with this issue.

1. Before I updated my AC, I  manually connected my RC and AC by pushing the buttons on the AC and RC.

You need to update the RC , If you updated the AC without updating the RC  depending on the version  of firmware it will no longer connect.  so make sure you update the RC and then may need to re link .



What version of firmware did you load to the AC and was it successful ? Was it version 1.3 you loaded to the aircraft or later version?  have you ever updated the Aircraft and system before and where did the wystem come from ? Was it new used or  What ?

The USB trick will only work with special files ,  so it may not be the MAC causing issues , if you used the MAC for upddating the Ac and Had "success" In the log it should work on the Thum drive for updaitng the RC.  BUT updaing for the most part is through wi fi connection to the go app and RC transmitter.  (My tips page COVERS THIS , READ THE ENTIRE POST OF MINE , IT WILL CLEAR UP ALOT .) ( and then only to version 1.6 ) for the most part updating should only be done wt9ih the go app and Awn fi connection to the Go app.

Read my tips page  link below in RED and watch the video and lets go from there . -
Tips: Loading NEW firmware to RC and AC- Insp. 1 Phantom ADV & PRO







2017-10-11
Use props
BerkayGulum
lvl.1
Flight distance : 123862 ft
Turkey
Offline

Donnie

Seems that you will be the cure to my problem..  I've got Inspire 1 from a friend. I updated the AC and master RC successfully to the latest firmwares (AC to 1.11.01.50 and RC to 1.7.80). I updated the Master RC via Dji Go app. With Master everything is running flawless. But when I want to update the slave RC I've got a problem. I connected to iphone to update the version via DJi go app but the app did not recognise the RC.
*******
Product: Unknown
Current Version: Unknown
Device Disconnected (red) (the device was connected by the way)
Select firmware version - none (I cannot click the none button it's deactivated)

***********


I tried your recommendations to Saad. I formatted a microSD with Windows and copied every version you post to the USB stick and tried to update RC but it failed. The USB stick is working as I copied all the files (one by one) to it. I tried DJI Assistant on Mac. The app recognise the RC but when I click on the RC icon I receive "cannot retrieve firmware list try later" error..  No connection no slave.. I tried to find the RC from as a slave from the master RC.. again it's not appearing... I'm stucked actually.


2017-10-30
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

BerkayGulum Posted at 2017-10-30 03:21
Donnie

Seems that you will be the cure to my problem..  I've got Inspire 1 from a friend. I updated the AC and master RC successfully to the latest firmwares (AC to 1.11.01.50 and RC to 1.7.80). I updated the Master RC via Dji Go app. With Master everything is running flawless. But when I want to update the slave RC I've got a problem. I connected to iphone to update the version via DJi go app but the app did not recognise the RC.

Did the slave work when you first received it and  did not update anything ?  Or did you  try updating everything before  testing the entire system .
Are you using the same go app device as the master .? If not try the one you use on the master for testing purposes, we want to make sure it is not simply a failed Go app device or cable.


One of two things is happening here , the Slave is on original FW ( or on a version before 1.3 ) and will need to be updated with  update number two and the 1.3 fw update and then you can update normally via the Go app and Internet connection ( wi fi )

Or you may have a filed USB port on the Back of the RC transmitter ( slave ) this is easily replaced and cost about US 100 dollars.  

****What color is the first LED light when you turn on the Slave RC ???? Is it  like a light blue color or ike a light pink or is it red ???

I would try to update with the first update on the link I am gong to give you , then update to version 1.3  see if one of these two will take .  You should get some beeping tones when the process begins .  I am going to give you a link on how to update the RC via thumb drive and also some older DJI RC FW  files.  Keep in mind you only want to update via the USB till version 1.3 , from there you update normally via the go app.

Now if  you do the procedure correctly and it still won't install then you more than likely have a bad USB port on the Slave RC.

Let me know what version the Slave  Rc was on when you got it from the friend or at the least ask him what version he had it loaded to , If it was past 1.3 then you can assume it is the bad port on the RC slave or the FW got interupted sometime  and was not done correctly , there is usually a blue light on the first led of the RC salve , next to the white power lights .

** Keep in mimd I am assuming your friend never updated the RC and thus this is why the go app does not recognize the Go app, If you are past 1.3 on the Rc the is will do no good .  :ets assume that you are on the Origianl FW ,load version 1.2.01.06 and see if it will load , if it does great , if not  go to version 1.3 and see if it will load , If not then you may have the bad port on the /rc or another problem
RC update via Thumb drive for version RC 1.2 OR  Blue Light onRC
inspire_firmwares.htm

**** what gives you the impression the  RC transmiter recognizes the go app ??? If you have the "Disconnected " meassage acoss  the top of the screen this is just as if the RC is not connected via the cable .  Just wondering what you meant by that statemwent .  Now if says "Aircraft Disconnected" that would inidcate the RC and Go app are commumicating but the RC tranmitter cannot connect to the aircraft .  Let me know hat you meant

Let me know
donnie





2017-10-30
Use props
BerkayGulum
lvl.1
Flight distance : 123862 ft
Turkey
Offline

Donnie * Posted at 2017-10-30 05:39
Did the slave work when you first received it and  did not update anything ?  Or did you  try updating everything before  testing the entire system .
Are you using the same go app device as the master .? If not try the one you use on the master for testing purposes, we want to make sure it is not simply a failed Go app device or cable.

Now.. yes.. the slave was working and I can see in the slave list of master RC. The Slave LED is pink.. I tried USB firmware update (1.2, 1.3, 1.6 etc) it failed.. you are probably right about the USB port failure. As, when I connect the master RC the iphone beeps but when I connect the slave RC nothing happens. As the port is not working the USB update method is not working. The slave is saying "Disconnected" not "Aircraft Disconnected"...
2017-10-30
Use props
BerkayGulum
lvl.1
Flight distance : 123862 ft
Turkey
Offline

BerkayGulum Posted at 2017-10-30 06:13
Now.. yes.. the slave was working and I can see in the slave list of master RC. The Slave LED is pink.. I tried USB firmware update (1.2, 1.3, 1.6 etc) it failed.. you are probably right about the USB port failure. As, when I connect the master RC the iphone beeps but when I connect the slave RC nothing happens. As the port is not working the USB update method is not working. The slave is saying "Disconnected" not "Aircraft Disconnected"...

And also.. I tried with an Android Tablet.. the result is the same.. The tablet does not give any reaction when connected to slave RC  but it does when its connected to master RC
2017-10-30
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

BerkayGulum Posted at 2017-10-30 06:17
And also.. I tried with an Android Tablet.. the result is the same.. The tablet does not give any reaction when connected to slave RC  but it does when its connected to master RC

OK , If the master can see the slave then the connection between them is good .  More than likely it is a bad USB port on the Slave RC .  

If you want to test this and are handy simply remove the cover off the back of the working RC ( the USB cover with 4 T-6 torx driver   screws ) pull the cover straight off don't this or anything as there is a plug in module that goes right it not he Back of the RC transmitter .  anyway just remove the usb cover and place on the other transmitter and test it out .  If you have connection to the Go app then you know its working .  

The only part  you need is the White plastic cover   with the USB module in it you don't need to remove the 3 flat ribbon cables , it is fairly simple .  I have a video on how to do it if you  want to see it .

send me  a email and I will reply with video .  It may go to a video dropbox service , it is only 1 minute long .
donaldjames1990@gmail.com

If you want to just send it in I get it .  the Part is #94 on the DjiI catalog , about 100 USA dollars.  SOMETIMES YOU NEED TO REPLACET ENTIRE  MODULE BUT I HAVE FOUND IT IS USUAlly just THE white COVER  with its USB electronics THAT FAILS AND NOT THE OTHER ELECTRONICS  that require the removal of the 3 flat ribbon cables.

donnie
2017-10-30
Use props
NW-flyer
lvl.1
United States
Offline

Skyclip Posted at 2016-11-25 01:31
Did you change the USB Cable ? Maybe its faulty.

Did you try to reset the RC?

This apparently does not work on the inspire one controller.
2017-11-13
Use props
joelgalbraith
lvl.1

United States
Offline

Donnie * Posted at 2017-10-11 04:37
You need to update the RC , If you updated the AC without updating the RC  depending on the version  of firmware it will no longer connect.  so make sure you update the RC and then may need to re link .

I've read your tips post, but don't know how to find what version of FW I have on my controller....since I can't even get into the controller with my go app.  I only get the "how to connect " instructions screen, but NO "enter camera" view that everyone keeps writing about.  I might be able to update my FW if I could get the app and controller speaking to each other.
I've tried different USB cables without success.  For all I know, the normal USB port on the controller is bad, but I don't think it will work to get an micro USB adapter and to use the smaller UB port.  Somewhere i read that is for charging only, and not for data.
Help would be appreciated.  Thank you
-Newbie
2018-7-9
Use props
12
Advanced
You need to log in before you can reply Login | Register now

Credit Rules