Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 4 Pro Won't connect after firmware update
12Next >
22269 47 2016-12-3
Uploading and Loding Picture ...(0/1)
o(^-^)o
fansb8a099d3
New

United States
Offline

Got my P4P a few days ago and flew it for about 20 min yesterday and everything worked great. Did a firmware update this morning for the drone, after it updated it told me to reconnect, after doing so the update got stuck at 99%. I just left it incase it was taking a long time but after an hour I figured it froze so I unplugged (later I read that for the P4 you have to turn the controller on for the update to finish). Now I can't connect to the drone. When my iphone is connected directly it charges but doesn't recognize the drone. When everything is powered up it only says RC connected. On the RC there is a solid pink/purple light on the Status LED. On the drone there are two flashing yellow lights on the battery side, two solid red lights on the opposite side, and a solid red light in between the micro sd slot and usb port. I even connected the drone to my Mac and successfully updated the firmware with the assistant app. Also tried reconnecting the RC via the app and after pressing okay and pressing the button in between sd slot/usb port for 2 seconds nothing happened. The pink light is still there.

Any suggestions?

Thanks.
2016-12-3
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

Try the following button combinations to manually refresh the communication:

Reset the RC:

* Turn on the controller, and the aircraft should be off.
* Press C1, C2, and shutter on the controller then turn the controller off.
* Turn on both the aircraft and the controller and link the remote.

To manually relink te RC to the aircraft, use the following:

* Turn on both the aircraft and the controller.
* Press C1, C2, and the record button on the controller, then the controller will beep like D-DD.
*Let go all fingers, press the wheel on the right side of the controller and then the first light of the controller will become blue and it will constantly beep DDDD.
* Use a pen to click the linking button on the aircraft and hold for 3-5 seconds, and then take the pen off the aircraft and wait, it will be linked soon.

2016-12-3
Use props
fansb8a099d3
New

United States
Offline

DJI-Jamie Posted at 2016-12-4 07:57
Try the following button combinations to manually refresh the communication:

Reset the RC:

That worked, thank you so much!!!
2016-12-3
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

fansb8a099d3 Posted at 2016-12-4 08:05
That worked, thank you so much!!!

No problem. Glad to hear you're up and running again.
2016-12-3
Use props
fans6358347d
lvl.1

Germany
Offline

Hi there,
unfortunately it seems that I've got the same problem. But instead, the LED of the RC stays purple. The button combination doesn't reallly work. The first beep like DD-D appears, but when I let go all fingers and press the right wheel, nothing happens. Any other tipps for me? I'm desperate.
2016-12-10
Use props
ruppt
lvl.1
Flight distance : 461102 ft
Switzerland
Offline

Hey,
I have the same problem as @fans6358347d. Solid purple LED on the RC, also after the button combination describet above. Has anyone a solution?
2017-1-12
Use props
Hooks
lvl.4
Flight distance : 226450 ft
Canada
Offline

fans6358347d Posted at 2016-12-10 08:01
Hi there,
unfortunately it seems that I've got the same problem. But instead, the LED of the RC stays purple. The button combination doesn't reallly work. The first beep like DD-D appears, but when I let go all fingers and press the right wheel, nothing happens. Any other tipps for me? I'm desperate.

I just had a client with this issue this morning on a brand new p4p out of the box...  After trying everything I could think of to fix the issue including reseting the UAV firmware all the way back to factory settings, I sent my client the exact instructions form DJI in this thread.  

Bam it suddenly worked... No more purple led  

If the button combo pressing didnt work for you so far, maybe try downgrading your uav firmware first through dji assistant then doing the rcreset/pairing as described above.
2017-1-12
Use props
ruppt
lvl.1
Flight distance : 461102 ft
Switzerland
Offline

Hey,
Thanks for your reply. I tried with every single Firmware released so far. Doesn't work with any of them.
When I turn on the RC, it doesn't have the common "DJI-Start-Sound"...it only makes D-D and then the purple light is there....so strange.
2017-1-12
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

ruppt Posted at 2017-1-12 10:34
Hey,
I have the same problem as @fans6358347d. Solid purple LED on the RC, also after the button combination describet above. Has anyone a solution?

Yeah, I had that issue - I'd tried to reset the RC, but using the wrong button with C1 and C2 (I was pressing the button on the left, and not the one on the right). After resetting the RC using the correct sequence and power cycling the RC, all was back to normal.
2017-1-12
Use props
ruppt
lvl.1
Flight distance : 461102 ft
Switzerland
Offline

Punchbuggy Posted at 2017-1-12 15:21
Yeah, I had that issue - I'd tried to reset the RC, but using the wrong button with C1 and C2 (I was pressing the button on the left, and not the one on the right). After resetting the RC using the correct sequence and power cycling the RC, all was back to normal.

thanks for your reply. does not work...i pressed the right buttons. but is it normal, that the RC makes D-D and shows the purple LED when I turn it on, even when the drone is turned off? souldn't it just show a red LED?
2017-1-13
Use props
unibond
lvl.1

United Kingdom
Offline

Hi guys I'm having the same problem .... just the purple light on the control
2017-1-27
Use props
unibond
lvl.1

United Kingdom
Offline

hi, did you get this problem sorted?
2017-1-27
Use props
fans28c12d89
lvl.1

United States
Offline

I'm sorry to hi-jack the thread, but I'm too new to open a new thread, apparently.
I'm having a problem between the P4P+ and the RC.
This is new, never flown and I haven't gotten through set up, yet.
The FW on the quad has been flashed to the current version.  When I power on the RC and quad all of the LEDs appear normal.  I have a green connection LED on both the RC and the quad.
On the controller screen I get the dji logo and then the "Hello" screen.  "Start" takes me to the "Welcome" screen.  I select "Next" and I then "Agree" to the User agreement and it goes to a WiFi screen.  I see all of the other networks around me, but not the P4P+.  If I select Next I get a pop-up message:
"Note
Network disconnected.  Failed to continue activating the remote controller.  Connect WiFi or insert wireless adapters."  
I select "Connect" and I'm back at the WiFi screen and stuck in a loop.  I can't move past this point.
I can see the P4P+ in the "DJI Assistant 2".  When I select "Simulator" I can rotate the camera up / down with the controller and I see the stick values change when I move them.
I've been tempted to re-sync the controller and quad, but it appears to be communicating and I don't want to make matters worse unnecessarily.
I hope I haven't overlooked anything simple.  Any help will be appreciated.
2017-1-30
Use props
oldandquitemad
lvl.1

United States
Offline

Never mind.  Someone on RC Groups was able to help me.
2017-1-30
Use props
Beasy B
lvl.1
Flight distance : 165240 ft
Belgium
Offline

Hi guys, I'm having the same problem and can't find a solution anywhere.
I have a Phantom 4 Pro (new out of the box), and I'm trying to connect it to the RC from my previous Phantom 4 (regular). For some reason they can't seem to connect.
Run through all the steps, automatically and manually, but none of them work. Any tips?
2017-2-15
Use props
_sawhe4d_
New
Flight distance : 185617 ft
United Kingdom
Offline

ve had this problem since last firmware update and the RC reset doesn't work. please help
2017-4-17
Use props
Mizamook
lvl.3
Flight distance : 1121519 ft
  • >>>
United States
Offline

Me too  this is really messed up.  Funny thing is it was WORKING before


2017-4-21
Use props
coptertux
New
Germany
Offline

Same problem here: Purple LED since I updated to 1.03.0509, reseting is not possible. Really annoying DJI
2017-5-3
Use props
fans0c8159f7
lvl.3
Flight distance : 511749 ft
United States
Offline

I have the same issue. Updated to the newest firmware and now the rc will not connect to the ac. Same purple led. Tried all button combos and nothing works. Anyone know how to fix this issue?
2017-6-10
Use props
Bootspike
lvl.4
Flight distance : 109281 ft
Australia
Offline

fans0c8159f7 Posted at 2017-6-10 13:18
I have the same issue. Updated to the newest firmware and now the rc will not connect to the ac. Same purple led. Tried all button combos and nothing works. Anyone know how to fix this issue?

Have you tried updating the firmware in your controller? That fixed my problem, but was not very obvious.
2017-6-10
Use props
fans0c8159f7
lvl.3
Flight distance : 511749 ft
United States
Offline

Yes I believe I did. Just after I updated the ac, I updated the controller. In the controller settings it says the latest software version is 1.04.01 or something like that.  I don't know how to ensure the update made it through.  I would like to reinstall the update but DJI assistant 2 has no way of updating the controller. That's the only thing I haven't been able to do is actually reinstall the update to the rc.
2017-6-10
Use props
fans0c8159f7
lvl.3
Flight distance : 511749 ft
United States
Offline

Otherwise I know the rc isn't talking to the ac. Funny thing is when I go to relink the rc by my iPhone, it says the ac is linked and clearly it is not do to the yellow flashing leds on the back of the ac.
2017-6-10
Use props
Stavros1603
lvl.1
Greece
Offline

unibond Posted at 2017-1-27 19:15
Hi guys I'm having the same problem .... just the purple light on the control

Same problem, steady purple light after update.
2017-6-14
Use props
Stavros1603
lvl.1
Greece
Offline

Stavros1603 Posted at 2017-6-14 01:11
Same problem, steady purple light after update.

After sharing the problem with Call Center in Germany, he suggested to send the controller for repair ... So, he did't convinced me that this was the right solution.
2017-6-14
Use props
fans2c1c2858
New
Ecuador
Offline

DJI-Jamie Posted at 2016-12-3 15:57
Try the following button combinations to manually refresh the communication:

Reset the RC:

Hi Jamie, I'm having the same issue here. I've tried your suggestion and it still doesn't work.
2017-6-17
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

fans2c1c2858 Posted at 2017-6-17 13:28
Hi Jamie, I'm having the same issue here. I've tried your suggestion and it still doesn't work.

If the issue still persists, then the next best course of action would be to send the unit in for service.
2017-6-17
Use props
MRC Media
lvl.1
United States
Offline

I'm having a semi-similar experience and cannot find a resolve for it. This Monday I foolishly updated the firmware on the P4P and it stalled at 99%. After 45 minutes and some reading on this forum I powered down the drone and remote and restarted them. The GO app checked the firmware update status and said all was good. Took the drone out and started it up, everything linked alright except my remote is flashing a green and yellow LED combination rapidly and the streaming view of my video it just a green pixealated blob with occasional bars of inverted color imagery. I used the remote to record undistorted video, shoot a photo and check for updates again but to no avail. Frustrated I powered everything down and plugged the aircraft into my computer and rolled back the firmware. Afterwards I got a video signal back again and thought I had solved my issue.

Tuesday I fired it up and tested the connection again without flying it and it took 3 attempts to get the remote to see the aircraft. Finally it linked up but I was concerned about the buggyness I was seeing and decided to abort. Today I took the drone out to fly and it will not connect at all. The remote has no idea there is an aircraft in range. I updated the firmware again, this time via the PC assistant and the remote is back to blinking green and yellow rapidly and showing me a green distorted pixel wall in the live view of the camera.

I have about 16 flights on this drone and I'm fuming that updating the firmware has turned into such a nightmare. I feel like there must be an easy fix for this but I'm just not getting it.
2017-6-23
Use props
MRC Media
lvl.1
United States
Offline

Sorry, the remote is flashing RED and GREEN, not yellow.
2017-6-23
Use props
Crashystm
New
Flight distance : 123894 ft
Iceland
Offline

MRC Media Posted at 2017-6-23 17:37
Sorry, the remote is flashing RED and GREEN, not yellow.

I have the exact same symptoms. Phantom 4 pro with iPad mini 4. Updated and I have no image feed from the drone. Remote light blinks red and green rapidly. Sometimes I get a pixelated green screen and somtimes some part of the screens shows up. DJI and their godforsaken firmware updates! I am fuming here. Finally had some time off to go fly and this updates bricks my drone. Tried to reinstall the update and messing with the HD link settings but nothing. Has anybody any ideas of how to fix this?
2017-6-24
Use props
fans040a977a
New
United States
Offline

MRC Media Posted at 2017-6-23 17:27
I'm having a semi-similar experience and cannot find a resolve for it. This Monday I foolishly updated the firmware on the P4P and it stalled at 99%. After 45 minutes and some reading on this forum I powered down the drone and remote and restarted them. The GO app checked the firmware update status and said all was good. Took the drone out and started it up, everything linked alright except my remote is flashing a green and yellow LED combination rapidly and the streaming view of my video it just a green pixealated blob with occasional bars of inverted color imagery. I used the remote to record undistorted video, shoot a photo and check for updates again but to no avail. Frustrated I powered everything down and plugged the aircraft into my computer and rolled back the firmware. Afterwards I got a video signal back again and thought I had solved my issue.

Tuesday I fired it up and tested the connection again without flying it and it took 3 attempts to get the remote to see the aircraft. Finally it linked up but I was concerned about the buggyness I was seeing and decided to abort. Today I took the drone out to fly and it will not connect at all. The remote has no idea there is an aircraft in range. I updated the firmware again, this time via the PC assistant and the remote is back to blinking green and yellow rapidly and showing me a green distorted pixel wall in the live view of the camera.

Having the exact same problem, hope someone has a surefire solution (or an update from DJI)
2017-6-26
Use props
SimonK
lvl.2
Flight distance : 801099 ft
United Kingdom
Offline

Same problem for me after updating my P4P+ via the app - controller light was rapidly flashing red/green and there was no transmission/signal from the camera, although I could still arm the motors. Tried the controller re-set and re-pair, didn't work.

As per another post here, I updated the controllers firmware through it's micro SD card slot and now I'm back in business. Off to give it a test flight later today.
2017-6-27
Use props
fans040a977a
New
United States
Offline

SimonK Posted at 2017-6-27 04:05
Same problem for me after updating my P4P+ via the app - controller light was rapidly flashing red/green and there was no transmission/signal from the camera, although I could still arm the motors. Tried the controller re-set and re-pair, didn't work.

As per another post here, I updated the controllers firmware through it's micro SD card slot and now I'm back in business. Off to give it a test flight later today.

Is the P4P+ working for you now?  Do you know if there's any way to update the firmware of the P4P with a micro sd card?  
2017-7-9
Use props
fans917b6ef3
lvl.1
Flight distance : 4767 ft
United States
Offline

I have same problem with p4... upgraded time nite...stuck at 99%...now remote flashes red green and no connection is made tried c1 c2 record and other suggestions below..nothing works..please help!
2017-7-13
Use props
fans917b6ef3
lvl.1
Flight distance : 4767 ft
United States
Offline

Fixed it!!!!!!!!!   Held in the top right 3 bars to get remote upgrade....this does not work to downgrade firmware without unplugging and re plugging iPad many times about 20 fails, but each time resumed at percentage where it failed until 100% was achieved...next he go 4 app finally recognizes that a remote upgrade is required.  Once I did this upgrade, all is fixed!!!!!!!
2017-7-14
Use props
Antonio76
Captain
Flight distance : 144403 ft
Denmark
Offline

Beasy B Posted at 2017-2-15 08:01
Hi guys, I'm having the same problem and can't find a solution anywhere.
I have a Phantom 4 Pro (new out of the box), and I'm trying to connect it to the RC from my previous Phantom 4 (regular). For some reason they can't seem to connect.
Run through all the steps, automatically and manually, but none of them work. Any tips?

The RC from the P4 does not work with the P4P. They are different. But by now I think you have realized it and got a P4P RC...
2017-7-14
Use props
fans81e92622
New

Australia
Offline

I can't connect to remote it's intamitted
2017-8-13
Use props
CaptCalvin
lvl.1
Flight distance : 65689 ft
United States
Offline

My RC has green light, My P4P has green light. I cannot get the two to connect.  In aircraft status I have POOR radio channel quality with "strong interference" Fly with caution below.  Any help would be appreciated as I am clueless.  
2017-8-21
Use props
alan Itacare
lvl.1
Brazil
Offline

I have the same problem.. 99% stopped loading... drone never used... not sure what to do next... want to return my drone for a refund!!!! Very frustrated
2017-8-22
Use props
AntonsenJO
lvl.1
Flight distance : 44045 ft
Norway
Offline

You are GOD ;-) you helped me ;-) I sat for two days now I got it
2017-10-5
Use props
bobwaz44\
lvl.3

United States
Offline

AntonsenJO Posted at 2017-10-5 12:17
You are GOD ;-) you helped me ;-) I sat for two days now I got it

Has anyone figured out how to get their Phantom 4 remote control to reconnect to their aircraft without using the  C1/C2 button method?  After applying a firmware update, my remote control has one solid red/pink light and four white lights.  The remote will not connect to the aircraft.  Unfortunately, I'm on firmware 1.9.3 already, so I cannot get the control to accept a new firmware update.  I've searched the web, and I cannot find a solution to this problem.  Any ideas are much appreciated.
2017-10-13
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules