Please select Into the mobile phone version | Continue to access the computer ver.
DJI no fly zone issues
1057 0 2016-12-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
PaulHerman
lvl.1

United States
Offline

My DJI Mavik Pro has worked perfectly for the first week or so. Then today around 3:00pm (ET) it all at once refused to take off. Checked everything I could think of, but could not resolve this issue. Logged on to the DJI support chat line, and the very courteous lady I chatted with suggested updating the firmware and reformatting the SD card. After doing so, the drone worked for one flight ... and then started reporting "No Fly Zone" whenever I tried to take off.

After a couple of hours of googling, experimenting, and trying to figure out the problem, it turned out to be the new GEO system implemented by DJI. Turned that feature OFF and now I can fly my drone again. For the record, I am nowhere near any no fly zones shown on the DJI NFZ map.

FYI, if your drone refuses to take off, and the aircraft status light is blinking 4 short greens one second apart, following by 2 long reds ... it apparently means that it thinks it is in a no fly zone. This particular error sequence is not documented in the DJI Mavik Pro manual. To fix the problem, disable "GEO System" in the DJO GO app.

Also of note ... the Litchi app also won't allow the aircraft to take off if the GEO System is enabled. It displays the error message "Unable to take off - Unknown error" (or something to that effect). I didn't find a way to enable/disable the GEO System from the Litchi app - but if you disable it using the DJI GO app, it seems to work for the Litchi app too. So apparently, the GEO System is something that runs on the firmware of the aircraft - not on the controller app.
2016-12-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules