Please select Into the mobile phone version | Continue to access the computer ver.
DJI team - Android 6.x.x support?
4192 17 2016-12-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

DJI team,
I have tried 3 different Samsung Tablets and only 1 worked w/ the app. It was running Android 5.x.x. (Tab A 7"). The Tab A 8" and the Tab S2 8" both have Android 6.01. Marshmallow and neither will allow the app to connect. A screen continually pops up asking if DJI GO or DJI GO4 (i tried both) should be the default app. If I can 'catch' the prompt (they flash quickly), the app will launch but it never connects w/ the Mavic. Eventually a timeout pops up saying the USB device can't communicate. When digging around in the menus of the tablets and looking at app detail, a pop up indicates 'This app was designed for an older version of Android'.

Yes, I realize the Samsung Tablets are not on your list of approved devices, but the S2 has 3Gb of RAM, quadcore Qualcomm processer, a new version of Android, and a great screen. It's not a 'knockoff'. It should be supported.

Is DJI Go and Go4 not supported in Android 6.0.1? Do you have an update coming out soon? I have to decide between using an iPad Mini 2 and the S2 and my preference is very strong for the S2. I think if DJI updated the app, it would work extremely well.
2016-12-13
Use props
Bullseye
lvl.3
Flight distance : 154423 ft
United States
Offline

For what its worth. I had the same errors occurring and (i think) a refresh of the controller firmware corrected mine.
I'm running 6.0.1 on a Note 5
2016-12-13
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

Bullseye Posted at 2016-12-13 19:38
For what its worth. I had the same errors occurring and (i think) a refresh of the controller firmware corrected mine.
I'm running 6.0.1 on a Note 5

Cool! I'll give that a try!
2016-12-13
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

Bullseye Posted at 2016-12-13 19:38
For what its worth. I had the same errors occurring and (i think) a refresh of the controller firmware corrected mine.
I'm running 6.0.1 on a Note 5

Well, I tried but no joy.  After the first refresh, it seemed to correct the issue of the 'bouncing' default app question, but I still didn't get a connection to the aircraft. I tried doing a refresh again and the bouncing came back. Strangely, there are 2 entries for the new current firmware. One is dated 12/6 and the other 12/9. Both showed the same (new) version v01.03.0000 but different dates. I tried both, no luck.
2016-12-13
Use props
Bullseye
lvl.3
Flight distance : 154423 ft
United States
Offline

Same thing here.  After seeing two versions I refreshed with the 12/6 version.  I also uninstalled and re-installed DJI Go 4.  After signing-in on the Go 4 app it all worked.  Not sure what I did to fix it.
After getting it working last Friday night I went flying Saturday in between rain showers, 4 flights no issues.  Good luck!
2016-12-13
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

Bullseye Posted at 2016-12-13 23:04
Same thing here.  After seeing two versions I refreshed with the 12/6 version.  I also uninstalled and re-installed DJI Go 4.  After signing-in on the Go 4 app it all worked.  Not sure what I did to fix it.
After getting it working last Friday night I went flying Saturday in between rain showers, 4 flights no issues.  Good luck!

Which tablet? I'll try re-tracing your steps exactly, although I did try installing and uninstalling both the Go app and the Go4 app, but not sure exactly about sequence.
2016-12-13
Use props
Bullseye
lvl.3
Flight distance : 154423 ft
United States
Offline

I'm on a Note 5. I only have Go 4 loaded

If you have both apps loaded this thread may help   http://forum.dji.com/thread-75403-1-1.html
2016-12-13
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Offline

zach5150 Posted at 2016-12-14 13:11
Which tablet? I'll try re-tracing your steps exactly, although I did try installing and uninstalling both the Go app and the Go4 app, but not sure exactly about sequence.

If you just keep one APP installed on device, how about the performance?
2016-12-14
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

DJI Natalia Posted at 2016-12-14 08:54
If you just keep one APP installed on device, how about the performance?

Same. I've tried each app individually installed. I've reset the tablet to factory and install fresh. I've refreshed the firmware on the RC. I know some people have had luck, and there are many variables at play, but from my research and the symptoms I'm seeing, it appears to be more of a conflict with the way Android 6.x.x manages USB devices than the app itself. I believe a firmware update to the RC as well as an update to the app is required to be fully stable for Android 6.

Of course, I'm not a DJI developer, so any insight from your team would be helpful.
2016-12-14
Use props
thehippoz
Captain
Flight distance : 23 ft
United States
Offline

I posted this in another thread. Also run 6.0.1 Marshmallow here. Finally got the drobe flying stable this morning. I used assistant 2 to downgrade firmware to v01.02.0900, but I couldn't get the rc to complete. It worked though, upgraded back to 1.3 in go 4. Then downgraded again back to 1.2. It completed on both and reset the defaults.

Wiped go 4 off my phone, cache and erased the folders. Then installed old go. The thing is flying like she used to finally. I could use all the gps features like tripod and gestures indoors and switching from opti to gps mode doesn't cause the drone to drift. Outdoors was never a problem. So basically I'm stuck on 1.2 firmware with the lastest version of go 3.

Going to wait till the nd filters, rear view camera and audio parts to come in to post up anything decent. But happy with this.
2016-12-14
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

thehippoz Posted at 2016-12-14 11:07
I posted this in another thread. Also run 6.0.1 Marshmallow here. Finally got the drobe flying stable this morning. I used assistant 2 to downgrade firmware to v01.02.0900, but I couldn't get the rc to complete. It worked though, upgraded back to 1.3 in go 4. Then downgraded again back to 1.2. It completed on both and reset the defaults.

Wiped go 4 off my phone, cache and erased the folders. Then installed old go. The thing is flying like she used to finally. I could use all the gps features like tripod and gestures indoors and switching from opti to gps mode doesn't cause the drone to drift. Outdoors was never a problem. So basically I'm stuck on 1.2 firmware with the lastest version of go 3.

Interesting! Thanks! OK. If I get that to work, the question I have to answer is whether I want to stick w/ Android or just go with iOS. Tough call. Thanks very much for the detailed procedure info.

P.S. rear camera???
2016-12-14
Use props
thehippoz
Captain
Flight distance : 23 ft
United States
Offline

zach5150 Posted at 2016-12-15 01:31
Interesting! Thanks! OK. If I get that to work, the question I have to answer is whether I want to stick w/ Android or just go with iOS. Tough call. Thanks very much for the detailed procedure info.

P.S. rear camera???

Oh just mods. You can mix it all up in premiere so you hear the blades spinning instead of music and have a rear view. I do it on my toy drone with fpv camera and down facing cam. I'm excited about the 4k on gimbal. Going to have a speaker mod can attach too. Then can bullhorn over it or play music xd

https://www.dropbox.com/s/2ah7e1 ... 209_132305.mp4?dl=0
https://www.dropbox.com/s/csu62s ... 09131504_1.mp4?dl=0
2016-12-14
Use props
fansea1e504f
lvl.2

United States
Offline

ive never has a issue connecting my tab s2... I use a short usb cable from the bottom of the controller to the tab and have no issues at all..
2016-12-14
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

fansea1e504f Posted at 2016-12-14 12:45
ive never has a issue connecting my tab s2... I use a short usb cable from the bottom of the controller to the tab and have no issues at all..

What version Android are you running? And what version firmware are you running on the Mavic and RC?
2016-12-14
Use props
zach5150
lvl.3
Flight distance : 225148 ft
United States
Offline

thehippoz Posted at 2016-12-14 11:49
Oh just mods. You can mix it all up in premiere so you hear the blades spinning instead of music and have a rear view. I do it on my toy drone with fpv camera and down facing cam. I'm excited about the 4k on gimbal. Going to have a speaker mod can attach too. Then can bullhorn over it or play music xd

https://www.dropbox.com/s/2ah7e127o23tbl4/VID_20161209_132305.mp4?dl=0

Ha! cool! Is that a Syma X5C?
2016-12-14
Use props
thehippoz
Captain
Flight distance : 23 ft
United States
Offline

zach5150 Posted at 2016-12-15 07:23
Ha! cool! Is that a Syma X5C?

Yeah it's that little one think x5c or something. But it does have new motors on it and I bent an antenna up inside so it can handle circular. Works good cause always spinning the thing.
2016-12-14
Use props
AREOVISION
lvl.1
France
Offline

Thank for your post i had the same problem:  The screen continually pops up asking  DJI GO 4 but can not catch the prompt. with android 7 on Samsung S2. I didn't find a solution could you help?no solution
2018-7-9
Use props
miketmtpro
Second Officer
Flight distance : 1883940 ft
United States
Offline

rollback the App to 4.2.14

latest versions of Go4 have trashed most Android device experiences even on newer phones and tablets like the Gal Tab S3, NOTE 8, S9 etc.

Uninstall GO4 app if version 4.2.20, then uncheck "auto update" from the Play Store for the Go4 app

Locate APK version of Go4 4.2.14 on APKpure site. Install 4.2.14

Enjoy flying again.

Tons of this and the suggestions from everywhere is buy an iOS device. Not the best answer for people that already spent on other devices, spend $1000 or more on a drone, had great flights up until the most recent app updates, and then told to buy an iOS device? Not going to make a great customer experience that way.

The DJI list of recommended devices is also very very dated. Most commonly sold Android tablets are not on the list. NOTE 4 is the last working tested phone? NOTE 8 is many times more powerful than the NOTE 4.

Most people that had great experiences with their Android devices (quite capable and well in spec of Go4) are ignoring the list of recommended (iOS mainly devices) and downgrading the app to 4.2.14 which is the last one to not have a bazillion problems with Android.

Another option is using the Litchi App. It's a great app and it works. Most Android users I know have flown with Litchi and very very few report any issues with the app. Video transmission issues are seldom heard of.



2018-7-9
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules