Please select Into the mobile phone version | Continue to access the computer ver.
Gimbal Fails to Initialise
2082 8 2016-12-18
Uploading and Loding Picture ...(0/1)
o(^-^)o
MikeTelfer
lvl.1

Australia
Offline

FYI after approximately 6 fights with my P4P - The Gimbal now fails to  initialise on startup. I ran through firmware updates etc but on closer  inspection it appears the camera actually touches the ribbon cable on  the gimbal on the TILT axis. This seems to have caused a problem with  the ribbon cable and now the TILT axis will not initialize. It is  completely dead. It appears to be a manufacturing fault.  

Has anyone else experienced this? Is there any way to fix this? It appears the ribbon cable has been damaged VERY easily after just a few flights.



2016-12-18
Use props
Jusba31
lvl.2
Flight distance : 248169 ft
Finland
Offline

I'm having same kind of problem.
My gimbal still works, but not as it should. Here is the video what happens when I power up the machine. Watch with the sound on, so you can hear the sound that I think is about that ribbon cable touching the camera/some where in gimbal other parts.
[url= ]Phantom 4 Pro gimbal problem[/url]

2016-12-18
Use props
fans871ed355
lvl.1
United States
Offline

My gimbal was also not working right out of the box, tried firmware upgrade, downgrade, calibration, nothing would fix it.  Looked similar to yours.  Never even got to fly it once.  Sent it back to them for a replacement weeks ago and they still haven't even updated my case to show it is approved for replacement yet.  Pretty frustrating I ordered immediately after announced and now apparently won't have one for Christmas (and they won't give my money back either).
2016-12-18
Use props
Coffee
lvl.2

United States
Offline

Hey Mike can you upload a photo of where it's touching? I had an issue with my gimbal which got stuck in a tilted downward position, was really frustrated but found another thread with a few people having the same issue. I downgraded my firmware three versions, did all calibrations my phantom asked me to do, then upgraded to current and it's working properly. If this is a hardware problem like it sounds I would definitley send it back. I think their policy of making customers with brand new products wait weeks for a replacement is complete utter garbage. DJI really needs to improve their customer service.
2016-12-18
Use props
epicjib
First Officer
Flight distance : 3016060 ft
  • >>>
Canada
Offline

Jusba31 Posted at 2016-12-19 05:39
I'm having same kind of problem.
My gimbal still works, but not as it should. Here is the video what happens when I power up the machine. Watch with the sound on, so you can hear the sound that I think is about that ribbon cable touching the camera/some where in gimbal other parts.
https://youtu.be/mxNnRZynIqI]Phantom 4 Pro gimbal problem[/url]

Mine does the same thing, the ribbon coil is catching on something by the tilt motor
2016-12-18
Use props
fansceec204b
lvl.2
Flight distance : 47700 ft
Australia
Offline

I have the very same problem. emailed dvi and they replied to me: "We are sorry to hear about the problem. This issue has been confirmed, and we will release a firmware to fix the problem soon. Before that, you can help proceed the gimbal camera initialization by hand. Just to help move the gimbal camera goes up and down. "

2016-12-18
Use props
punkie
lvl.4
Australia
Offline

fansceec204b Posted at 2016-12-19 13:55
I have the very same problem. emailed dvi and they replied to me: "We are sorry to hear about the problem. This issue has been confirmed, and we will release a firmware to fix the problem soon. Before that, you can help proceed the gimbal camera initialization by hand. Just to help move the gimbal camera goes up and down. "

I love how clear Dji are in their instructions!! So you know exactly what to do now??
2016-12-18
Use props
Geebax
Captain
Australia
Offline

punkie Posted at 2016-12-19 15:54
I love how clear Dji are in their instructions!! So you know exactly what to do now??

You could probably get a detailed reply in Chinese. You do understand Chinese, don't you?
2016-12-18
Use props
Jusba31
lvl.2
Flight distance : 248169 ft
Finland
Offline

fansceec204b Posted at 2016-12-19 04:55
I have the very same problem. emailed dvi and they replied to me: "We are sorry to hear about the problem. This issue has been confirmed, and we will release a firmware to fix the problem soon. Before that, you can help proceed the gimbal camera initialization by hand. Just to help move the gimbal camera goes up and down. "

How does the firmware update change that thing, that there is some mechanical problem what makes that klik sound when camera is moving?
There are already a couple of guys reported that their gimbal is totally dead because of broken ribbon cable.
2016-12-19
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules