Please select Into the mobile phone version | Continue to access the computer ver.
ESC error M600
1913 13 2016-12-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
gryzzly
lvl.3

United States
Offline

Hello,
I have recently replaced a bad motor on my M600 but I'm still getting a M600 error.  When I start it up the lights at the end of the motors flash yellow on all but my new motor.  Its like all the other motors need to be reset or something.  Any advice?
Thanks!

2016-12-29
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

Did you only replace the motor itself, or its whole arm? Did you make sure you got the appropriate CW or CCW one?
2016-12-29
Use props
gryzzly
lvl.3

United States
Offline

DJI-Jamie Posted at 2016-12-29 13:19
Did you only replace the motor itself, or its whole arm? Did you make sure you got the appropriate CW or CCW one?

I replaced the whole arm assembly.  And yes, I got the appropriate one.  The one I replaced actually turns when ESC testing in DJI Assistant.  It's all the others that don't turn. Its as if the others are stuck in "auto-shutoff" mode or something.  Like they just need to be reset or something.  
2016-12-29
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

gryzzly Posted at 2016-12-29 14:34
I replaced the whole arm assembly.  And yes, I got the appropriate one.  The one I replaced actually turns when ESC testing in DJI Assistant.  It's all the others that don't turn. Its as if the others are stuck in "auto-shutoff" mode or something.  Like they just need to be reset or something.

Just to clarify, did you replace the motor due to a crash or out of box issue?
2016-12-30
Use props
gryzzly
lvl.3

United States
Offline

DJI-Jamie Posted at 2016-12-30 10:34
Just to clarify, did you replace the motor due to a crash or out of box issue?

It was a crash, but the motor I replaced was the only one with physical damage.  The arm broke and the wires were pulled from the motor mount so I replaced the whole arm assembly.
2016-12-30
Use props
Tahoe Ed
Super Moderator
Flight distance : 41668330 ft
  • >>>
United States
Offline

Did you check all the connections on the motors that you did not replace.  Do you have the flight data log of that crash?  I am just wondering if something else was damaged.
2017-1-1
Use props
gryzzly
lvl.3

United States
Offline

Tahoe Ed Posted at 2017-1-1 15:54
Did you check all the connections on the motors that you did not replace.  Do you have the flight data log of that crash?  I am just wondering if something else was damaged.

Do you mean open up all the motor mounts and check the wires connecting to the ESC board?  No, I didn't do that.  But I don't think those wires would have been put under stress when none of those arms were affected by the crash.  The main hub of the craft wasn't hurt either and all those connections look fine.  I downloaded the ".dat" files from the bird, but apparently there is no way to read those.  Only DJI support can?  What do I need to do to get the log of the crash?

I'm really hoping to repair this thing myself because shipping an M600 is a pain...
2017-1-1
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

gryzzly Posted at 2017-1-1 21:29
Do you mean open up all the motor mounts and check the wires connecting to the ESC board?  No, I didn't do that.  But I don't think those wires would have been put under stress when none of those arms were affected by the crash.  The main hub of the craft wasn't hurt either and all those connections look fine.  I downloaded the ".dat" files from the bird, but apparently there is no way to read those.  Only DJI support can?  What do I need to do to get the log of the crash?

I'm really hoping to repair this thing myself because shipping an M600 is a pain...

Just for further troubleshooting, have you tried switching the working arm with one of the other arms fo see if it only responds to the replaced arm or that particular motor position.
2017-1-5
Use props
gryzzly
lvl.3

United States
Offline

DJI-Jamie Posted at 2017-1-5 15:00
Just for further troubleshooting, have you tried switching the working arm with one of the other arms fo see if it only responds to the replaced arm or that particular motor position.

I have not, but I'll give it a try when I get some time.  
2017-1-5
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

gryzzly Posted at 2017-1-5 16:39
I have not, but I'll give it a try when I get some time.

Whenever you have a chance would be great.
2017-1-5
Use props
RimpleStillSkin
lvl.1

United States
Offline

I have just updated firmware on M600 and I got 1ESC Error Status.  The M1 motor blinks yellow about 1 time a second.  I have downgraded best I know how but no help.  DJI Go app says to contact DJI Customer Support?  What should I do?   My Z5 light is red.   This aircraft has performed flawlessly up til now.  No crashes, no flips, simple perfect operations and soft landings.

Is there a way to revert software to the very beginning and reload everything?   

What is DJI solution?

Or should I start a new thread.

Thanks.
2017-3-4
Use props
ricci2
Captain
Flight distance : 61158 ft
  • >>>
France
Offline

gryzzly Posted at 2017-1-1 21:29
Do you mean open up all the motor mounts and check the wires connecting to the ESC board?  No, I didn't do that.  But I don't think those wires would have been put under stress when none of those arms were affected by the crash.  The main hub of the craft wasn't hurt either and all those connections look fine.  I downloaded the ".dat" files from the bird, but apparently there is no way to read those.  Only DJI support can?  What do I need to do to get the log of the crash?

I'm really hoping to repair this thing myself because shipping an M600 is a pain...

Hi,
This thread shows how to read the data using assistant 2 data view if that helps .
http://forum.dji.com/thread-83184-1-1.html
Ricci
2017-3-4
Use props
RimpleStillSkin
lvl.1

United States
Offline

ricci2 Posted at 2017-3-4 19:13
Hi,
This thread shows how to read the data using assistant 2 data view if that helps .
http://forum.dji.com/thread-83184-1-1.html

thanks... will take a look
2017-3-5
Use props
RimpleStillSkin
lvl.1

United States
Offline

Replaced the M1 motor arm CCW and error went away... crap
2017-3-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules