Please select Into the mobile phone version | Continue to access the computer ver.
DJI GO don't recognize Controller
1881 11 2017-1-3
Uploading and Loding Picture ...(0/1)
o(^-^)o
agustin9200
lvl.1

Argentina
Offline

Hi to all, I need help with a problem that I am having with my Phantom 3 Professional.

The app of DJI GO dont recognize any more the remote controller.

The controller connect to the aircraft I can move de camera with the left scroll , but the when i open the DJI GO app, i seem that is not conected, previously it show the mesage " Camare View" but now it appeard "How To Connect" .

I tried with my Samsung phone  and a Samsung Galaxy tablet, but the same problem.
I unistall the app DJI GO, and restore the factory preset to my phone, I installed again the app but the same problem.

The light in the controller stay in green blinking slowly.
And the aircraft light's two green slowly blinking.

I don't know what happend, before when I connect the phone to the controller it poop up a message and open the DJI go app, but now when i connected it don't recognize anymore, and it seems like it be a phone charger connected.

Any one have the same problem that can help me?

Thanks to all
Regards


2017-1-3
Use props
Ranini
Second Officer
Flight distance : 478422 ft
Mauritius
Offline

are you able to fly without connecting your phone ?
if not just re link your remote

here is how to do it

2017-1-3
Use props
iMeMoz
lvl.2
Flight distance : 298720 ft
Finland
Offline

If you can tilt the camera and even fly it, problem seems to be between RC and phone. Have you tried using different cable (it needs to be data cable not just charging)? Also if possible try with different mobile device.
2017-1-3
Use props
Squishy The Dog
lvl.1
Flight distance : 73665 ft

United Kingdom
Offline

Hello agustin9200, Please try a different cable as IMeMoz posted above. If not, Try enabling developer options and then enable USB debugging in developer options. A quick google search will tell you how to do this. If the problem still persists. Try swiping down to open the notification window then press the charging option then press transfer files and media. This should hopefully fix your problem. Please bear in mind that the controler must be on and connected to see this option in notifications. Good luck!
2017-1-3
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Please try above advice and let us know if it helps.
2017-1-4
Use props
Oldflyer-141
lvl.2
Flight distance : 1707310 ft
United States
Offline

I had this same problem many times, but since I started this sequence I have not had a problem of the them not connecting.

1) With the tablet disconnected from the RC, Make sure the tablet is turned OFF.
2) Power on the RC
3) Power on the Phantom; you should get a green light on the RC
4) Connect the USB cable to the tablet and the RC
5) Power ON Tablet; then launch DJI GO

Good Luck
2017-1-4
Use props
PhantomBearcat
lvl.1
United States
Offline

Oldflyer-141 Posted at 2017-1-4 09:21
I had this same problem many times, but since I started this sequence I have not had a problem of the them not connecting.

1) With the tablet disconnected from the RC, Make sure the tablet is turned OFF.

I'm having the same problem even after using the above method. Used to work fine. Now the DJI app thinks that I have an inspire drone. When I scroll to the Phantom 3, it displays the how to connect button.
2017-1-4
Use props
PhantomBearcat
lvl.1
United States
Offline

So, an update from my world. I was able to obtain an IOS device to see if it changed anything related to my issue. Well, it sure did. When starting the DJI app, I was able to enter the interface for Phantom 3 professional, but I saw a message that the remote controller required a firmware upgrade. No problem, but it gave me the web address for version 1.3.20 for an INSPIRE?!?! I don't have an inspire. It sounds like my controller needs a lobotomy.
2017-1-6
Use props
Dan Hargrave
lvl.1
United States
Offline

Squishy The Dog Posted at 2017-1-3 11:57
Hello agustin9200, Please try a different cable as IMeMoz posted above. If not, Try enabling developer options and then enable USB debugging in developer options. A quick google search will tell you how to do this. If the problem still persists. Try swiping down to open the notification window then press the charging option then press transfer files and media. This should hopefully fix your problem. Please bear in mind that the controler must be on and connected to see this option in notifications. Good luck!

This absolutely worked for me!!!  I have 2 tablets.  The Nexus 7 has no problem.  The Nextbook I bought from Walmart worked before and when I updated the software it didn't work.  I did the first part and it worked.  I didn't have to do the second part.  Thank you Squishy!!!
2017-3-25
Use props
Dan Hargrave
lvl.1
United States
Offline

Dan Hargrave Posted at 2017-3-25 09:27
This absolutely worked for me!!!  I have 2 tablets.  The Nexus 7 has no problem.  The Nextbook I bought from Walmart worked before and when I updated the software it didn't work.  I did the first part and it worked.  I didn't have to do the second part.  Thank you Squishy!!!

To clarify:  The cable was not the problem.  I enabled developer options and then enabled USB deubugging in developer options.  Works now.  Thanks Squishy!!!
2017-3-25
Use props
Blu Sky farm
lvl.1
Flight distance : 13645 ft
United States
Offline

Ok folks I have some what of the same problem but with a twist, I also have the 3pro my rc and phantom connect but that all I get I can't get past the how to connect, I've tried different cords, deleted the app and reloaded, I hit the reset button on the phantom still nothing any ideas?
2017-3-25
Use props
KeesJ
lvl.2

Netherlands
Offline

Squishy The Dog Posted at 2017-1-3 11:57
Hello agustin9200, Please try a different cable as IMeMoz posted above. If not, Try enabling developer options and then enable USB debugging in developer options. A quick google search will tell you how to do this. If the problem still persists. Try swiping down to open the notification window then press the charging option then press transfer files and media. This should hopefully fix your problem. Please bear in mind that the controler must be on and connected to see this option in notifications. Good luck!

Squishy,

I now you posted this tip long ago but you completely helped me out. Thumbs up.
Do you know whether one can savely disable developer options once the phone reliably detected the RC/Drone? Or do you have to keep it on?

Best regards, Kees
2017-11-19
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules