Please select Into the mobile phone version | Continue to access the computer ver.
GO4 app inflight video feed artifacts - is this normal?
1643 18 2017-1-16
Uploading and Loding Picture ...(0/1)
o(^-^)o
Spirytus
lvl.3
Flight distance : 126864 ft
  • >>>
Canada
Offline

Hello everyone,

Love my P4P, still learning the ropes and so far it's been performing flawlessly. That said, this being my first DJI product, I don't have much of a bench mark to base my flight-tests on so can anyone please look at my short clip linked below and tell me if the compression artifacts and the video feed stutter is normal on the GO4 app?



Any way I can improve this?

P.S. Recorded video is just fine. Using Go4 app on a Nexus 7 (2013).
2017-1-16
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Online

Please confirm the firmware version on "About" page, all are up to date?
You flew it in different open places, and noticed the same issue on live feed for each flight?
Please reset camera settings then check the shutter again, and make sure all other background programs are disable when flying.
It's appreciated if you can try another mobile device, if still the same case, please make a screenshot of HD page, thanks.
2017-1-16
Use props
Cetacean
Captain
Flight distance : 2494390 ft
  • >>>
United States
Offline

Aloha Spirytus,

     Aside from what Natalia wrote, I noticed you used 1080p at 120 frames per second.  When I used that high a frame rate, I had that problem to with the live view.  Just to experiment, cut the frame rate to 60 frames per second and see if the live view cleans up.

     The high frame rate somehow messes with the live view, at least for mine.  The recorded video is fine but live view is problematic.  It seems recording at 4K is easier on the system than 120 frames per second.  I have a hard time even wrapping my imagination around 120 frames per second.

     Hope this helps!

Aloha and Drone On!
2017-1-17
Use props
fans7a3c33ca
lvl.2

United States
Offline

My live feed on my p4 is so garbled I can barely use it.  However...oddly I can disconnect the cable from controller to the NVidia Shield I bought hoping the NViDIa's mor "gamimg" power and speed would solve it.    Did I get a bad cable?  Other suggestions.  And yes I cut the image quality way down...same thing.   Dji..how can I get help on this and a couple more cords before sendimg it BACK in again for repair please.   Of note it has the updated HDMI module on controller
Thanks ,  mark
2017-1-17
Use props
Helimage
lvl.4
Flight distance : 144140 ft
Finland
Offline

I have more or less artifacts every single flight, no matter the circumstances. Even in open areas the feed might glitch at any point, but it's definitely more noticeable with greater distances. It's not unusable, just a bit annoying if it's continuous. I found that the 3rd party app Litchi has a more stable video feed, but I don't know if this is the case for everyone.
2017-1-17
Use props
Spirytus
lvl.3
Flight distance : 126864 ft
  • >>>
Canada
Offline

DJI Natalia Posted at 2017-1-16 23:02
Please confirm the firmware version on "About" page, all are up to date?
You flew it in different open places, and noticed the same issue on live feed for each flight?
Please reset camera settings then check the shutter again, and make sure all other background programs are disable when flying.

Firmware is latest:

V01.02.0304 on the FC.
V01.03.00.00 on the remote controller.
App version 4.0.1.

I did fly it in 4 different locations since I got it. Noticed it all 4 times (live feed only, recording was good).

Will try all things suggested and will get back to you.
2017-1-17
Use props
Ipecactus
lvl.2
Flight distance : 25489 ft
United States
Offline

Spirytus Posted at 2017-1-17 07:33
Firmware is latest:

V01.02.0304 on the FC.

I have the same issue with two different tablets.  I thought it might be radio interference but I'm out in the desert at the moment and still experiencing artifacts and freezing.

But, I am not on the latest firmware yet. I may update tomorrow.
2017-1-17
Use props
Spirytus
lvl.3
Flight distance : 126864 ft
  • >>>
Canada
Offline

Update: Unfortunately the weather did not cooperate today, thankfully I was able to duplicate this issue on my bench and I "think" I got it fixed.

I took a shotgun approach and carried out the following:

1. Disabled local video caching, cleared cache and made sure GO4 app was the only active process running.
2. Forced GPU rendering through developer mode (http://www.androidauthority.com/enable-developer-options-569223/)
3. Reset camera settings as Nat suggested.

Artifacts / video-link stutter is now gone (while my phantom sits on the desk). Hopefully I'll be able to test it in-flight tomorrow... Will keep you posted.
2017-1-17
Use props
Cetacean
Captain
Flight distance : 2494390 ft
  • >>>
United States
Offline

fans7a3c33ca Posted at 2017-1-17 02:28
My live feed on my p4 is so garbled I can barely use it.  However...oddly I can disconnect the cable from controller to the NVidia Shield I bought hoping the NViDIa's mor "gamimg" power and speed would solve it.    Did I get a bad cable?  Other suggestions.  And yes I cut the image quality way down...same thing.   Dji..how can I get help on this and a couple more cords before sendimg it BACK in again for repair please.   Of note it has the updated HDMI module on controller
Thanks ,  mark

Aloha mark,

     My P4 is working very well with the nVidia Shield K1.  Yes, a bad cable can cause problems, try another cable but do not coil it if it is long (that creates interference).  If it works, buy a 1 foot data cable, shielded if possible.

     The nVidia Shield K1 needs to have all apps not involved with flying disabled or deleted.  There is an option to allow only one app to operate and/or one in the background.  No more than one in the background.  Multiple apps can make even the fastest tablet mess up.

     When you say you cut the image quality way down is that in the HD option or in the recorded camera controls?  Also, how is the quality in the HDMI view?  Note that Spirytus said he reset the camera settings.  With his particular problem that alone could solve his problem, so maybe it can help you.

     You appear to have what you need to resolve this issue but you have to test the options.

Aloha and Drone On!
2017-1-17
Use props
Cetacean
Captain
Flight distance : 2494390 ft
  • >>>
United States
Offline

Helimage Posted at 2017-1-17 03:37
I have more or less artifacts every single flight, no matter the circumstances. Even in open areas the feed might glitch at any point, but it's definitely more noticeable with greater distances. It's not unusable, just a bit annoying if it's continuous. I found that the 3rd party app Litchi has a more stable video feed, but I don't know if this is the case for everyone.

Aloha Helimage,

     Have you tried setting the options to custom in HD in the General Options?  Set the bitrate to its lowest setting and choose the most stable channel.  This can really help in some cases.

Aloha and Drone On!
2017-1-17
Use props
Cetacean
Captain
Flight distance : 2494390 ft
  • >>>
United States
Offline

Ipecactus Posted at 2017-1-17 18:34
I have the same issue with two different tablets.  I thought it might be radio interference but I'm out in the desert at the moment and still experiencing artifacts and freezing.

But, I am not on the latest firmware yet. I may update tomorrow.

Aloha Ipecactus,

     Have you tried setting the options to custom in HD in the General Options?  Set the bitrate to its lowest setting and choose the most stable channel.  This can really help in some cases.

     Be sure your tablets have no apps running in the background.  Even with the new firmware, if it does not solve the problem, try the Custom option in HD with lowest bitrate and stable channel.

Aloha and Drone On!
2017-1-17
Use props
Helimage
lvl.4
Flight distance : 144140 ft
Finland
Offline

Cetacean Posted at 2017-1-17 22:42
Aloha Helimage,

     Have you tried setting the options to custom in HD in the General Options?  Set the bitrate to its lowest setting and choose the most stable channel.  This can really help in some cases.

Cetacean, wireless digital signal is very, very susceptible to interference, and most people fly in diverse areas with lots of possible obstacles. While optimizing transmission settings might do something, it definitely doesn't get rid of the issue. As I said, the issue isn't that bad for me, just occasional glitches.
2017-1-18
Use props
Cetacean
Captain
Flight distance : 2494390 ft
  • >>>
United States
Offline

Helimage Posted at 2017-1-18 02:00
Cetacean, wireless digital signal is very, very susceptible to interference, and most people fly in diverse areas with lots of possible obstacles. While optimizing transmission settings might do something, it definitely doesn't get rid of the issue. As I said, the issue isn't that bad for me, just occasional glitches.

Aloha Helimage,

     Have you tried parabolics?  The little reflectors you put on your antennae that amplify the RC signal?  They also shield interference from behind the operator's back and side.  The ones I use have helped keep my screen behaving very well and also when playing in the jungle, they help penetrate the jungle foliage.  I used to have regular problems with green screens and pixelation.  Now it is a rarity.

Aloha and Drone On!
2017-1-18
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Online

fans7a3c33ca Posted at 2017-1-17 02:28
My live feed on my p4 is so garbled I can barely use it.  However...oddly I can disconnect the cable from controller to the NVidia Shield I bought hoping the NViDIa's mor "gamimg" power and speed would solve it.    Did I get a bad cable?  Other suggestions.  And yes I cut the image quality way down...same thing.   Dji..how can I get help on this and a couple more cords before sendimg it BACK in again for repair please.   Of note it has the updated HDMI module on controller
Thanks ,  mark

In addition, please try another mobile device to check the performance again.
2017-1-19
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Online

Spirytus Posted at 2017-1-17 20:47
Update: Unfortunately the weather did not cooperate today, thankfully I was able to duplicate this issue on my bench and I "think" I got it fixed.

I took a shotgun approach and carried out the following:

Glad to hear the improvement, please have a test and keep us posted, thanks.
2017-1-19
Use props
SPIKE_151
First Officer
Flight distance : 69767 ft
United Kingdom
Offline

Could be a couple of issues here, the snow on the ground confirms the temperature there is below zero centigrade, your drone is only certified to work properly at a lowest temp of -5 degrees Centigrade. if your temp is there or there abouts that may be a cause of the issue. Another is the polarisation of the Phantom antennas, as you turn your drone, at some point the the polarisation will not be picked up by the craft , for a a fraction of a second. The only antennas that get round this are the aftermarket circular polarized antennas


circular polarized antennas
2017-1-19
Use props
Spirytus
lvl.3
Flight distance : 126864 ft
  • >>>
Canada
Offline

DJI Natalia Posted at 2017-1-19 01:56
Glad to hear the improvement, please have a test and keep us posted, thanks.

Just to update and put an end to my issue:
To recap from last week:
•        Was able to duplicate the fault on the bench:
o        Disabled local video caching in the GO4 app.
o        Forced GPU rendering through developer mode (instructions here: (http://www.androidauthority.com/enable-developer-options-569223/).
o        Reset Camera setting through the GO4 app.
•        Video feed issues disappeared, but was unable to test in-flight due bad weather.
Last week I tested the above in-flight with mixed results;
•        Upon aircraft initialization video feed tearing and compression artifacts returned.
•        Flew it around for 5 minutes, confirmed all apps (except GO4) were shut down, reset forced GPU rendering in the developer mode and this seemed to have fixed video feed issues for the remainder of the flight.
Today:
•        Before flight I cleared my system cache partition (http://forums.androidcentral.com ... partition-wipe.html)
•        At location I reset/forced GPU rendering through Developer mode.
•        Tested the feed inflight without issues.
•        Tried different recording speeds and resolutions, both 2.4Ghz and 5.8Ghz frequencies, video feed is smooth without interruptions.
To recap, I’m using a Nexus 7 (2013), running Android 6.0.1 Marshmallow.
Thanks for your feedback guys/gals.
2017-1-23
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Online

Spirytus Posted at 2017-1-23 15:04
Just to update and put an end to my issue:
To recap from last week:
•        Was able to duplicate the fault on the bench:

Appreciated for your update and details, that's helpful.
Enjoy your flight!
2017-1-24
Use props
Eraser339
lvl.2
Flight distance : 25502 ft
Australia
Offline

I also have the same problem with an old Android Samsung galaxy Note 3. I updated the DJI GO 4 App to 4.2.8. I have done a low light test AND NO TEARING. I turned all the GPU developer options off as this article "https://android.stackexchange.com/questions/68819/why-is-force-gpu-rendering-disabled-by-default-developer-options?utm_medium=organic&utm_source=google_rich_qa&utm_campaign=google_rich_qa" and others suggest multiple cpu's if not sleeping are faster.

I have an App on my Android phone that has 4 Cores, called System Monitor. It shows GPU usage, CPU usage and Memory Usage. I check if any of the CPU were Idle. My concern was that the DJI GO 4 app was NOT Multithreading. I ran this while viewing the camera and all 4 cores burst into life when the App was running. The GPU showed minimal activity but the DJI GO 4 APP was in background and according to the Android application lifecycle the App should hibernate. Though the graph did not reflect any activity from the time the DJI GO 4 app was running.

I'll try later in full sun light.
2018-3-26
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules