Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go not saving settings to Inspire
1162 12 2017-1-31
Uploading and Loding Picture ...(0/1)
o(^-^)o
Ogilthorp
lvl.1

United States
Offline

Hello - I have a Inspire 1 and am having issues with the settings I put in the Go app instantly losing their values as soon as I move away from the screen.  A video will be easier to show here :



The only thing out of the ordinary with my setup is that the battery has a "broken cell" (even though the app shows all the cells with voltage).  Not sure if that would be why.

Anyone run into this before?
2017-1-31
Use props
Donnie Stugots
Captain
Flight distance : 3636782 ft
United States
Offline

Just wonder if becasue you had the  compass error if that was the cause , can you try again without the error dispaly .
A  Broken cell is a common warning and and a FULL drain  ( below 3% ) and a full charge should remedy that .  Keep the aircraft in tight for the next flight with the battery just in case indeed a cell is broken , I doubt it though .

You did not happen to have the Mode switch on the RC already set to  F or A mode did you ? If you did try to put it in default P mode and try again .  I think it was because of the compass warning that it is not wrking but am trying to think of other possibilities.  
Be sure to set your RTH height as well, I notice you dont have yours set .  Make sure it is above any obstructiion in your area and just a bit higher than that , you dont want to waste altitude on a low battery situation .  

I tell you it is very strange , I tried to duplicate the problem  and cant .  The other starge part is some of the settings are at "0" like RTH, I think the min default  is 20.  It is almost like the Go app is not connected  to the RC or the RC is OFF but it must be on , you are getting video .
Also are you up to date on FW ?  or is this an Old Go app by any chance ?   This is bugging me that I cant  replicate and fix it ........
ANY IDEAS OUT THERE CREW !





donnie






2017-2-1
Use props
Ogilthorp
lvl.1

United States
Offline

Hey Donnie,

Thanks for looking into this.  I unfortunately cannot calibrate the compass because I can't get the craft out of P-GPS mode.  I read that you need to do that first, but every time I flip the switches between P-F-A it does absolutely nothing.  So I'm in a situation where I can't proceed.

I can't set the RTH height or any other value anywhere - they all do the same thing as when I flip to multiple flight mode.  The settings instantly disappear when I move away from that menu.

When I initially turned it on, it came up with a new pilot wizard type thing.  On the 4th slide it asks you to set RTH height of 30, 50, 100m - I chose 30 and hit save, but it doesn't do anything and after awhile it comes up with the error message attached :



Through the app I can see the camera, see that the GPS has 16 satellites, etc.  It looks normal, but settings aren't saving to the Inspire at all.   I have the latest version of the app and the latest firmware on the controller and aircraft.  I can't see the aircraft firmware version on the app probably because I can't see any other value.  It's all just blank.  I've also tried re-installing the app to no avail.

The only thing that may be worth mentioning is the fact that I pulled this out of storage from two years ago.  I have never flown it and during that two years, the craft was never plugged in.  I had to do some hacks to get the batteries operational, but got them working.  Not sure if the batteries would have anything to do with settings not saving on the craft.  I have new batteries coming in today to see if that has anything to do with it.

I have no idea
2017-2-1
Use props
Donnie Stugots
Captain
Flight distance : 3636782 ft
United States
Offline

Ogilthorp Posted at 2017-2-1 09:59
Hey Donnie,

Thanks for looking into this.  I unfortunately cannot calibrate the compass because I can't get the craft out of P-GPS mode.  I read that you need to do that first, but every time I flip the switches between P-F-A it does absolutely nothing.  So I'm in a situation where I can't proceed.

Ok so what firmware are you using ?  Can you go to the "About"page on the Go app and list them for me please ,( sample below ) , I have never seen that screen you have for the RTH settings .
Why did you have to modify the battery also ?  I dont understand that .  

More than likely you have VERY OLD  firmware on the AC & RC and  go app is not recognizing it .  


DO NOT UPDATE ANYTHING till we know what firmware you are on , then you will ALWAYS UPDATE THE AIRCRAFT FIRST  make sure you do not update the RC before doing the aircraft, I bet you are on version 1.2.0.14 on the aircraft , if so you must load 1.3 first then jump to 1.10.  the RC is going to be a tough one also , going to have to use a thumb drive to update it to version 1.3 then you will update via the go app to the latest version , but like I say , hang tight till we see what version you are on .  

donnie


about page 1.8.PNG
2017-2-1
Use props
Ogilthorp
lvl.1

United States
Offline

Screenshot of the about screen here.  Notice no aircraft firmware version showing.



App is the latest from the app store.

The batteries were completely dead when I took them out of storage.  See this thread on what I had to do : https://forum.dji.com/forum.php? ... id=83058&page=1
2017-2-1
Use props
Donnie Stugots
Captain
Flight distance : 3636782 ft
United States
Offline

Ogilthorp Posted at 2017-2-1 11:06
Screenshot of the about screen here.  Notice no aircraft firmware version showing.

[view_image]

You must have updated the RC transmitter  recently then correct ?  But did you update the Aircraft ?  

Can you currently even start the motors on the aircraft from the RC?
When you did the screenshot did you have the aircraft on??


2017-2-1
Use props
Donnie Stugots
Captain
Flight distance : 3636782 ft
United States
Offline

Ogilthorp Posted at 2017-2-1 11:06
Screenshot of the about screen here.  Notice no aircraft firmware version showing.

[view_image]

OK , got it Just re -read your post , You need to simply re link the RC and the AC and I think  you will be in business follow these directions below:
When you updated the aircraft to the LATEST version 1.10 did you look and make sure you had the SUCCESS on the SD card ?  If so , this should fix your challenge.

***After you do an update to the AC and Or RC you may loose connection between the RC transmitter and the aircraft .  Once you confirm that you have the proper updates on the AC and RC  go to the Remote contol Settings tab on the go app.  go to the bottom and in blue highlight it will say "Linking  Remote Controler".  Before you press that , make sure you can find the Red link button on ther aircraft , it is inside the Main fuselage behind the right top silver nose cone screw , may need a flashlight  to see it.  Once you find it have the AC and RC on and press link button on Go app  , you will then have 60  seconds to press the red button on the aircraft, press and hold that button in firmly for about 5 seconds, let go .  You should then have a success box on the go app.   

2017-2-1
Use props
Donnie Stugots
Captain
Flight distance : 3636782 ft
United States
Offline

Ogilthorp Posted at 2017-2-1 11:06
Screenshot of the about screen here.  Notice no aircraft firmware version showing.

[view_image]

I have another customer at work , I will check back  when I can  , I bet the AC and RC just need a linking , give it a go and let me know .

donnie
2017-2-1
Use props
Ogilthorp
lvl.1

United States
Offline

Hey bud - I updated the aircraft from 1.3 firmware to this new 1.10 firmware and it appears to be responding now!
2017-2-1
Use props
Donnie Stugots
Captain
Flight distance : 3636782 ft
United States
Offline

Ogilthorp Posted at 2017-2-1 12:09
Hey bud - I updated the aircraft from 1.3 firmware to this new 1.10 firmware and it appears to be responding now!

Alrighty then, I knew something weird was going on ,glad you have it up and running .

donnie
2017-2-2
Use props
Alan Jupp
lvl.1
Flight distance : 1055561 ft
Australia
Offline

Donnie, I just came across this post and I have a very similar issue I would welcome your input on.

Just recently I rolled back my firmware per advice from your namesake at   

Following that rollback I find I now have this self-same issue of settings not being saved.

After eventually (It took me many days and many attempts) rolling back the Aircraft and RC firmware from latest to:

Aircraft: v1.8.1.00
RC: v1.6.0

I got the following results this morning (16.12.17):

a) Significant RC range improvement (Got to approx 500m from RC but due to other issues below decided not to push my luck) and if it were not for the following I would have said its FIXED.

b) Aircraft, or so the iPad tells me, was not remembering settings (Even between screen changes):

     i) Set multi Flight Mode
    ii) Set RTH altitude
   iii) Set max altitude
   iv) No Advanced Setting/Sensors info showing
    v) No Advanced Setting/Smart RTH, Enable Vision Positioning, Automatic Landing Gear (Yet it actually went up & down automatically and via RC command)
   vi) Low Battery Warning setting not remembered
  vii) Gimbal mode not adjustable

Should DJI Go App have it's firmware rolled back also and if yes to what version?

The other Donnie recons there is something else at play here. I used Airdata UAV to check for various issues and can share Flight Reports if interested. The Airdata screen views do however appear to indicate that perhaps the RC-Aircraft connectivity isn't quite as good as I thought.
2017-12-16
Use props
Mark Guille
Captain
Flight distance : 2031818 ft
Guernsey
Offline

Alan Jupp Posted at 2017-12-16 21:03
Donnie, I just came across this post and I have a very similar issue I would welcome your input on.

Just recently I rolled back my firmware per advice from your namesake at https://youtu.be/GmX_MESi86o  

Hi Alan,
The best advice I could give you here would be to get all your FW up to date. YouTube Donnie talks a good talk but his "experiments" are not exactly scientific, he actually admit at one point in this video that he had come out from under his "metal structure" to perform the second part of his "test", the part where he wanted to prove he was getting better range. He was also performing the second part later in the day, temperature/humidity could easily have changed enough (during the time it took to roll back the FW on 3 I1 units) to make a difference. Had he flown 2 like units (no range extenders) at the same time, from the same place, one with V1.08 and the other with V1.10, THEN swapped FW on each I1 and repeated the test, I would be less sceptical. This guy does not seem to be looking for facts, but rather, to prove his own notions.
So for facts and the best advice, stick to our own Donnie (Stugots), forum member, Top Bloke and Apple shareholder.

Mark G.

2017-12-17
Use props
fansa84fe8a4
First Officer
Flight distance : 3 ft
United States
Offline

Alan Jupp Posted at 2017-12-16 21:03
Donnie, I just came across this post and I have a very similar issue I would welcome your input on.

Just recently I rolled back my firmware per advice from your namesake at https://youtu.be/GmX_MESi86o  

I suspect it might be GO 4.1.8 losing connectivity.  Your settings that are lost are similar to what is happening with my P4.  If I unplug and replug the Lightning cable, they come back once connection is made.  I've made screenshots in the Phantom forum where my Max. Alt. disappears and reappears in the Aircraft main menu.  I think GO 4.1.8 is really messed up, or Apple 11.2.1 is dropping the USB port, but still doesn't explain why the settings in GO disappear entirely, and some saved settings as well.
2017-12-17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules