Please select Into the mobile phone version | Continue to access the computer ver.
No image in Vision app
123Next >
33399 85 2015-2-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
victortch
lvl.3

United States
Offline


Video feed was working fine since I got the drone. Then I got black screen right after camera firmware update 1.3.0.g. It persisted on all devices, later I noticed I have USB cable connected to the Phantom and laptop, so I have disconnected it and power-cycled my Phantom and suddenly video feed came back on Galaxy tab and iPhone. Never happened again, but it was scary. I only have drone for a couple of days though, so I can not give you reliable input on reoccurrence of the issue. Also, when applying the FW update make sure you rename the file as instructed on the microSD ("firmware_plus.bin") and make sure after update it is renamed to "firmware_plus.bin.bak00" by the drone and then delete it.

I did have a momentary control signal loss at 100ft though. It seems when user trigger failsafe from S1 switch - it disconnects from drone on purpose to make it switch to RHT mode. Looks like it is designed this way.

My WiFi extender power LED does not go to "green" when fully charged (it did after first charge though). Looks like both red, green led are on so it looks orange or green depending at angle you look at it, but app shows 100%.
Did a test flight today over open park field - got as far as 250m away (afraid to fly too far w/o GPS tracker): WiFi signal - full strength. It was short flight though as it is very cold outside. As usual, I forgot to press video record, should make it a habbit.
2015-2-28
Use props
homer
lvl.3
Flight distance : 612457 ft
United States
Offline

Has anybody noticed the 8 pin connector is crooked on the camera assembly or is this just mine and my problem?
IMG5445.JPG
2015-3-2
Use props
victortch
lvl.3

United States
Offline

I think the cause of my video blackout was a result of keeping my Phantom turned on for way too long. I was studying it and it seems WiFi unit got overheated and shutoff video stream. It is possible the video chip inside WiFi unit may be a toast ...
2015-3-3
Use props
homer
lvl.3
Flight distance : 612457 ft
United States
Offline

victortch@gmail Posted at 2015-3-4 08:20
I think the cause of my video blackout was a result of keeping my Phantom turned on for way too long ...

I have read some post on video and heat issues. I would think a overheating problem a new product would only happen on a really hot day. Over time electronics will fail premature because of overheating and will keep getting worse. I supposed in a enclosed environment (Not outside and no airflow) with it powered up it for long period, it would get hot in the inside. I will be looking at options for cooling in the future. So far I have not actually operated mine with Live Video. Sent mine for repair today.  
2015-3-4
Use props
Naza-PA
lvl.3

United States
Offline

homer@paddocks. Posted at 2015-3-5 03:23
I have read some post on video and heat issues. I would think a overheating problem a new product  ...

Indeed, it is strange why it would blackout for about 10 mins and then starts working and keeps working like nothing happened in my case. I did not power it down for extended period of time, may be 30-60 secs max.
I think I have figured out the reason for my backpout. It seems you have to power cycle all components, WiFi extender, RC controller and the bird after any major component FW update. Second time I experienced it was after FW 3.08 downgrade. But after power cycling all of the components video feed was working fine.

2015-3-5
Use props
Gareth
lvl.2

Norway
Offline

Just got back from a six week holiday and have updated all the latest firmware. Same old problem


From: Gareth
Sent: 18 February 2015 22:07
To: 'us.support@dji.com'
Subject: Vision app - no image feed

Hi, I have just got a Phantom 2 Vision+ and am experimenting with it (in the kitchen without the propellers on).  The Vision app is communicating with the camera. I can tilt the camera up and down. I can take pictures and video but there is no image showing in the Vision app just a black screen (I cannot see what I am photographing or filming in the Vision app). Under settings I have tried each of the preview quality settings without any success. The back lights on the drone show flashing yellow. What am I doing wrong? Cheers Gareth
2015-4-17
Use props
homer
lvl.3
Flight distance : 612457 ft
United States
Offline

Gareth,

I thought you had sent yours off for repair.
2015-4-17
Use props
Gareth
lvl.2

Norway
Offline

No thought I would wait and see if a solution showed up
2015-4-17
Use props
jhall
lvl.1

United States
Offline

Gareth Posted at 2015-4-18 03:03
No thought I would wait and see if a solution showed up

Gareth -- I am having the EXACT same issue with my DJI PV app.  No picture.  I have all the other data, battery, satellites, etc.  It will even take pictures and video with no problem - Just I cant see what Im taking on the app.!  

Let me know if you've found any fixes yet!!  Mine is also Up To Date on all firmware, apps, etc.
This just started not long ago for me.  
thanks!
JWH
2015-7-22
Use props
KickerM
New

United States
Offline

Howdy All, I am having the same problem as Gareth and now Jhall, Please let me know of your solution to this problem? I tried rebinding the camera and I get "ERROR DJI Vision was explicitly denied access to the camera." I have done no such thing infact its not even in my settings list on my iphone6?
2015-7-22
Use props
R18 drone
lvl.1

Brazil
Offline

I'm also having the same problem that Gareth , Jhall and KickerM , after I did the app update 09-09-2015. This is the image that appears on my phone, i made a flying days before making the update and everything was ok!!! I'm sure that it´s a problem in the app. The DJI must make the app correction.
2015-9-12
Use props
Barney Rubbel
Captain
United States
Offline

Has anyone tried using a 3rd party app like Autopilot, or I am sure there are others. I would think that if the problem is in the Vision App, it should work fine in a 3rd party app. If it is in the firmware or hardware, it will have the same problem in a 3rd party app. Just a thought.

Barney
2015-9-12
Use props
roy
First Officer

United States
Offline

No video a member found this.
"One of the flat cables from the camera gimble ends up in a pcb connector at the wifi box (the metal box on the motherboard), I guess this connector was oxidized or something, because right after I wiggled this cable a little at the connector (I actually tried to disconnect it) the preview started working again. It did not stop working when i wiggled it again, so I assembled the drone and took it for a test flight, works without any problems."
http://www.phantompilots.com/attachments/previewfix-png.27680/
After all you have done if this doesn't fix it you probably have a bad wifi module. New one is around $165 on eBay if yours is under warranty that may be the route to go. Get a magnifying glass and double check the ribbon cable on the camera. Look for scrapes and tears. Only two items that normally stop video. Good luck!
2015-9-14
Use props
R18 drone
lvl.1

Brazil
Offline

Hi Gareth

Phantompilots the forum are reporting the same problem in updating the Vision App.
The solution is to restore the old version through backup in iTunes.
I will try to restore the old App to see if the screen returns to display images.

http://www.phantompilots.com/thr ... n-1-0-52-ios.53597/
2015-9-14
Use props
R18 drone
lvl.1

Brazil
Offline

Hi friends,

I found that the problem is the new version of Vision App (V. 1.0.52) because I got a iphone with the old Vision App (V. 1.0.48) and visualized the images smoothly. So the range extender, the control and the Phantom are running smoothly.
It is now expected that the Dji fix the bug in the new Vision App (V. 1.0.52) or install the old Vision App (V. 1.0.48).
2015-9-15
Use props
R18 drone
lvl.1

Brazil
Offline

Hi friends,  Yesterday after Apple released IOS 9, the Dji Vision App version 1.0.52 again function normally.  Blunder of Dji have released the new version a week before the new IOS, and what's more disappointed because Dji not replied to my questions.
2015-9-17
Use props
motia
lvl.4
Flight distance : 2894 ft
United States
Offline

Updating to IOS 9 didn't help me. I wonder, if it has something to do with the IOS privacy settings. Did you set any special privacy setting during the IOS update process or did you leave everything as default?
2015-9-17
Use props
MikeDrone7
lvl.2

United States
Offline

I have an iPhone 6 with the latest IOS but was only having a problem with ground station with the 1.0.52 app (camera view was fine). I spoke to DJI support on 9/25 and was told that they are working on a fix and either a patch or a new version of the app will be available soon. Not sure what DJI considers soon though!

However on a good note I was able to find version 1.0.48 of the App in my iTunes library.  It had the icon for the Vision App with a diagonal red stripe that said update across it.  When I right clicked on it and selected info it said it was version 1.0.48.  So I deleted the crap App, plugged my iPhone 6 into my laptop, selected the App and clicked install then sync.  Tada I now have the old App back on my iPhone.  Also gave it a quick try and everything is back to normal with the ground station/waypoints etc.  I did however have to re-cache google maps.  But I wasn't so lucky on my iPad Air as I had synced it not long ago and the newer version was all that showed up.

Good luck to all that are having problems with version 1.0.52.  I hope that DJI makes good on their promise for a fix in the near future!
2015-9-28
Use props
fernando.marinh
New

Brazil
Offline

Hello everyone,

Does anyone have any news?

Any solution to the problem of the live image in the app ?
2015-10-20
Use props
jackpresley
lvl.1

United States
Offline

I have the same problem as Gareth. Happened after app update.

Frustrating as everything was working just fine. I've updated camera firmware, and everything else. Flies great, takes great vids/photos -- just no live feed.
2015-11-1
Use props
roy
First Officer

United States
Offline

Video feed trouble shooting
Please try the following steps:
•        Ensure you have upgraded all DJI products to their latest firmware. Check updated, plus the camera firmware
•        Ensure you are connected to the wifi phantom-xxxx SID
.        Check bluetooth be sure it is off
•        Ensure your phone has been updated to the latest software.
•        Ensure you have closed all other multi-tasking applications.
•        Check the free space on your mobile device, it is recommend having at least 3GB available, less storage could be causing an issue.
•        Try deleting the app from your phone and downloading it again.
           Try reformatting the SD card with  full format.
•        Reduce the preview framerate from 30 fps to 15 fps in the Settings of the DJI Vision app.
Check your wifi battery level.
Check the three leads going to the gimbal to be sure they are tight. Check each one closely for any pins that may have pulled up and loose.
If the above don't get it then the only remaining check is the video feed plug on the wifi transmitter under the shell.
If that's ok then it's most likely a damaged or burnt out wifi transmitter if you still see the SID.
If that does not fix the issue and you have an android tablet try wwwflylitchi.com  app and see if all works in that app if you have the same issue it has to be the wifi Tx in the Phantom. Anyone willing to try and report back.
2015-11-3
Use props
R18 drone
lvl.1

Brazil
Offline

Hi friends,

Since the update iOS 9.1 that APP Dji Vision has a problem, because even with the last update on 11.12.2015 V. 1.0.54, can not I see the images on my iPhone6 screen. The screen goes black with a spinning wheel in the center, but can perform all operations (fly, shoot and shoot) with my Phantom 2 Vision + V. 3.0
It's disappointing because I'm flying blind to 2 months. The Dji must correct and launch new version of the APP as soon as possible, as there are several reports of people who are having the same problem.
It is problem of aircraft, as tested with an android phone and it worked perfectly.

Roberto Azevedo.
2015-11-17
Use props
motia
lvl.4
Flight distance : 2894 ft
United States
Offline

Same problem here.
2015-11-17
Use props
steele
New

United States
Offline

SO maddening.

I am now having the same issue.

All data on my phone, gps, elevation, distance, etc. Even the map and location are good, just no video.

I can tap record on my iphone and the app says it is recording, no video will display. But... I can offload the video and see that the camera is recording fine. Just no video feed.

All devices are completely up to date.

Would love a solution!
2015-11-18
Use props
daniel.hellstra
New

Sweden
Offline

Same here, no picture from cam in vision app, but if I restart app and quad I can usually get it working again. Feels like the app could use some debugging. This is on android, samsung s5
2015-11-30
Use props
kevin
New

United States
Offline

Has this been resolved yet?  I'm still flying blind over here!

Just picked up a v2+ with VRPT581 controller(no batteries). Using a Galaxy S5 phone with DJI Vision App.  Currently getting no video feed but all other items are functioning properly.  The video worked then it didn't, then worked twice, then it didn't and now nothing.  That lead me to the forum here and over the last week I've tried all of the previous posts with no luck.  

Seems like if it was an app it would have never worked.  Is this an internal wire problem?  Did the fix "Jason in TN Comment #39" did fix the image?

I will be starting a ticket on this as I cannot find an actual fix anywhere online.  Hopefully return this v2+ and get a 3 if the problem continues.

2016-1-17
Use props
DJI-Patrick
Captain

Hong Kong
Offline

kevin@blockrise Posted at 2016-1-18 08:34
Has this been resolved yet?  I'm still flying blind over here!

Just picked up a v2+ with VRPT581 co ...

Hi , Kevin . Can you take photos and videos blindly ? If you do , please contact your dealer or support center about that . That'll need a repair .
2016-1-17
Use props
BLOCK
New

United States
Offline

DJI-Patrick Posted at 2016-1-17 22:48
Hi , Kevin . Can you take photos and videos blindly ? If you do , please contact your dealer or su ...

Yes photo & videos blindly.

What type of repair?  Is it on the aircraft or controller?
2016-1-18
Use props
DJI-Patrick
Captain

Hong Kong
Offline

BLOCK Posted at 2016-1-19 03:50
Yes photo & videos blindly.

What type of repair?  Is it on the aircraft or controller?

It's on the aircraft . Please kindly contact US support center about that .
2016-1-18
Use props
roy
First Officer

United States
Offline

Video feed trouble shooting
Please try the following steps:
•        Ensure you have upgraded all DJI products to their latest firmware. Check updated, plus the camera firmware
•        Ensure you are connected to the wifi phantom-xxxx SID
.        Check bluetooth be sure it is off
•        Ensure your phone has been updated to the latest software.
•        Ensure you have closed all other multi-tasking applications.
•        Check the free space on your mobile device, it is recommend having at least 3GB available, less storage could be causing an issue.
•        Try deleting the app from your phone and downloading it again.
           Try reformatting the SD card with  full format.
•        Reduce the preview framerate from 30 fps to 15 fps in the Settings of the DJI Vision app.
Check your wifi battery level.
Check the three leads going to the gimbal to be sure they are tight. Check each one closely for any pins that may have pulled up and loose.
If the above don't get it then the only remaining check is the video feed plug on the wifi transmitter under the shell.
If that's ok then it's most likely a damaged or burnt out wifi transmitter if you still see the SID.
2016-1-19
Use props
jjk_fl
lvl.1

United States
Offline

Hey everyone.  I am not a brain surgeon but after having the same No Video on the phone problem shortly after my Vision 2+ was new, and having to send it back, waiting at least 6 weeks, I decided this time I am getting to the bottom of the problem myself.  Its not under warranty so I might as well figure out what is going on by process of elimination.  DJI does not seem to help identify what worked for me, or want to stand behind their product any longer than necessary.  

I have the Vision 2+ and have always used a Galaxy 5S.  I was having good results from the craft, video and photo, and put it away for about 3 to 4 weeks.  When I tried using again, no video on the Galaxy 5.  Just a black screen.  I went through all the checks everyone recommends, however more important, read what everyone has been writing for a long time.  My problem was no different than theirs so why should I just copy their frustration?  I also wondered why you would need to change any settings if the results were great when put away.  That made no sense and just a cop out for why the screen was black.  Something had failed.

Although it still did not make sense why it worked when put away, but did not when activated the next time, it came down to replacing the WIFI module.  The information was not getting to the phone.  The range extender was working, I could take videos and photos, yet something had failed in the transmission.  I took the advise of another owner and contacted Dronesplus.com and purchased another WIFI module.  They are not cheap but the Vision is worthless not working.  I have to say, Dronesplus was great about shipping the part right away and I received it within 3 or 4 days even though I am across the country.  I have to say they were great to deal with.

After replacement, follow you tube videos, its working great!  I have flown it only a few times but its working great.  For me, the module was the problem.  Nobody wants to break down and spend nearly $200 for a part but for me, it made sense that was the problem.  Also, when the Vision was sent to the factory under warranty for the same problem, I could tell that is what they replaced.  I won't say it will take care of everyone but if a couple people try and have the same results, I think we have figured out what the factory will not tell us.  

One more comment.  Heat and electronics do not get along.  I recommend not running the drone any longer than necessary without flight.  Take off as soon as possible and shut down as soon as possible.  The airflow produced by the blades helps to cool the metal casing under the dome.  When downloading photos and videos, remove the micro SD card.  Don't use the cable and power the drone.  Any sitting time causes heat that is not doing any good.

I hope this helps someone else.  I hate to see anyone spend good cash replacing parts but you have spent good cash top buy a craft that does not work.  I hope the Vision 3 has this problem resolved.  I just ordered one!  Wish me luck.

2016-1-26
Use props
houzful
lvl.1

United States
Offline

DJI confirms WiFi module is bad.

DJI Confirms WiFi module bad.

DJI Confirms WiFi module bad.
2016-1-27
Use props
pasohaze
lvl.1
United States
Offline

I have the exact same problem. The drone worked great last week, then yesterday when I was starting it up and clicked on the camera icon, just a black screen and no data from the drone. The remote will fly the drone, I can control the camera with the thumbwheel, just nothing else. No crashes, the drone is always handled with care, batteries are fully charged, software on drone and phone is good. It worked a few days ago, with no change, today its down. I cant seem to find out what's going on.
2016-2-22
Use props
digod2
New

Brazil
Offline

Any news?

I'm also having the same problem to 4 days.
I'm doing research on the internet but no one had a solution yet.

Someone managed to solve this problem?

2016-11-3
Use props
plumbfreeordie
lvl.2

United States
Offline

I started a facebook page for people with this problem.  It is my hope to gather them together so we can make an organized noise about this BS.  I started a petition, there is a link at the page.

https://www.facebook.com/DJIstinks/
2016-11-4
Use props
crash1sttime
First Officer
Flight distance : 1047503 ft
United Kingdom
Offline

If its a new unit that doesnt work, and you paid on a credit card, take it up with the card issuer, they may help you get your money back, loss of FPV on a new unit shouldnt happen but then DJI do ship bad units on occasion
2016-11-4
Use props
Visual Air
Captain
Flight distance : 355154 ft
  • >>>
Canada
Offline

Gareth Posted at 2015-2-22 02:18
Just the video feed missing

Same thing happened to mine and a few hundred dollars later DJI replaced the wifi module in the aircraft etc.

I bet its the exact same thing. It worked perfectly one day then no video until i sent it in and they fixed it.
2016-11-11
Use props
P.I.C. Aerial
lvl.2

United States
Offline

Though it in the freezer for a hour or two and then try it chances are it will work until warm again. DJI should have replaced all the video transmitters in these for free the are lemons.
2017-2-22
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

This is an old thread.  Regardless, the P2P+ is still a blast to fly.  

Yeah the burnt out FPV transmitter due to overheating is a known problem.  DJI could have done a better job with that.  I know some guys have installed a tiny fan in there to keep it cool.  Another idea is to turn down the dBi within the AC's FPV transmitter and then add an amp to the controller.  Try not to fly on really hot days.  Do what you can to solve the problem in advance because it's expensive to fix.  
2017-2-23
Use props
fans1d990681
lvl.3
Flight distance : 612457 ft
United States
Offline

Hum, I was looking for some old post I had made, anyways, If you haven't been to http://www.phantompilots.com/ check it out.
This is now an edit, the post is shows the correct Avitar but the name should be "Homer" and I'm seeing "fans1d990681"

On the web sight that works for me it is RodPad

Rod

2017-3-26
Use props
123Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules