Please select Into the mobile phone version | Continue to access the computer ver.
App Not Connected
835 25 2017-2-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

it's been a month since i last flew either my Mavic or Inspire 1 Raw,
on attempting to turn on both of my craft i have discovered that niether of them will connect to the app..

I am able to enter the control screen and all the RC controls seem to be linked and working but there is no video transmission from either craft.

In the time since i was last able to connect there has been an app update for ios DJI Go and DJI Go 4. iOs itself has alos updated in that period.

I am using an iPhone 6S Plus with the latest version of iOs at this time and latest firmware on both craft as checked through the DJI Assistant 2 on PC.

What am i supposed to do to adress this? Any help would be much appreciated!

Cheers
2017-2-11
Use props
rerun
lvl.1
United States
Offline

Did you check your cable? I had that problem and turned out it was a crappy cable.
2017-2-11
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

rerun Posted at 2017-2-11 17:36
Did you check your cable? I had that problem and turned out it was a crappy cable.

Tried several cables on the inspire with no difference. The Mavic is using the standard short built in usb-Lightning.

Seems strange that the same is happening for both craft using thier respective apps. Inspire on DJI Go and Mavic on DJI Go 4.

UPDATE. I got a connection on the Inspire1 But only once. restarting and trying several times thereafter resulted in the same lack of connection..

This is really strange and all signs point to either a fault in the iPhone hardware or software..
2017-2-11
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Droney McDronef Posted at 2017-2-11 17:57
Tried several cables on the inspire with no difference. The Mavic is using the standard short built in usb-Lightning.

Seems strange that the same is happening for both craft using thier respective apps. Inspire on DJI Go and Mavic on DJI Go 4.

Just tried my iPad with both devices on the previous version of both apps and same version of iOS (10.2.1)

Both craft connected perfectly..

Will update the apps on the iPad now and see if it breaks..
2017-2-11
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Droney McDronef Posted at 2017-2-11 18:07
Just tried my iPad with both devices on the previous version of both apps and same version of iOS (10.2.1)

Both craft connected perfectly..

Updated and all still works on iPad but not on the iPhone..

It could be that the lightning port on my phone is faulty but it does seem to operate correctly in mounting the phone to Mac or PC for sync etc..

Not sure where to go from here..

Suggestions?
2017-2-11
Use props
dronist
Captain
  • >>>
United States
Offline

Droney McDronef Posted at 2017-2-11 19:53
Updated and all still works on iPad but not on the iPhone..

It could be that the lightning port on my phone is faulty but it does seem to operate correctly in mounting the phone to Mac or PC for sync etc..

Did you delete and reinstall the app? If you did it the phone. I use the same phone with no problem. it might be the data part of the cable and not the charging part.
2017-2-11
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

dronist Posted at 2017-2-11 20:17
Did you delete and reinstall the app? If you did it the phone. I use the same phone with no problem. it might be the data part of the cable and not the charging part.

Thanks, Yeah i deleted both and reinstalled with no difference.
It's strange because I've managed to get the Inspire to connect a couple of times by plugging the lightning cable in after entering the flight control screen..

The Mavic i can't get to connect at all.

I thought maybe it might be the data pins of the port that are dead also.. but like i said, I've done a sync of the phone through iTunes which worked fine.

I did go snowboarding for a few days with my phone in my pocket last week and it's possible some moisture found it's way into the lighting port..
2017-2-12
Use props
dronist
Captain
  • >>>
United States
Offline

Droney McDronef Posted at 2017-2-12 00:32
Thanks, Yeah i deleted both and reinstalled with no difference.
It's strange because I've managed to get the Inspire to connect a couple of times by plugging the lightning cable in after entering the flight control screen..

I'll do the "RICE DIP" for few hours and see
2017-2-12
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Well i fixed it., Sort of..

As a last resort to find out if it was faulty hardware or not, i went though the process of doing a factory reset of my iPhone.

Doing a basic setting restore had no effect, But a full factory reset by deleting all apps and data and hey presto! Connects perfectly on the first try!

Setting up my phone from scratch is not ideal and i wonder what kind of mess the DJI apps had gotten themselves into that even uninstalling them would not fix the issue..?
I'm guessing that restoring my phone from backup will likely reintroduce the same connection issues though so i guess this is probably the only fix for now..
Anyone know the best way to get DJI to look at this so it might be avoided in the future?
2017-2-12
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Seems i may have jumped the gun

The inspire seems to connect reliably now but still no connection to the Mavic in either djiGo or djiGo v4..

tried different brand new lightning cables etc.

This is hugely frustrating.. A whole day wasted trying to get this damn thing to connect.
2017-2-12
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

I read somewhere a recommendation to avoid having both DJI GO 3 and DJI Go 4 on the same device, but am pretty sure this was an Android thread. Anyway, fwiw, you might try deleting the older version, restarting your phone, and seeing if it consistently connects. Good luck, that's got to be super-frustrating.
2017-2-12
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Ex Machina Posted at 2017-2-12 20:35
I read somewhere a recommendation to avoid having both DJI GO 3 and DJI Go 4 on the same device, but am pretty sure this was an Android thread. Anyway, fwiw, you might try deleting the older version, restarting your phone, and seeing if it consistently connects. Good luck, that's got to be super-frustrating.

Cheers, Yeah that was the first thing i tried. been running both apps for months with no trouble until now.

It just makes no sense as the 6S connects fine with the Inspire 1.

Just tried an old iPhone 5 with the Mavic and it connects fine.. So there's something that the Mavic doesn't like about my 6S..
2017-2-12
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

Droney McDronef Posted at 2017-2-12 22:07
Cheers, Yeah that was the first thing i tried. been running both apps for months with no trouble until now.

It just makes no sense as the 6S connects fine with the Inspire 1.

You say after doing a factory restore on the 6s it did work with the Mavic for a while?
2017-2-13
Use props
dbgrn
lvl.3
Flight distance : 661791 ft
United Kingdom
Offline

I have a similar, but not identical issue, with the DJI Go 4 app on my iPhone 7 Plus.

All worked fine when I last used my Mavic about a week ago, but went to fly it today and shortly after take-off it lost the video feed completely. Only way to get it back was to kill the app and restart, but the video feed only returns intermittently when doing that (i.e. Sometimes the video feed remains blank, and sometimes it returns briefly).

Only change I made was to upgrade the DJI Go 4 app to 4.0.3 a few days ago.

I see there's now 4.0.4 available on the App Store (seems very quick since the last app update), but want to know if there's a known issue before updating the app again so soon.
2017-2-13
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

dbgrn Posted at 2017-2-13 10:16
I have a similar, but not identical issue, with the DJI Go 4 app on my iPhone 7 Plus.

All worked fine when I last used my Mavic about a week ago, but went to fly it today and shortly after take-off it lost the video feed completely. Only way to get it back was to kill the app and restart, but the video feed only returns intermittently when doing that (i.e. Sometimes the video feed remains blank, and sometimes it returns briefly).

This is a seperate issue. what i am experiencing is a failure of connection between the phone an the RC.. Not a video signal loss. My issue is that i can't get any control over the aircraft via Phone because the RC isn't recognising there is even a phone plugged in.

I've noticed on several other threads that many people are suffering intermittent signal loss during flight etc. I haven't experienced this myself but it seems like a real problem.
2017-2-13
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Ex Machina Posted at 2017-2-13 07:11
You say after doing a factory restore on the 6s it did work with the Mavic for a while?

The reset of my phone did nothing to help the Mavic.. But seemed to fix my connection issues with my Inspire 1. Got over excited just to see one of them working again before fully testing..
2017-2-13
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

Droney McDronef Posted at 2017-2-13 14:27
The reset of my phone did nothing to help the Mavic.. But seemed to fix my connection issues with my Inspire 1. Got over excited just to see one of them working again before fully testing..

Have you looked at your phone's lightening connector? Maybe you've got some lint or something that's causing intermittent contact failure? We just had to blow some dust out of a laptop's card slot to get it to mount my Mavic's MicroSD. Seems unlikely to be a problem with your RC if your iPad and iPhone 5 can consistently connect.
2017-2-13
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Ex Machina Posted at 2017-2-13 14:33
Have you looked at your phone's lightening connector? Maybe you've got some lint or something that's causing intermittent contact failure? We just had to blow some dust out of a laptop's card slot to get it to mount my Mavic's MicroSD. Seems unlikely to be a problem with your RC if your iPad and iPhone 5 can consistently connect.

Yep. cleaned and re cleaned.. also works fine for use with Inspire and syncing with itunes to transfer phone backups etc. The port can't be the issue or those wouldn't work.

It has to be either the RC firmware or the App having an issue with my specific phone..
2017-2-13
Use props
Brian B Henri
lvl.1
Flight distance : 241644 ft
Germany
Offline

I am also reporting the same issue with my Mavic and my iPhone 6s Plus. Same scenario. RC signal is fine between the aircraft and controller and I can land it. Although one time, it was too far away to control via naked eye and had to use RTH button as I had no video feedback. Sometimes disconnecting the cable (from the controller) and the plugging it back in helps--hardly though. I've also reset my phone and it seems to have helped a little, but it is totally unreliable with my iPhone 6S Plus.

I've installed DJI go on all my team members phone so I can ask to borrow theirs in a bind. Quite frustrating.

I have even cleaned the lightning connector in my phone thinking the connection was not good. But that doesn't seem to be the problem. It's something with the phone the software doesn't like.

Any ideas?
2017-2-13
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

Droney McDronef Posted at 2017-2-13 14:48
Yep. cleaned and re cleaned.. also works fine for use with Inspire and syncing with itunes to transfer phone backups etc. The port can't be the issue or those wouldn't work.

It has to be either the RC firmware or the App having an issue with my specific phone..

I doubt iTunes uses all the pins on that connector, but it is surprising that it works consistently with the Inspire. Is anyone else on the forum complaining about iPhone 6S connectivity? Also and FYI, saw a new version of the iOS Go 4 app was just released -- give it a go yet?
2017-2-13
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Ex Machina Posted at 2017-2-13 15:05
I doubt iTunes uses all the pins on that connector, but it is surprising that it works consistently with the Inspire. Is anyone else on the forum complaining about iPhone 6S connectivity? Also and FYI, saw a new version of the iOS Go 4 app was just released -- give it a go yet?

Just tried and no difference.
Also rolling my phone back to my previous backup has killed my connection to the Inspire. I'd really like to try rolling back my iOs to 10.2 but it is no longer signed by Apple.. That's the only other thing that's changed since it all last worked but i am unable to roll back to verify if it is the cause.
2017-2-13
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

Droney McDronef Posted at 2017-2-13 16:05
Just tried and no difference.
Also rolling my phone back to my previous backup has killed my connection to the Inspire. I'd really like to try rolling back my iOs to 10.2 but it is no longer signed by Apple.. That's the only other thing that's changed since it all last worked but i am unable to roll back to verify if it is the cause.

Ok, that suggests there's an app or something that's interfering with your 6s' connection. Do you have any weird networking, security or developer-level port probing tools installed on your 6s that's not on your iPad or iPhone 5?
2017-2-13
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Ex Machina Posted at 2017-2-13 16:29
Ok, that suggests there's an app or something that's interfering with your 6s' connection. Do you have any weird networking, security or developer-level port probing tools installed on your 6s that's not on your iPad or iPhone 5?

Yeah possibly.. Would have though that the iPhone factory reset and running in flight mode would have ruled out any such interference..?
2017-2-13
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

Droney McDronef Posted at 2017-2-13 16:36
Yeah possibly.. Would have though that the iPhone factory reset and running in flight mode would have ruled out any such interference..?

Except if you restored from your backup you've possibly reintroduced the problematic apps or configuration. Sometimes stuff gets corrupted in subtle ways that are hard to diagnose.

If you do another factory restore and the Inspire again connects, then you might want to consider manually reloading your apps, a few at a time, interspersed with testing the connection with your Inspire, until either it breaks again or you've successfully reloaded all your apps and data. I'd re-download the apps from the app store instead of copying them over from iTunes.

Anyway, that's about all I got. It's a lot of work for a phone that's apparently still not going to work with your Mavic, though. Has anyone else been complaining about the iPhone 6S?

I guess the Apple Store Genius Bar people have hardware diagnostic tools they could run on your phone if you live close to one and want to give that a try.
2017-2-13
Use props
Droney McDronef
lvl.3
Flight distance : 31539 ft
  • >>>
New Zealand
Offline

Ex Machina Posted at 2017-2-13 17:40
Except if you restored from your backup you've possibly reintroduced the problematic apps or configuration. Sometimes stuff gets corrupted in subtle ways that are hard to diagnose.

If you do another factory restore and the Inspire again connects, then you might want to consider manually reloading your apps, a few at a time, interspersed with testing the connection with your Inspire, until either it breaks again or you've successfully reloaded all your apps and data. I'd re-download the apps from the app store instead of copying them over from iTunes.

Yep impossible to diagnose so instead of hoping and waiting for a magic update i went out and grabbed a new 7Plus. works fine. Fingers crossed it stays that way.
Shame, Was kinda on the fence over upgrading but was really happy with my 6SPlus.. Oh well, guess i can try and pass it on to someone who will never use it with a dji drone..
Should also mention that i have done a backup restore from my old phone to the new one which connects just fine.. either it was a 6S specific software issue or it really was a hardware issue with the lightning port.. maybe there's a secret damaged pin that only DJI use for the mavic.. Who knows.
2017-2-13
Use props
Ex Machina
Captain
Flight distance : 1784344 ft
United States
Offline

Droney McDronef Posted at 2017-2-13 20:34
Yep impossible to diagnose so instead of hoping and waiting for a magic update i went out and grabbed a new 7Plus. works fine. Fingers crossed it stays that way.
Shame, Was kinda on the fence over upgrading but was really happy with my 6SPlus.. Oh well, guess i can try and pass it on to someone who will never use it with a dji drone..
Should also mention that i have done a backup restore from my old phone to the new one which connects just fine.. either it was a 6S specific software issue or it really was a hardware issue with the lightning port.. maybe there's a secret damaged pin that only DJI use for the mavic.. Who knows.

Heh, that's one way to address a problem -- glad it's working for you!
2017-2-13
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules