Please select Into the mobile phone version | Continue to access the computer ver.
Sensor Calibration with DJI Assistant 2 Problem fixed.
5098 2 2017-3-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
Puttmaster
Second Officer
Flight distance : 18931532 ft
  • >>>
United States
Offline

I did not pay attention to if I was getting the "calibrate sensor" error before or after I did the latest FW update today 3-8-17 , so not sure what the cause was. That being said, I went to do the calibration and upgraded to the currect version of the DJI assistant. It installed fine, but when going to do the calibration I kept getting the "please restart aircraft" message and the calibration button was greyed out. It would not let me go on. This has to do with one of the drivers not being installed correctly during the intital installation.
If you are experiencing this, this is what I did to get it to work on Windows 7.  This should also work on Windows 10 as well.

1. Go into Windows device manager. I get there from the start menu by doing a right click on computer, then properties, then click device manager.
2. Turn your aircraft on with the USB plugged into the side of it (DO NOT plug into your computer yet.)
3. Make sure the device manager window is visible.
4. Plug the other end of the USB cable into your laptop or computer while watching the device manager window. You will see a new device pop up that is your Mavic. It does not say Mavic, but something else.
5. Click the side arrow to expand it down and you will not see the actual device of the driver you need to update.
6. Right click on that device and choose "Update Driver Software"

7. Choose "Browse my computer for driver software"
8. Enter in the following location "C:\Program Files (x86)\DJI Product\DJI Assistant 2"
9. Click Next

That is all it took me to get this going after a couple of hours of reinstalling the software, downgrading firmware, upgrading firmware, etc.
This whole process takes about 15 seconds. After that the calibration went perfectly and I was able to click "Continue" and it not being greyed out.
I am not sure of the problem of why the driver did not install properly, but I believe it was because it was not a signed driver, or not from a trusted source and my computer settings did not like it. No matter, something went wrong and there is no reason to downgrade firmware or do all the other tricks that are suggested.
Hope this helps someone else. I have seen this all over the place lately.

2017-3-8
Use props
MavicT
New

United States
Offline

Thank you for posting your solution. Unfortunately it doesn't work for my Windows 7 64 bit PC. I tried the solutions that have been posted here. 1.disabling the driver signature requirement 2. updating the driver as per your directions. I still get the error message to "reboot the aircraft" and as a result, I cannot calibrate the Mavic. Very frustrating their software has so many bugs. Any thoughts?
2017-3-18
Use props
WynandKruger
lvl.2
Flight distance : 871739 ft
South Africa
Offline

Did you ever manage with a solution? I am having tbe same problem, also tried all the driver tricks, but still asks me to reboot aircraft.
2018-4-9
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules