Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go 4 (forced update)
791 4 2017-3-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
fans8bd2b97c
lvl.1
Flight distance : 264541 ft
United Kingdom
Offline




This update is a total disgrace.  One day my P4 was working great as it has been for the past nine months and as soon as this 'update' was applied my signal is unusable.  Video a disaster.

I have a Nexus 7 tab which is on the approved list, so play the ball and not the man DJI!!!

Not even a year old and its been bricked by ts own maker..........

Please sort asap!!!!!!
2017-3-13
Use props
hungdang
Second Officer
Flight distance : 4831962 ft
  • >>>
Australia
Offline

Downgrade your rc back to 1.6, it should solve your problem
2017-3-13
Use props
fansa84fe8a4
First Officer
Flight distance : 3 ft
United States
Offline

Yes, roll back to 1.60.  I had to as 1.80 was breaking up video on an iPad Ai2 2 which never broke up prior.  Even on the rollback, it might break up 1% of the time.  Now I ignore the warning to update if it is working right.

Why 1.80 is still out there with issues is odd.

Something going on with the 3rd party apps like Litchi and Autopilot both as well, but don't know if it is firmware or 1.80 related yet still seems unfixed.  Other Inspire 2 forum had a Nexus recommended screen crash and guy almost lost it.

2017-3-13
Use props
fans8bd2b97c
lvl.1
Flight distance : 264541 ft
United Kingdom
Offline

Issue is still there with 1.6
2017-3-14
Use props
fans8bd2b97c
lvl.1
Flight distance : 264541 ft
United Kingdom
Offline

This is still broken.  Any comment from DJI rather than the punters?  No, thought not.  Well called DJI, ace support.  Not.
2017-4-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules