Please select Into the mobile phone version | Continue to access the computer ver.
Connection issue with andriod device
524 2 2017-3-26
Uploading and Loding Picture ...(0/1)
o(^-^)o
tomato
lvl.3
Flight distance : 328 ft
  • >>>
Australia
Offline

Just started using a Huwaei Mediapad x2 with the DJI Go 4 App. The first time installed the app everything worked fine.

Now every time I connect my RC controller to the device it won't connect. I connect the USB cable and nothing happens (besides background going black), I then open the DJI Go 4 app and very quickly it pops up a message about thisusb connection, however this message isn't on screen long enough to allow me to accept it.

Here is a video of the process. http://tinypic.com/r/x5sfwp/9

Any ideas?


2017-3-26
Use props
JanN_H
lvl.1
Germany
Offline

Try resetting "standard action" in Settings/Apps/DJI GO4 if there is one set. And try to set the USB-Mode to PTP in the popup, if it comes up.

Best regards
Jan
2017-3-30
Use props
Damacone
lvl.3
Flight distance : 358622 ft
United Kingdom
Offline

I had a similar problem with an Xperiz Z5 tablet.
So.. assuming it's not your cable, try this:

- Enable the 'developer menu' on your device
- Connect the controller to the device
- Go into the developer menu and look for the 'Select USB configuration' option
- Click this option and change it to any other option but 'charging'
- Change it back to 'MTP'
- Try going into the DJI Go4 app - you should be able to click 'Enter Device' now.

This fixed it for me - unfortunately I can't remember where I first saw this workaround to give credit.
2017-3-30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules