Please select Into the mobile phone version | Continue to access the computer ver.
Still haven't fixed my range issue after crash
744 11 2017-3-27
Uploading and Loding Picture ...(0/1)
o(^-^)o
randaljds
lvl.2
Flight distance : 148612 ft
Australia
Offline

Hi and thank you in advance for any tips.

Situation...
My fault, got to close to a branch and fell out of the sky! P3S still flies fine and every thing seems to be as per normal except the flight range possible. Prior to playing touch in the dust my quad was easy going 50+ mets in antsy direction and now I can only get 30 consistently before rth kicks in!

HELP!!!

I have had it in bits thinking a wire might have come of the board, and although ond did seem looser than the other they both went back on tightly. I put it back together without removing the board from the lower half of the casing and still no go...

Any advice would be most welcome, love the drone and I'm having width drawalls.  I would love to be able to fix the thing myself and learn something in the mean time. Where is the actual receiver located and can it be replaced or anything like that?
http://Randal@Randal.com.au
2017-3-27
Use props
Michgolden
First Officer
Flight distance : 822851 ft
United States
Offline

Just out of curiosity have you tried to recallibrate anything since the crash? These Phantoms are tough but sometimes the IMU etc can get knocked out of whack. Not sure if that would help but it's a place to start. Also did you happen to do any Firmware/App updates after the crash but before the next flight when the range suffered?  Just trying the old process of elimination.
2017-3-27
Use props
Gonesoft
lvl.1
Germany
Offline

Same problem here, also P3S - I was able to fly out more than 450m (over open field or water) before a crash and now it's down to about 60m. I'll try the hint of recalibrating and will post results.

If that doesn't help, I wanted to try and unplug the camera. Mine had suffered a broken gimbal arm (that I could repair) and I was wondering if somehow now it produces radio noise that interferes with the antennae, since it sits right between them. Anybody ever flown w/o camera? Does it even work or will the drone refuse to start?
2017-3-28
Use props
randaljds
lvl.2
Flight distance : 148612 ft
Australia
Offline

I did a controller and compas recalibration. Not sure about IMU. I'll look up how to do it and try. No updates to anything.
2017-3-28
Use props
Gonesoft
lvl.1
Germany
Offline

Don't have the time to try before the weekend. In the meantime, I contacted DJI support and they said, it could be that the two antennae got damaged in the crash even though there is no visible damage. I found a set for 15€ on eBay - if calibrating doesn't help, I'll install those and will report back here.
2017-3-29
Use props
Gonesoft
lvl.1
Germany
Offline

Got around to checking on it today: recalibrating IMU did not help. Re-pairing (which is called "setting the frequency") did not help. My symptom is, even when the drone sits still with engines off and I do not touch the controller when they're just a meter apart, once or twice a minute the signal quality suddenly drops from all bars to a red "signal low" warning or even to "signal lost", coming back to 100% after a few seconds. At least one time I also observed interference in the picture at the same time, so maybe there really is something causing radio noise from within the drone

I'm hoping to receive the new antennae tomorrow.
2017-3-30
Use props
RicardoGray
Captain
Flight distance : 4356421 ft
United States
Offline

Gonesoft Posted at 2017-3-30 08:37
Got around to checking on it today: recalibrating IMU did not help. Re-pairing (which is called "setting the frequency") did not help. My symptom is, even when the drone sits still with engines off and I do not touch the controller when they're just a meter apart, once or twice a minute the signal quality suddenly drops from all bars to a red "signal low" warning or even to "signal lost", coming back to 100% after a few seconds. At least one time I also observed interference in the picture at the same time, so maybe there really is something causing radio noise from within the drone

I'm hoping to receive the new antennae tomorrow.

Does your RC light also turn red? I was working on a standard for someone that had a light crash and broke off the gimbal. I had to new ribbon to try on it to see if the camera was functional, so that I didn't end up buy a new arm & such if the camera was bad. So I just laid everything out on the table and turned it on and all looked ok. so, I ordered the parts I needed and decided I would make sure the drone flew ok so I unhooked the camera and ribbon cable, tied up the rest of the unit under the drone, and powered it up. I got that signal on, signal off about every 15 seconds on the RC. I could start motors or anything. I hooked up the ribbon to the camera and all was good again. It must have been looking for some signal from the camera or something. May not be your answer, but what I am suggesting is maybe something has come loose or apart with your gimbal / camera.
2017-3-30
Use props
#shotxclvck
Second Officer
Flight distance : 3423297 ft
United States
Offline

i flew into a tree 100 ft up in the air my p3s just bounced off corrected itself and I brought her in for a landing then inspection- the standard is a beast- so underrarted
2017-3-30
Use props
Gonesoft
lvl.1
Germany
Offline

PROBLEM SEEMS SOLVED WITH NEW ANTENNAE

Thanks for the hints. I unplugged the camera and experienced the same as you - permanent low signal warning. I'm guessing that is the reaction of the system to a missing 2.4GHz signal, not actually something that kills the 5.8GHz.

Anyway, got my new antennae and it *appears* that my range is OK again. Could only test it over the residential area where the drone has to compete with dozens of radio transmitters (albeit 2.4, but still a lot of packet data noise). Here at home, it's pretty much back to how it was before the crash. Will test it over open field, away from houses when I get the chance. So far, I'm relieved.

I could not imagine that the antennae could take damage - after all, it's just two coax cables with tiny coils at the ends. But upon closer inspection, I see evidence that the port side legs got smashed into the lower body and were probably bent far enough to make a kink in the cable or to swage the tiny end under the coils - I'm not an HF expert, but I understand that if the length of this bit is off by even a fraction of a mm, that shifts away the resonant frequency, so maybe that's what was wrong.

Bottom line: if anybody else has range issues after a crash, you might want to have a look at your antennae. And please, share your experiences if it helps you, too. Oh, and be careful when installing the new antennae not to bend the coax cables too tightly - seems they're somewhat more fragile than expected.
2017-4-1
Use props
Michgolden
First Officer
Flight distance : 822851 ft
United States
Offline

Good to hear that it seems to be working now ! Nice to see that you aren't afraid to dig into it and figure it out. Also thanks for posting your results, will most likely help someone else.
2017-4-1
Use props
DJI-Thor
Administrator
Flight distance : 13602 ft
Offline

Glad to see it works out for you.
2017-4-1
Use props
randaljds
lvl.2
Flight distance : 148612 ft
Australia
Offline

Ok so it looks like I will replace the antennas on my drone as well and hopefully mine will be back to normal as well... where is the best place to get them from? I'm in oz
2017-4-3
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules