Please select Into the mobile phone version | Continue to access the computer ver.
HELP! X3 has no image
12Next >
2347 41 2017-5-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

ok so heres the run down picked up a inspire 1 (just the bird that had nothing else) that had slight damage (broken nose, and two landing actuators) fixed it and bought a X3 used that i was told worked before being sold. my 1st bird, x3, remote all up to current firmwares. now when i take my current x3 and put on either bird i get image. but when i take the newly purchased x3 and put on either bird i get a black screen with a grey bar at bottom of the app. this is present when attached to either bird? now the newly purchased x3 via the app says it at current firmware, i get full control of it via remote but yet no image shows?? any help is greatly appreciated
2017-5-6
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

oh also left out i can take pictures and view them when putting the SD card in my comp. but absolutly nothing shows when trying to view in the app
2017-5-6
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

Is this X3 color white or black? wondering if this was off the OSMO handle. as they will not work o the Inspire 1

Rich
2017-5-6
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

its white the x3 for the inspire 1
2017-5-6
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

TruGreen Posted at 2017-5-6 17:14
its white the x3 for the inspire 1

Sounds to me like there is a corrupted video module on the X3   that was used and just purchased .  You say that you can take pics with it but get no image is that correct ?  If so then more than likely the camera would need to be sent in for repair . ( You get no video image on BOTH OF THE AIRCRAFT YOU ATTACH THIS USED X3  TO CORRECT ,  THE CAMERA IS UP TO DATE AS WELL CORRECT, if so read on . )

OK, here we go ,  you say that the latest FW is loaded to this X3 that has the problems correct ?  if so what I would do is place the Current FW that is on that X3  ( you say it is the latest FW )  and AC and load it again to  the AC via this problem camera , now you are not actually updating but you are just getting data off the SD card , now since the X3 and AC are up to date  you will only wait a few minutes and you will have the data we need, now take the SD card and load it to the Computer and look at the Hidden file , If lines of code 0800 and 1500 say " Device Not Detected " then you will need to send this camera in for repair , now way around it .  If it does not say that , then you may have another problem , let us know , but my money is on this .
Below is a link on how to view the hidden file  if you dont know how, it is very simple .

How to View Hidden Files: Tool to  diagnose No signal and SD  Issues

donnie

Below is a sample of what a corrupted video module will look like on the Log of the SD card , the latest Firmware data  will be on the VERY BOTTOM OF THE LOG PAGE  so  look to that data  as the others will be from previoous updates  , notice lines 0800 and 1500 .  ***

Sadly on line  ( ebay and what not )  I see this problem all the time , the seller  corrupts the camera and then sell it and say , gee , worked for me .  It is not usually an expensive fix but you must send it in for the video board to be  wiped clean OR they replace the video  board depending on what is wrong with it .  The video module can be corrupted in many ways but the most common is leaving the RC transmitter on when updating the Aircraft with the latest firmware ( any version ) .  That is the most common reason I have found for the Video module getting corrupted , that is why you NEVER have the RC  transmitter on when updating the Aircraft OR the Aircraft on when updating the RC transmitter ...........You did not have the RC on when updating the used camera to your system did ya??????

[00014450]========== 2016.03.28 18:10:01. boot(15) ============
[00014487]Packet [C:\P3X_FW_V01.07.0060.bin] detected, card sn [0x6d851758].
[00014521]Packet upgrade start...

[00014560]Packet checking...
[00014603]Packet vlink 01.07.0060 <-> 01.06.0040.
[00014640]Record vlink 01.05.0030 <-> 01.04.0010 (flow = 0).
[00014678]Done.

[00014715]Version checking[1]...
[00014780][03 05][00] v34.2.0.9 -> v34.2.0.9
[00014860][03 06][00] v2.4.13.0 -> v2.4.13.0
[00014903][04 00][00] v1.41.0.0 -> v1.41.0.0
[00015020][11 00][00] v1.7.15.1 -> v1.7.15.1
[00015099][12 00][00] v1.10.0.0 -> v1.10.0.0
[00015202][12 01][00] v1.10.0.0 -> v1.10.0.0
[00015300][12 02][00] v1.10.0.0 -> v1.10.0.0
[00015400][12 03][00] v1.10.0.0 -> v1.10.0.0
[00027944][15 00][00] device not detected.***
[00028023][17 00][00] v1.1.1.7 -> v1.1.1.7
[00028143][17 01][00] v1.0.2.7 -> v1.0.2.7
[00028202][19 00][00] v1.0.8.96 -> v1.0.8.96
[00028244][01 00][00] v1.29.4920 -> v1.29.4920
[00028286][01 01][00] v1.29.4920 -> v1.29.4920
[00040820][08 00][00] device not detected.***
[00040879][09 00][00] v2.13.0.0 -> v2.13.0.0
[00040913]Packet upgrade failed at version checking.








2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

Donnie * Posted at 2017-5-7 04:16
Sounds to me like there is a corrupted video module on the X3   that was used and just purchased .  You say that you can take pics with it but get no image is that correct ?  If so then more than likely the camera would need to be sent in for repair . ( You get no video image on BOTH OF THE AIRCRAFT YOU ATTACH THIS USED X3  TO CORRECT ,  THE CAMERA IS UP TO DATE AS WELL CORRECT, if so read on . )

OK, here we go ,  you say that the latest FW is loaded to this X3 that has the problems correct ?  if so what I would do is place the Current FW that is on that X3  ( you say it is the latest FW )  and AC and load it again to  the AC via this problem camera , now you are not actually updating but you are just getting data off the SD card , now since the X3 and AC are up to date  you will only wait a few minutes and you will have the data we need, now take the SD card and load it to the Computer and look at the Hidden file , If lines of code 0800 and 1500 say " Device Not Detected " then you will need to send this camera in for repair , now way around it .  If it does not say that , then you may have another problem , let us know , but my money is on this .

ok i will check the log and get back to you with that, also let me try and better get the run down since my first does seem tad confusing.

my original inspire well call bird1, x3 1, rc1

newly puchased will be bird2, x3 2

so i can take x3 1 and attach to both bird1 and bird2 linking rc1 to either (since currently just the one) and i get image via the dji go app (also latest version) doesnt matter if using my Samsung tab S2 or my Droid turbo 2 phone

but when i take the x3 2 and attach to both bird1 and bird2 i get zero image via the app, now sometimes the screen solid black, others its black with the grey line at bottom this is present on both tab S2 and phone. can take pic and if try to view in app i see same black screen but inserting sd to comp the image shows

yes i tried to upgrade the firware with RC off and it goes a min then the loud solid BEEEEEEEEEEEP

2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

TruGreen Posted at 2017-5-7 05:12
ok i will check the log and get back to you with that, also let me try and better get the run down since my first does seem tad confusing.

my original inspire well call bird1, x3 1, rc1

I think I get this , the camera on Bird 2 will NOT work on Aircraft  ( bird ) 1 or Aircraft  ( bird ) 2 .  This camera just wont give any live video , just takes pictures and you can record  on BOTH BIRD 1 AND BIRD 2  but no live view , is that correct .
You only own the ONE  RC transmitter , I get that part .

You believe all of your Aircraft , Cameras , go app  are up to date  correct ?

So this camera is the big problem on bird 2  is that correct or did I miss something ?  
So when you tried to load the FW  via the Used Camera  on bird 2  with the problematic X3  you only get  a loud  no beat tone correct  ddddddddddddddddddddddddddddddddddddddddddddddddddddd.  
Did the previous owner tell you what version was on the camera ?  The "About " tab on the Go app is indicating that  the X3 camera is on the latest Firmware is that correct ?
The SD card should still give a log even if you are getting the Fail tone .
This sounds to me like the X3 used from bird 2 is the only problem , the  X3 from Bird 1 works fine on Bird 2 so I think the only problme here is the used X3 camera on bird 2.  This is a fairly common problem , I  cant sya for sure if the person who sold it to you did it  with the knowledge that it was broken or not, the only way to know would be to look at the log from HIS Aircraft . so hopefully you got the camera for a good deal and if DJI or the repair facddility of your choice only needs to Re load the Firmware it should be only about 50 -90  dollars, if you need  a new board, then who knows ????
****And NO you are not seeing things , I did  have the Donald Duck Avatar  but changed it to Heidi Klum , she is Much more pleasing to look at in my opinion !!




donnie





2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

correct takes pics and videos via both birds but no live view on either

correct everything is up to current FW both birds, x3s, apps, RC

correct just X3 2 is the big problem when trying to load the newest FW on DJI site it starts the regular tone then drops to a the long DDDDDDDDDDDDDDDDDDDDDDDDDDDDD shortly after

the previous owner told me he updated to the newest FW version before being sold to me included no SD card so not sure on his log info but give me a few to get outta bed and ill try to update and show the logs. and i picked up this X3 along with two TB48 batts (10 and 11 charges) for $500 so semi good deal depending how you split it haha
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

this is what i get in the hidden file log
DJI.jpg
2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

TruGreen Posted at 2017-5-7 07:11
this is what i get in the hidden file log

Just as I suspected , the only thing you could try but does not work most of the time is to rollback the firmware to version 1.9  then re install version 1.10  .    I highly doubt this will work but is the only thing I know you could try and this is what DJI will tell you also .  I would just make arrangements to send it in  myself .

sorry

donnie
2017-5-7
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

TruGreen Posted at 2017-5-6 17:14
its white the x3 for the inspire 1

Sorry about your issue. it was worth asking none the less.

Looks like Donnie is helping you and by the looks of your hidden log file the video module is corrupted #15. This mean you will need to send it back to DJI for repairs

Rich
2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

RichJ53 Posted at 2017-5-7 08:16
Sorry about your issue. it was worth asking none the less.

Looks like Donnie is helping you and by the looks of your hidden log file the video module is corrupted #15. This mean you will need to send it back to DJI for repairs

Hey Morning Rich , Looks like another corrupted video module, how many of these have  we seen .......  

By the way , you own a Z3 camera correct ?  do you know how to get to  the the calibration menu ?  I have seen this question posed many times and thought maybe you or Mark would have the answer, I know on the X5 it is on the Go app far right camera " Tool "  settings but can find any information regarding this .

If you can , here is the link to the question . You may have seen it , not sure .

http://forum.dji.com/thread-88633-1-1.html
donnie
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

Donnie * Posted at 2017-5-7 08:10
Just as I suspected , the only thing you could try but does not work most of the time is to rollback the firmware to version 1.9  then re install version 1.10  .    I highly doubt this will work but is the only thing I know you could try and this is what DJI will tell you also .  I would just make arrangements to send it in  myself .

sorry

and how would i go about that? i know how to downgrade the RC but zero idea on how to do it with the AC and X3
2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

TruGreen Posted at 2017-5-7 08:29
and how would i go about that? i know how to downgrade the RC but zero idea on how to do it with the AC and X3

Just try to load the 1.9 Fw to the Bird No 2 with the faulty camera , then it will rollback to that version , then you re load the 1.10 FW . You do it just like the regular upgrade to 1.10 but you would be loading the previous version .  

The problem is you say that it defaults to the  fail dddddddddddddddddd when you try to upgrade with the faulty  camera  so  you may not be able to do this .  

Does the "about " tab say that the camera is on the latest version of FW when you have  the entire system fired up ? ( the bird no 2 with faulty x3 )  

I would call the person you bought it from and see if they squirm at all when you tell them it does not work , see if they give you some sort of  compensation .  Might be worth a try anyway , they may indeed not know as it could have happened with your system , though I doubt it ,  long as you did not have the RC on when you were updating , this is the Number ONE cause of this .  

I would just plan on sending into ?  DJI for an estimate ,  Is it under the one year warranty by any chance ?

donnie
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

the person i got it from stated the RC was off when he did the update, the FW in the app shows the 1.10 for AC and X3. the guy i got it from is telling me to downgrade the FW on the RC then to re update it.

so im gunna try to downgrade the RC turn it off then try to down grade the AC and see what i get
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

ok put the 1.9 on a fresh formatted SD put into the faulty x3 and bird2 turn on and it does steady paced DDD_DDD_DDD_DDD followed by long DDDDDDDDDDDDDDDDDDDDD turned it off and checked the regular text file that pops and get this
dji2.jpg
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

then within the hidden log file i get this
dji3.jpg
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

same things when trying to go to 1.10

in app About still shows 1.10 for AC and X3 and 1.7 for RC

trying to downgrade RC to 1.6 just to see if that does anything
2017-5-7
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

TruGreen Posted at 2017-5-7 09:32
the person i got it from stated the RC was off when he did the update, the FW in the app shows the 1.10 for AC and X3. the guy i got it from is telling me to downgrade the FW on the RC then to re update it.

so im gunna try to downgrade the RC turn it off then try to down grade the AC and see what i get

If the guy you purchased this camera from had the original SD card then, ask him or her for the hidden file confirmation. This will tell you if the camera was successfully updated when they had it.

I always keep a copy of the file for my equipment after doing the FW updates. This is nice to have on hand when things like this happen.  Of course the new Mavic Pro, P4P and Inspire 2 do not have this same process and no hidden file to look at.

Rich
2017-5-7
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

Donnie * Posted at 2017-5-7 08:20
Hey Morning Rich , Looks like another corrupted video module, how many of these have  we seen .......  

By the way , you own a Z3 camera correct ?  do you know how to get to  the the calibration menu ?  I have seen this question posed many times and thought maybe you or Mark would have the answer, I know on the X5 it is on the Go app far right camera " Tool "  settings but can find any information regarding this .

Hello Donnie,
first of all ----- nice work on this case. Looks like another FW corrupted module (bummer) yup we have seen this a lot ... I wonder how we are going to troubleshoot the new stuff, they do not give this information anymore. The DJI assistant software does not provide a hidden log file or the Inspire 2 after updating the FW. My Mavic Pro or P4P gives me nothing to view afterwards either.

Sorry Donnie, I do not have the Z3 camera and do not have the answer to this members question.  I would think it is similar to the X5.  I don't think my P4P has this feature.... I will take a look and see

Have a great day my friend
Rich
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

well after trying everything ive been told and nothing working i sent a thing to request a fix from DJI and they already sent me a UPS shipping label. guess the X3 goes off for repairs blah more time to wait before i can sell this drone i guess
2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

TruGreen Posted at 2017-5-7 12:07
well after trying everything ive been told and nothing working i sent a thing to request a fix from DJI and they already sent me a UPS shipping label. guess the X3 goes off for repairs blah more time to wait before i can sell this drone i guess

I thought it was futile but worth a try .  Good luck with the repairs.

donnie
2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

RichJ53 Posted at 2017-5-7 10:13
Hello Donnie,
first of all ----- nice work on this case. Looks like another FW corrupted module (bummer) yup we have seen this a lot ... I wonder how we are going to troubleshoot the new stuff, they do not give this information anymore. The DJI assistant software does not provide a hidden log file or the Inspire 2 after updating the FW. My Mavic Pro or P4P gives me nothing to view afterwards either.

DJI better give   some of Us  the Inspire 2 or there out of free help  on the forum ....LOL fat chance of that happening !!

donnie
2017-5-7
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

Donnie * Posted at 2017-5-7 13:42
I thought it was futile but worth a try .  Good luck with the repairs.

donnie

thanks for trying its greatly appreciated, good thing though the repair place is like 75 miles from me in California so hopefully a quick turn around time
2017-5-7
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

Donnie * Posted at 2017-5-7 13:43
DJI better give   some of Us  the Inspire 2 or there out of free help  on the forum ....LOL fat chance of that happening !!

donnie

Funny guy. It would be awesome, but not likely my friend      By the way, I have not seen DJI Ken for awhile on the forum. Hope he is okay.
I order the DJI goggles today so some of my money for the I2 just got drained.  

If we wait a little longer the I2 V2 will be out

Rich
2017-5-7
Use props
Donnie *
Captain
Flight distance : 3636782 ft
United States
Offline

RichJ53 Posted at 2017-5-7 17:52
Funny guy. It would be awesome, but not likely my friend      By the way, I have not seen DJI Ken for awhile on the forum. Hope he is okay.
I order the DJI goggles today so some of my money for the I2 just got drained.  

Let me know how those goggles work out, I had tried the Zeiss cinemizer and could not get  acclimated to them , they kept fogging over and the fit was not good on my pumpkin head  LOL !!

Donnie

2017-5-8
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

Donnie * Posted at 2017-5-8 04:23
Let me know how those goggles work out, I had tried the Zeiss cinemizer and could not get  acclimated to them , they kept fogging over and the fit was not good on my pumpkin head  LOL !!

Donnie

I have the Fatshark HD Dominators and they are pretty good overall.  I don't like the way they fit against my forehead.  We will see how DJI stands up to the challenge (for me)

Rich
2017-5-8
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

RichJ53 Posted at 2017-5-8 07:22
I have the Fatshark HD Dominators and they are pretty good overall.  I don't like the way they fit against my forehead.  We will see how DJI stands up to the challenge (for me)

Rich

random question and off topic but the drones listed to the left above "+ Add Friend" are those there when you register your drone with DJI? or is that the longer you been posting on site?
2017-5-8
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

TruGreen Posted at 2017-5-8 07:43
random question and off topic but the drones listed to the left above "+ Add Friend" are those there when you register your drone with DJI? or is that the longer you been posting on site?

Hi TG
These are the drones registered to your DJI account / name. DJI added these features to the forum along with the flight distance but does not count your third party flight logs. Although, it does not seem very accurate in my case, flight distance is wrong and I have a OSMO not showing up.

Rich
2017-5-8
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

RichJ53 Posted at 2017-5-8 07:54
Hi TG
These are the drones registered to your DJI account / name. DJI added these features to the forum along with the flight distance but does not count your third party flight logs. Although, it does not seem very accurate in my case, flight distance is wrong and I have a OSMO not showing up.

ok thanks makes sense why mine only shows the P3 S then, as it the only one I've registered. guess i should get around to adding my P3 4K and Inspire 1
2017-5-8
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

TruGreen Posted at 2017-5-8 08:09
ok thanks makes sense why mine only shows the P3 S then, as it the only one I've registered. guess i should get around to adding my P3 4K and Inspire 1

I believe these should show up once they are activated on your DJI email  ID

Rich
2017-5-8
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

well the X3 is on its way to DJI. hopefully i dont have to wait months for it to come back
2017-5-10
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

and just got an email this afternoon from DJI that they received my X3 and will be sending out a replacement in 5-7 days
2017-5-12
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

TruGreen Posted at 2017-5-12 16:24
and just got an email this afternoon from DJI that they received my X3 and will be sending out a replacement in 5-7 days

That's great news and make sure you give DJI some positive feedback.....  


did they offer a replacement under warranty?  

Rich
2017-5-12
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

RichJ53 Posted at 2017-5-12 19:28
That's great news and make sure you give DJI some positive feedback.....  

this is the email i got.

       

Dear Customer,

The item you sent to DJI for exchange has been received. Your case No. is:

CAS-XXXXXX-XXXXXX

And your exchange is expected to be sent to you in five to seven business days. Please visit our Repair Progress Inquiry website or use the DJI Go app to view the exchange progress.

Product Details:

Product Name                                            Serial Number         Quantity
Zenmuse X3 Gimbal and Camera        WXXXXXXXXXX372        1
2017-5-12
Use props
RichJ53
Captain
Flight distance : 1773274 ft
  • >>>
United States
Offline

TruGreen Posted at 2017-5-12 19:39
this is the email i got.

       

Great.... keep us posted of your progress.

Super good news
Rich
2017-5-12
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

RichJ53 Posted at 2017-5-12 19:49
Great.... keep us posted of your progress.

Super good news

very good new, specially if it actually comes back in a week. after some of the post ive read here on months and months of waiting
2017-5-12
Use props
TruGreen
Captain
Flight distance : 518937 ft
  • >>>
United States
Offline

and just got this email:

Dear Customer,

You repair service of Inspire 1 has been quoted by our repair team. Please refer to the invoice below and complete your payment via Paypal.

Invoice

Customer:        James
Case No:        CAS-XXXXXX-XXXXXX
DJI Care Balance:       
Quote Date:        05-15-17
Remarks:        Zenmuse X3 WXXXXXXXXXX372 Technotes: No Image Feed. - Activated: 2015-06-13 (No Warranty) - No DJI care / No extended warranty records.


Item                                                 Quantity        Unit Price(USD)        Total Price(USD)
Inspire 1 Camera Main Board             1                      208.00                               208.00
Repair Service Fee                                1                        65.00/H                                  65.00
Freight:                                  15.00
Total Amount:                288.00
Discount:                         -65.00
DJI Care deduction:             0.00
Total Payment:                 223.00

Payment by Paypal:    Payment Links

Please make sure Your Case No. is included in your Payment Information when completing your transaction.
2017-5-17
Use props
DALLASFREAK
lvl.2
Flight distance : 1074957 ft
United States
Offline

Donnie, I have the same issue ....never wrecked or hard landing . I flew one battery pack and waited to fly about 30m before it was time to hit the sky again.(house Duties) before the wife gets home. This time no imagine transmission....ahhhhhh. I sent it to Drone Nerds for repair . He said my bird was it prefect condition (duh) but my camera had a software issue and they can't fix, will have to send it in to DJI. My Question is what would cause this issue if there was no updating to the complete bird just another battery.
2017-7-29
Use props
DALLASFREAK
lvl.2
Flight distance : 1074957 ft
United States
Offline

RICH/Donnie . Would it be better to just buy a new x3 Camera or get it fixed.....looks like about 210.00 for the repair (Truegreen) new camera 449.00. I also want to get the osmo...will my x3 work ......I am lost on what will and won't . I read that the firmware is different and you would have to update every time you change from the inspire 1v2 to the Osmo......The way I see it that looks like a module melt down.....
2017-7-29
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules