Please select Into the mobile phone version | Continue to access the computer ver.
Dji OSMO Black Screen and connect as an Inspired 1
930 4 2017-5-21
Uploading and Loding Picture ...(0/1)
o(^-^)o
Big Z
lvl.1

United States
Offline

I am sure  I am not the only person having this issue. My OSMO connected normally by wifi. I updated the software on the phone which is Android 4.4.4 and the firmware inside in the OSMO X3 which is OSMO Firmware v1.8.2.40. After the update,  I turn the OSMO X3 on and it turns on as normally I went to the DJI Go App to OSMO  connected as normal but the screen was Grey and Black. I backed out the App turned off the OSMO to reset it.  I turn the app back on as well as the DJI OSMO and it connects and recognized as an Inspire 1.

Is it a way to downgrade the app and the firmware?   


I have tried to:
-  Downgrade OSMO Firmware to v1.6.2.10
- I have tried to format the SD on the computer. I have formatted the card to Fat32 and exFat on the mac and windows. I used the computer because I was unable to format on the OSMO due to the DJI APP not being able to recognize the card.
- I have held down all the buttons and the OSMO power led turned red and green but nothing else happen. It still did the same thing.


The DJI OSMO is my vlogging camera. I love the OSMO but now it is just a paperweight.


Please help if you had this problem.

2017-5-21
Use props
RobertFenix
New
United States
Offline

Were you able to fix that problem?
2017-8-20
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

RobertFenix Posted at 2017-8-20 12:08
Were you able to fix that problem?

Did you encounter the same problem?
If so, please make sure the DJI Go 4 APP is closed completely when you run DJI Go.
2017-8-20
Use props
djiuser_rfy0Llx
New

Indonesia
Offline

DJI Mindy Posted at 2017-8-20 23:09
Did you encounter the same problem?
If so, please make sure the DJI Go 4 APP is closed completely when you run DJI Go.

a couple days ago, I rent a DJI Osmo from a Osmo Rent, and that was the first time i used Osmo.

I was very impressed. there was a notification that offered me to update the firmware. So, i decided to update and everything was OK. i could still record and video using the Osmo.

But, after the memory was full, it stopped recording, and after that both led indicator, the left and the right, turned on solid. Yellow for the left and green for the right one. and after that i could not use the Osmo to record and moreover, the screen on my android phone as the Osmo Monitor, turned into black. But, actually, the gimbal still worked well.
I got v1.10.2.60 version. The warranty on the Product was also expired.

DJI, could you help me please? what should I do? actually i cannot access the DJI forum. Thanks billion for the solution.
2017-10-25
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

djiuser_rfy0Llx Posted at 2017-10-25 23:16
a couple days ago, I rent a DJI Osmo from a Osmo Rent, and that was the first time i used Osmo.

I was very impressed. there was a notification that offered me to update the firmware. So, i decided to update and everything was OK. i could still record and video using the Osmo.

Sorry for the late response.
So now the left indicator is yellow and the right one for green?
Solid yellow on the left indicator means SD card error. Have you removed the footage in SD card and formatted it?
2017-10-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules