Please select Into the mobile phone version | Continue to access the computer ver.
N3 S-BUS problem
5718 15 2017-5-24
Uploading and Loding Picture ...(0/1)
o(^-^)o
LONGSHOT3506
lvl.2
Flight distance : 12052497 ft
  • >>>
South Korea
Offline

Hello I have a new dji N3 flight controller
i use Aurora9 TX and Optima SL (S-BUS) RX     [tx,rx,N3 is Latest firmware]
system work well at NAZA-V2 and NAZA-Lite But N3 doesn't work

2.png
i can't fix this problem

Thank you for time sparing to read this.
2017-5-24
Use props
NORMAP
lvl.2

Canada
Offline

Same here. I get the same readings as you have in your green box, on the red box, it only shows the absolute maximum, no gradual change. Seems no DJI staff is commenting on this.
2017-6-24
Use props
rotormedia
lvl.1
Republic of Lithuania
Offline

Same here too. But with A3 Pro FC. Problem start after latest fw update. Downgrade did not help...
2017-6-25
Use props
Orpheus
Second Officer

Russia
Offline

Got the controller in its original factory packaging. To activate barely found the Assistant2' old version. On the latest version, the activation of the controller did not pass.
Taranis X9D + X8R receiver. On rcgroups.com some peoples write that N3 works fine with with this transmitter/receiver. I talked to one of them, checked his settings, the problems did not disappear.
My problems:
SBUS not working
Can't change battery to anything other than default 6s
Large acc0 bias
Can't enable SDK function
Gains params reset to default after power off
Can't calibrate compass and IMU

Latest N3/X8R/XJT firmwares. Latest OpenTX. Latest Assistant 2.
Any ideas?
2017-10-5
Use props
WiSi-Testpilot
lvl.4

Germany
Offline

Try assistant v 1.1.2, see here:
https://www.rcgroups.com/forums/ ... ad%2A%2A%2A/page150

2017-10-5
Use props
Orpheus
Second Officer

Russia
Offline

Thank you so much. I found the version 1.1.2, reinstalled it and it all worked. Calibrating both the IMU and the compass, changing the necessary settings, everything is saved. The receiver connected by SBUS.
2017-10-5
Use props
fansa75a31ba
lvl.2
Flight distance : 39728 ft
  • >>>
Italy
Offline

WiSi-Testpilot Posted at 2017-10-5 13:19
Try assistant v 1.1.2, see here:
https://www.rcgroups.com/forums/showthread.php?2647235-Official-DJI-A3-%2A%2A%2AOwner-s-Thread%2A%2A%2A/page150

sorry, when i can download the 1.1.2 version? is it for mac or Windows? thank's
2018-1-2
Use props
fansa75a31ba
lvl.2
Flight distance : 39728 ft
  • >>>
Italy
Offline

fansa75a31ba Posted at 2018-1-2 10:09
sorry, when i can download the 1.1.2 version? is it for mac or Windows? thank's

sorry, i would write where, not when...  
2018-1-2
Use props
WiSi-Testpilot
lvl.4

Germany
Offline

Now you may use the recent version v 1.2.0 from Dec.29.
For me it works.
Best regards,
Wilhelm

https://dl.djicdn.com/downloads/ ... 81.2.0%EF%BC%89.pdf

2018-1-3
Use props
Orpheus
Second Officer

Russia
Offline

fansa75a31ba Posted at 2018-1-2 10:09
sorry, when i can download the 1.1.2 version? is it for mac or Windows? thank's

Windows version: https://dl.djicdn.com/downloads/ ... stant+2+1.1.2_2.exe
Mac version: https://dl.djicdn.com/downloads/ ... 216bf(b21de8d8).pkg
I'm using the Windows version. I do not know whether Mac version will work
2018-1-12
Use props
hazardPRO
lvl.2
United Kingdom
Offline

Hi I know this is a old thread but im having the exact same issue.

Im using Hitec Flash 7 with sBus (optima) receiver. I get the exact same results as the person on this opening ticket.

Ive tried changing N3 firmware (made no difference) and I am using Assistant 2 v1.2.4 (I cant find anywhere to download old versions?).

Ive tried on both PC and MAC.

HELP - desperately need to get this working.

H
2018-10-18
Use props
hazardPRO
lvl.2
United Kingdom
Offline

FYI seems Hitec TX/RX is not compatible.

Tried Radiolink and it works. :/

H
2018-10-23
Use props
fans2528ad72
lvl.2
Flight distance : 598360 ft
France
Offline

Hi i am having the same problem as above, i am running on FW version V 1.7.15 (i down graded ) and have tried with assistant V 1.1.2  Assistant V2 and the latest assistant but i am still having the same problem with a Futaba T10j using Sbus , it is impossible to connect the RC with the N3 even though i can see the signals working in the basic channel window where you can assign the channels
Please help
thank Craig
2019-3-7
Use props
tysonfromcanada
lvl.1

Canada
Offline

I had a similar problem, frsky X8R Pro and N3.  If I assign any channels other than the default and landing gear then the controller stays in failsafe after restarting.  The only way I could get it to work was:

On receiver page, switch receiver type from sbus to something else, and then back
This triggers calibration.  Do that
Channel 5 is flight mode by default on mine.  That should work already.
Assign channel for landing gear if it works for you
Leave IOC, return to home etc alone.  None of this stuff works after restart.
Power off/on and see if it still works.

That's it.  I can't get it to work any other way
2019-3-21
Use props
quadnet1
lvl.1

United States
Offline

Futaba T8J won't connect the my N3 SBus  please help anyone
2019-11-2
Use props
JDanilom
lvl.1

Brazil
Offline

I managed to solve the problem. I was using an existing model on my radio, I created a new one and recognized the L9R receiver.
2021-1-31
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules