Please select Into the mobile phone version | Continue to access the computer ver.
Screen is Black/OSMO works though
4944 14 2017-6-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
Gary C
lvl.4
Flight distance : 1508002 ft
  • >>>
United States
Offline

My Osmo has worked perfectly and all of a sudden my screen on my Android phone went black. The OSMO works perfectly and all functions work (except record) but when I try to link it to the DJI App, it wants to update to my OSMO mobile that isn't even on. Thoughts, comments, solutions? Many thanks!
2017-6-19
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

To resolve the No Image Transmission Error issue.Please follow the steps below to troubleshoot for it:
• check the handle contact to clean the obstacle if there is.
• remove your SD Card from your Osmo to check if the image can be recovered.
• reset Osmo system: hold down the Trigger and shutter button simultaneously, pull the Power Switch down for about 5 second, wifi password will become 12341234
•If still not working, please force your Osmo’s firmware to update: hold down the Trigger and Record button simultaneously, pull the Power Switch down for about 5 second until the right LED blinks red and green.The Osmo will detect the firmware and begin updating. The update is complete when the LED displays solid green.
DJI Go may recognize the wrong Osmo, the third step is important, please keep us updated if these step work or not.
2017-6-20
Use props
jn123
lvl.2
United States
Offline

Did you ever get your OSMO to work?
2017-7-5
Use props
Gary C
lvl.4
Flight distance : 1508002 ft
  • >>>
United States
Offline

jn123 Posted at 2017-7-5 09:40
Did you ever get your OSMO to work?

Nothing has worked....sorry for the long wait but I was overseas. I've tried both methods and nothing. It does react to gimbal movements but does not show up on the screen nor is anything recorded on the sd card. It's really frustrating because I own the mobile OSMO and that's fantastic but this OSMO , which has never been used much is just not working.
2017-7-20
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Gary C Posted at 2017-7-20 08:44
Nothing has worked....sorry for the long wait but I was overseas. I've tried both methods and nothing. It does react to gimbal movements but does not show up on the screen nor is anything recorded on the sd card. It's really frustrating because I own the mobile OSMO and that's fantastic but this OSMO , which has never been used much is just not working.

Except the image transmission, you mean there is no record in SD card? Which SD card do you use?
Have you changed another SD card to have a try? What is the right LED when you power on?
2017-7-24
Use props
GustavoRodrig
New

Brazil
Offline

Mi osmo also do the same thing. After recording 25 seconds the screen on the app goes black. I'm looking for the solution and all I've already tried. What else could I do?
IMG_5133.PNG
2017-7-25
Use props
GustavoRodrig
New

Brazil
Offline

Now I was able to record normally but only on the slow mo mode when I change it to AUTO mode and the screen went black again. Whats wrong?
2017-7-25
Use props
Gary C
lvl.4
Flight distance : 1508002 ft
  • >>>
United States
Offline

DJI Mindy Posted at 2017-7-24 02:25
Except the image transmission, you mean there is no record in SD card? Which SD card do you use?
Have you changed another SD card to have a try? What is the right LED when you power on?

I've now tried everything, and when I try to link to theDJI GO app, it only recognizes an Inspire or a Phantom 3, not the Osmo. It keeps switching back and forth automatically and you can't choose Osmo.
2017-7-31
Use props
Salty777
lvl.4
Flight distance : 117077 ft
Malaysia
Offline

I had exactly the same problem and resolved it by resetting the wifi on the Osmo. from the manual:

"If the problem persists, reset the Osmo+’s Wi-Fi network to its default settings by using the key combination and try again. (Key combination: Hold down the Trigger and Shutter Button at the same time. Then, pull the power switch down until the System Status Indicator blinks green. Release the power button before releasing the Trigger.)"
Cheers

Oops, just noticed Mindy already mentioned that....
2017-7-31
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Gary C Posted at 2017-7-31 17:44
I've now tried everything, and when I try to link to theDJI GO app, it only recognizes an Inspire or a Phantom 3, not the Osmo. It keeps switching back and forth automatically and you can't choose Osmo.

Have you also installed DJI Go 4 in your mobile phone? Please make sure DJI Go 4 is closed completely when you run DJI Go.
2017-8-1
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

GustavoRodrig Posted at 2017-7-25 17:16
Now I was able to record normally but only on the slow mo mode when I change it to AUTO mode and the screen went black again. Whats wrong?

Try to ''reset camera'' in Camera Settings.
2017-8-1
Use props
annasanders12
lvl.1

Philippines
Offline

You can also resort to hard rebooting your mobile.  This also happened to me when mobile phone went blank after connecting it to DJI.
4-26 07:49
Use props
fans7585f089
lvl.1
United States
Offline

It was happening to my Osmo Pro and after many attempts and following all advices on this forum the screen still wouldn't work. One thing I did was disconnect any cables connected to the front of the Osmo (such as the Osmo Focus Wheel in my case) and the screen magically worked, even after reconnecting the cable. So maybe this will benefit some. Cheers.
5-2 14:42
Use props
davidep
lvl.2
Flight distance : 64934 ft
Offline

Osmo plus: with Android (Xiaomi Mi9) as soon I start reconding a video after 2-3 seconds the screen becomes black and sometime disconnect from wifi going back to main menu and sometime comes back the screen and goes on to record the video. But on a iPad ios device works well!  How is possible? Any suggestion? Thank you.
10-16 15:14
Use props
jvlanna
New

Brazil
Offline

davidep Posted at 10-16 15:14
Osmo plus: with Android (Xiaomi Mi9) as soon I start reconding a video after 2-3 seconds the screen becomes black and sometime disconnect from wifi going back to main menu and sometime comes back the screen and goes on to record the video. But on a iPad ios device works well!  How is possible? Any suggestion? Thank you.

ENG: Hello, I have the same problem. Did you manage resolve?

PT-BR: Olá, eu estou com o mesmo problema. Você conseguiu resolver ?
11-19 18:26
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules