Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go 4 v 4.1.3 Forced Update
1358 1 2017-7-1
Uploading and Loding Picture ...(0/1)
Broken Deviant
Flight distance : 176919 ft
United States

I had gotten completely disgusted with the constant crashing and disconnects that we a lot of us are having to deal with in the DJI Go 4 app. I moved on to the Litchi and my Mavic and I have been very happy… until today. I started off for a little flight and barely made it to the edge of my property when I got an alert that I had reached the distance restriction. I have never had that before but thought I just needed to open the DJI Go4 app, when I tried it said YOU MUST UPDATE. I ended the flight, did the update.

Now I am back with DJI 4 that still crashes and disconnects. If I just try to take off with my Litchi app like I did before, it stops me at the distance restriction needing a login. Did the new update disable or break the ability to login through Litchi? Before this Forced Update, I did not have to start DJI Go 4 first than start Litchi. I just turned on the phone, transmitter than the Mavic Pro. The Litchi app would auto start, connect and all worked. What changed and why?

Use props
Flight distance : 246788 ft
United States

I don't know about Litchi, but I ran into the same restrictions AFTER the latest update and I have mainly used DJI Go 4 with my Mavic from the start.  Yesterday after updates, I can only ascend 98 feet and go 150 feet distance.  Rebooted checked all settings, no change.  A couple of people have suggested deleting and re-installing DJI Go 4 on my phone, but I don't want to lose my flight logs...
Use props
You need to log in before you can reply Login | Register now

Credit Rules